IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut [Débutant][Applet]Impossible de charger mon applet sous IE
    Bonjour à tous,
    j'ai un probleme avec le chargement d'une applet sous IE.
    Sous Mozilla/firefox, tout roule, mais sous IE : java.lang.ClassNotFoundException !! :@
    (Testé avec le jre de sun ET celui de microsoft .. ni l'un ni l'autre marche .. )

    Donc, j'ai ma classe toto (extends JApplet) dans son package tata ..

    et coté html :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    <applet code="tata.toto" width="100" height="100"/>
    J'arrive a lire d'autres applet que les miennes depuis mon navigateur .. et les versions de jdk/jre sont similaires ..

    J'suis sur que ca vient d'une connerie .. j'ai honte de poster ca .. mais ca me bloque comme un con ..
    Si vous avez le moindre début d'idée de piste, balancez !!!

    Merci d'avance
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  2. #2
    Membre habitué
    Profil pro
    Inscrit en
    juillet 2002
    Messages
    137
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France

    Informations forums :
    Inscription : juillet 2002
    Messages : 137
    Points : 143
    Points
    143
    Par défaut
    Juste une idée... dans IE, menu "Outils", item "Options Internet", tab "Avancé", tu as bien l'onglet coché pour dire le Java utilisé ? ( et pas celui de Microsoft )

  3. #3
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Ouep, c'est bien ce qui me desespere ... :'(
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  4. #4
    Membre habitué Avatar de soulhouf
    Inscrit en
    août 2005
    Messages
    213
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 213
    Points : 133
    Points
    133
    Par défaut

    et ta classe toto n'utilise-t-elle pas d'autres classes que tu as écrite??
    "Ce qui ne nous tue pas nous rend plus fort"
    Nietzsche

  5. #5
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Bien tenté ..
    Mais ma classe toto elle a juste sa methode init(),
    paint(Graphics g){g.drawLine(0,0,100,100);}

    raaah, c fou ca quand meme ..
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  6. #6
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Bon,
    Meme sans le package ca ne fonctionne pas .. alors que ca tourne tjr sous Mozilla ..

    j'ai juste une classe toto.class .. toute juste et toute simple .. j'ai meme fait un simple extends Applet .. (histoire que si il connait pas JApplet on gagne du temps ..) et toujours rien ..

    Personne n'a l'ombre d'un début d'idée ?
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  7. #7
    Membre habitué Avatar de soulhouf
    Inscrit en
    août 2005
    Messages
    213
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 213
    Points : 133
    Points
    133
    Par défaut
    c'est à arracher les cheveux ton histoire
    tu peux nous faire voir le code de ton applet et ton html stp?
    "Ce qui ne nous tue pas nous rend plus fort"
    Nietzsche

  8. #8
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    import java.applet.Applet;
    import java.awt.Graphics;
     
    public class toto extends Applet  {
     
            public void init(){
     
            }
            public void paint(Graphics g){
                    g.drawLine(0,0,100,100);
                    this.setSize(100,100);
     
            }
    }
    et

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    <applet code='toto'  codebase='/ResultatsPlan/' width='800' height='300'/>
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  9. #9
    Membre habitué Avatar de soulhouf
    Inscrit en
    août 2005
    Messages
    213
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 213
    Points : 133
    Points
    133
    Par défaut
    d'abord stp yu utiliser les balises "code" c'est plus lisible.
    je crois que:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    codebase='/ResultatsPlan/'
    ne sert à rien

    parce que tu n'as pas un jar mais ça n'empèche pas de le faire fonctionner sous IE quand même
    essaie de l'enlever pour voir.
    "Ce qui ne nous tue pas nous rend plus fort"
    Nietzsche

  10. #10
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Quelle balise est plus clair ??
    J'ai pas compris :s
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  11. #11
    Membre habitué Avatar de soulhouf
    Inscrit en
    août 2005
    Messages
    213
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 213
    Points : 133
    Points
    133
    Par défaut
    je voulais te dire quand tu inseres un code sur le forum pense à utiliser les balises [code] (fais juste un click sur le bouton "code" au dessus du champ du texte quand tu postes un message)
    "Ce qui ne nous tue pas nous rend plus fort"
    Nietzsche

  12. #12
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Arf, désolé ..

    Sinon, même sans le codebase ca chie des bulles ..
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  13. #13
    Membre habitué Avatar de soulhouf
    Inscrit en
    août 2005
    Messages
    213
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 213
    Points : 133
    Points
    133
    Par défaut
    sinon quelle version de IE tu utilises?
    "Ce qui ne nous tue pas nous rend plus fort"
    Nietzsche

  14. #14
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    IE 6.0.2880 et JRE 1.4.2

    J'ai mm tenté un javac -target 1.1 toto.java .. mais mm avec ca : pan, rien
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  15. #15
    Membre habitué Avatar de soulhouf
    Inscrit en
    août 2005
    Messages
    213
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 213
    Points : 133
    Points
    133
    Par défaut
    dans ce cas là je dirai que ton IE a un problème car il n'y a aucune raison pour que ça marche pas
    "Ce qui ne nous tue pas nous rend plus fort"
    Nietzsche

  16. #16
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Je tenterai de dire non car j'arrive à lire d'autres applet ..
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  17. #17
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Nouveau test tenté ..
    Compiler avec -target 1.1 et en repassant avec le plugin de ms .. et la ca marche ..

    Pq la jvm de sum marche pas boudiou ?? !!!
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  18. #18
    Membre habitué Avatar de soulhouf
    Inscrit en
    août 2005
    Messages
    213
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 213
    Points : 133
    Points
    133
    Par défaut
    je crois que je comprends maintenant, vu que chaque navigateur a sa propre JVM c'est normal que la jvm de sun ne marche pas sous IE.
    même Mozilla ou Firefox n'utilisent pas la même jvm que celle installée sur ton ordi.
    "Ce qui ne nous tue pas nous rend plus fort"
    Nietzsche

  19. #19
    Candidat au Club
    Profil pro
    Inscrit en
    juin 2003
    Messages
    11
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 11
    Points : 2
    Points
    2
    Par défaut
    Hum ..
    Je te raconte d'ou ca venait, et ensuite je pars me cacher en courant ..

    En fait, mozilla semble tres tres bien gérer le codebase .. mais IE nettement moins ..
    Donc en mettant le chemin complet dans archive et sans mettre de codebase .. plouf plouf miracle, une zolie applet qui fonctionne

    Merci de ton temps passé ..

    A bientot peut etre
    N'oubliez jamais que, quoi qui se passe, je resterai toujours plus con que vous ! -=Dibus=-

  20. #20
    Membre habitué Avatar de soulhouf
    Inscrit en
    août 2005
    Messages
    213
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 213
    Points : 133
    Points
    133
    Par défaut
    l'essentiel est que ça marche maintenant 8)
    "Ce qui ne nous tue pas nous rend plus fort"
    Nietzsche

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Impossible de charger un applet
    Par ticroch dans le forum Applets
    Réponses: 0
    Dernier message: 25/04/2013, 07h24
  2. Appel à une servlet depuis mon applet impossible
    Par gsphere dans le forum Applets
    Réponses: 2
    Dernier message: 09/01/2011, 19h11
  3. [ZF 1.9] Autoloader : impossible de charger mon formulaire
    Par Invité dans le forum MVC
    Réponses: 8
    Dernier message: 01/12/2009, 14h39
  4. [Crystal Report] Impossible de charger mon dataset
    Par koyot3 dans le forum Windows Forms
    Réponses: 0
    Dernier message: 13/01/2009, 10h16
  5. impossible de lancer mon jar sous kubuntu
    Par altadeos dans le forum NetBeans
    Réponses: 2
    Dernier message: 14/11/2006, 13h45

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo