Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre à l'essai
    Comment compiler en 64 bits avec gcc, -m64 ne marche pas.
    Bonjour,

    Je crois que tout est dans le sujet.

    Je suis débutant sous Unix, et débutant en C.

    J'essai de compiler une librairie native sous Unix, hp-ux.
    J'ai trouvé l'option -m64 mais il en veux pas.
    Il me répond ca :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    > gcc -c cdfNativeLibrary.c -I${CDF_BASE}/include -I/opt/java1.4/include/ -I/opt/java1.4/include/hp-ux/ -m64
    cc1: Invalid option `64'


    Quelqu'un peut_il m'aider ?

    Merci,

  2. #2
    Membre habitué
    http://www.network-theory.co.uk/docs...cintro_65.html
    http://gcc.gnu.org/ml/gcc-help/2008-.../msg00261.html

    If you have 64-bit OS (uname shows x86-64), your gcc defaults to 64-bit
    mode, unless you set -m32. The code fragment you quote appears designed
    to throw an assertion failure, if data types don't default to expected
    sizes. If they wanted a 32-bit unsigned integer, there are standard C
    data types for that.
    Il est dit que nativement gcc est en 64 bit et qu'il est nécessaire de mettre l'option -m32 pour le forcer en 32bits.

    Ce qui veut sûrement dire d'en ton cas qu'il est nécessaire d'avoir la dernière où plus récente mise à jour de gcc. ( ou que tu n'as pas un système 64bits ou un matériel 64bits )

    http://gcc.gnu.org/
    "Quand le monde est dangereux, l'humilité est un facteur de longévité." ( Baxter "Evolution" )