IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Futur Membre du Club
    Profil pro
    Inscrit en
    avril 2007
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 12
    Points : 5
    Points
    5
    Par défaut [débogage] error PRJ0003 : Erreur lors de la génération dynamique de 'cmd.exe'
    A chaque fois que je lance un debogage j'otiens l'erreur suivante:

    Projet : error PRJ0003 : Erreur lors de la génération dynamique de 'cmd.exe'.
    Le journal de génération a été enregistré à l'emplacement "file://c:\Documents and Settings\Famille MARPAUD\Mes documents\Visual Studio 2005\Projects\web\web\Debug\BuildLog.htm"
    web - 1 erreur(s), 0 avertissement(s)
    ========== Génération*: 0 a réussi, 1 a échoué, 0 mis à jour, 0 a été ignoré ==========
    je suis dans un projet:"aplication console win32" et j'utiliser le code:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    #include <iostream>
    using namespace std;
    int main()
    {
    cout<<"bonjour"<<endl;
    system("pause");
    return 0;
    }
    après cette erreur le code s'execute normalement.
    Pourqoi cette erreur?

  2. #2
    Expert éminent sénior
    Avatar de Médinoc
    Homme Profil pro
    Développeur informatique
    Inscrit en
    septembre 2005
    Messages
    27 194
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2005
    Messages : 27 194
    Points : 40 763
    Points
    40 763
    Par défaut
    Tu auras sûrement plus d'infos sur l'erreur dans le fichier BuildLog.htm...

    PS: Elle est vraiment, mais alors vraiment pourrie la traduction Française de Visual... Je me demande quel est le gogo qui a pondu un truc pareil...
    SVP, pas de questions techniques par MP. Surtout si je ne vous ai jamais parlé avant.

    "Aw, come on, who would be so stupid as to insert a cast to make an error go away without actually fixing the error?"
    Apparently everyone.
    -- Raymond Chen.
    Traduction obligatoire: "Oh, voyons, qui serait assez stupide pour mettre un cast pour faire disparaitre un message d'erreur sans vraiment corriger l'erreur?" - Apparemment, tout le monde. -- Raymond Chen.

  3. #3
    Futur Membre du Club
    Profil pro
    Inscrit en
    avril 2007
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 12
    Points : 5
    Points
    5
    Par défaut reponse de BuildLog.htm
    je suis allé sur le lien du debogage mais je n'obtiens pas la raison du
    problème
    j'ai comme page:
    Journal de génération Générer démarrée : Projet : web, Configuration : Debug|Win32
    Lignes de commande Création du fichier temporaire "c:\Documents and Settings\Famille MARPAUD\Mes documents\Visual Studio 2005\Projects\web\web\Debug\RSP00000136443484.rsp" avec pour contenu
    [
    /out:".\Debug\web.exe.embed.manifest" /notify_update /manifest

    ".\Debug\web.exe.intermediate.manifest"
    ]
    Création de la ligne de commande "mt.exe @"c:\Documents and Settings\Famille MARPAUD\Mes documents\Visual Studio 2005\Projects\web\web\Debug\RSP00000136443484.rsp" /nologo"
    Création du fichier temporaire "c:\Documents and Settings\Famille MARPAUD\Mes documents\Visual Studio 2005\Projects\web\web\Debug\BAT00000236443484.bat" avec pour contenu
    [
    @echo La ressource de manifeste a été mise à jour pour la dernière fois à %TIME% le %DATE% > ".\Debug\mt.dep"
    ]
    Création de la ligne de commande """c:\Documents and Settings\Famille MARPAUD\Mes documents\Visual Studio 2005\Projects\web\web\Debug\BAT00000236443484.bat"""
    Fenêtre Sortie Incorporation du manifeste en cours...
    Projet : error PRJ0003 : Erreur lors de la génération dynamique de 'cmd.exe'.
    Résultats Le journal de génération a été enregistré à l'emplacement "file://c:\Documents and Settings\Famille MARPAUD\Mes documents\Visual Studio 2005\Projects\web\web\Debug\BuildLog.htm"
    web - 1 erreur(s), 0 avertissement(s)

  4. #4
    Membre éprouvé Avatar de Spout
    Profil pro
    Ingénieur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    904
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux

    Informations forums :
    Inscription : février 2007
    Messages : 904
    Points : 975
    Points
    975
    Par défaut
    Je pense que ton problème vient des options de ton projet, soit dans l'"étape de génération personalisée", soit dans le chemin de sortie de ton projet. Il faut que tu regardes bien les options de ton projet pour voir si tous ces répertoires existent bien sur ton PC.
    "L'ordinateur obéit à vos ordres, pas à vos intentions." [Anonyme]

  5. #5
    Futur Membre du Club
    Profil pro
    Inscrit en
    avril 2007
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 12
    Points : 5
    Points
    5
    Par défaut reponse
    j'ai verifié il me semble que l'erreur ne vient pas de là.
    Peut t-elle venir des variables de l'environnement de travail?
    (path,classpath,dans le panneau de configuration -> système)

  6. #6
    Membre éprouvé Avatar de Spout
    Profil pro
    Ingénieur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    904
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux

    Informations forums :
    Inscription : février 2007
    Messages : 904
    Points : 975
    Points
    975
    Par défaut
    Je pense que si une variable d'envirronnement étati manquante ou mal configurée, il te dirait directement celle qu'il a pas trouvé (Visual 2003 le fait lui). Donc je ne pense pas que ce soit ton problème.
    Je ne pense pas que ton code soit faux, donc pour moi je persiste à dire que c'est une option de ton projet qui ne doit pas être bonne. Je te conseille de bien tout vérifier méticuleusement.
    Bon courage
    "L'ordinateur obéit à vos ordres, pas à vos intentions." [Anonyme]

  7. #7
    Futur Membre du Club
    Profil pro
    Inscrit en
    avril 2007
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 12
    Points : 5
    Points
    5
    Par défaut reponse
    desolé,je ne vois pas d'erreur

  8. #8
    Membre éprouvé Avatar de Spout
    Profil pro
    Ingénieur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    904
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux

    Informations forums :
    Inscription : février 2007
    Messages : 904
    Points : 975
    Points
    975
    Par défaut
    Comment se nomme ton projet? et l'exécutable de sortie?
    "L'ordinateur obéit à vos ordres, pas à vos intentions." [Anonyme]

  9. #9
    Futur Membre du Club
    Profil pro
    Inscrit en
    avril 2007
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 12
    Points : 5
    Points
    5
    Par défaut reponse
    Mon projet se nomme web et l'executable de sortie se nomme:
    web.exe

  10. #10
    Membre éprouvé Avatar de Spout
    Profil pro
    Ingénieur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    904
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux

    Informations forums :
    Inscription : février 2007
    Messages : 904
    Points : 975
    Points
    975
    Par défaut
    La seule ambiguité que je ne comprends pas, en dehors des problèmes de chemin, est le fait que lorsqu'il créée la ligne de commande BAT00000236443484.bat, il utilise un mt.dep alors qu'il a créé une autre ligne de commande mt.exe.
    Je ne m'y connais pas assez pour dire si c'est normal ou non. Peut être que le mt.dep découle directement du mt.exe.
    Quoiqu'il en soit, je ne suis pas en mesure de t'aider.
    Désolé et bon courage tout de même pour trouver!
    "L'ordinateur obéit à vos ordres, pas à vos intentions." [Anonyme]

  11. #11
    Futur Membre du Club
    Profil pro
    Inscrit en
    avril 2007
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 12
    Points : 5
    Points
    5
    Par défaut reponse
    Merci,j'espère que quelqu'un d'autre va m'aider.

  12. #12
    Futur Membre du Club
    Profil pro
    Inscrit en
    avril 2007
    Messages
    12
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2007
    Messages : 12
    Points : 5
    Points
    5
    Par défaut La solution
    J'ai trouvé l'erreur elle venait des variables d'environements

  13. #13
    Membre éprouvé Avatar de Spout
    Profil pro
    Ingénieur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    904
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux

    Informations forums :
    Inscription : février 2007
    Messages : 904
    Points : 975
    Points
    975
    Par défaut
    Il ne trouvait pas une variable? C'est bizarre, lorqu'il ne trouve pas la variable d'environnement, il l'affiche à la toute fin du rapport d'erreur... Je suis curieux de comprendre, peux-tu m'en dire un peu plus?
    "L'ordinateur obéit à vos ordres, pas à vos intentions." [Anonyme]

  14. #14
    Candidat au Club
    Profil pro
    Inscrit en
    février 2008
    Messages
    3
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 3
    Points : 3
    Points
    3
    Par défaut
    Citation Envoyé par DEBUTANTc++ Voir le message
    J'ai trouvé l'erreur elle venait des variables d'environements
    Bonjour,
    J'ai le même problème, si tu peux détailler ta procédure pour le régler, merci d'avance!

  15. #15
    Membre éprouvé Avatar de Spout
    Profil pro
    Ingénieur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    904
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux

    Informations forums :
    Inscription : février 2007
    Messages : 904
    Points : 975
    Points
    975
    Par défaut
    Sur mon PC: j'ai les variables d'environnement suivantes (VC71):

    INCLUDE : (ton répertoire d'instal de visual)\V71\SDK\v1.1\include\
    LIB : (ton répertoire d'instal de visual)\V71\SDK\v1.1\lib\
    VS71COMNTOOLS : (ton répertoire d'instal de visual)\V71\Common7\Tools\

    Je suppose que son problème était que l'une d'elle n'était pas bonne...

    NOTE: il faut relancer Visual pour que les modifs de variables d'environnement soient prises en compte.
    "L'ordinateur obéit à vos ordres, pas à vos intentions." [Anonyme]

  16. #16
    Candidat au Club
    Profil pro
    Inscrit en
    février 2008
    Messages
    3
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2008
    Messages : 3
    Points : 3
    Points
    3
    Par défaut
    Citation Envoyé par spoutspout Voir le message
    Sur mon PC: j'ai les variables d'environnement suivantes (VC71):

    INCLUDE : (ton répertoire d'instal de visual)\V71\SDK\v1.1\include\
    LIB : (ton répertoire d'instal de visual)\V71\SDK\v1.1\lib\
    VS71COMNTOOLS : (ton répertoire d'instal de visual)\V71\Common7\Tools\

    Je suppose que son problème était que l'une d'elle n'était pas bonne...

    NOTE: il faut relancer Visual pour que les modifs de variables d'environnement soient prises en compte.
    Merci bcp spoutspout, mais ça fonctionne toujours pas!

  17. #17
    Membre éprouvé Avatar de Spout
    Profil pro
    Ingénieur systèmes et réseaux
    Inscrit en
    février 2007
    Messages
    904
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux

    Informations forums :
    Inscription : février 2007
    Messages : 904
    Points : 975
    Points
    975
    Par défaut
    Peut-être que ces deux liens pourront t'aider:
    notamment la variable PATH si toutes les autres sont bonnes.
    "L'ordinateur obéit à vos ordres, pas à vos intentions." [Anonyme]

  18. #18
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    mars 2008
    Messages
    1
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2008
    Messages : 1
    Points : 1
    Points
    1
    Par défaut
    Perso, j'ai eu le même problème, et j'ai pu le résoudre en rajoutant C:\Windows\Microsoft.NET\Framework\v1.1.4322\ dans la variable d'environnement système PATH.

    Après la modif de la variable, il faut fermer Visual et le relancer.

    J'ai trouvé en comparant avec le meme projet qui compilait sur 1 autre PC.
    Apparemment, c'est pendant les mises à jour que çà a changé ...

  19. #19
    Membre éclairé
    Avatar de mamelouk
    Profil pro
    Inscrit en
    mai 2005
    Messages
    867
    Détails du profil
    Informations personnelles :
    Localisation : France, Rhône (Rhône Alpes)

    Informations forums :
    Inscription : mai 2005
    Messages : 867
    Points : 810
    Points
    810
    Par défaut
    moi dans mon cas j'ai résolu le problème en ajoutant c:/windows/system32 aux répertoires standard de visual studio

    lol

    Débugger du code est deux fois plus dur que d'en écrire.
    Donc, si vous écrivez votre code aussi intelligemment que vous le pouvez, vous n'etes, par définition, pas assez intelligent pour le débugger.

  20. #20
    Nouveau Candidat au Club
    Profil pro
    Inscrit en
    décembre 2009
    Messages
    1
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2009
    Messages : 1
    Points : 1
    Points
    1
    Par défaut Pour VS 2008 et Windows Seven
    Salut,

    J'ai eu le même problème il n'y a pas longtemps, et cela venais que l'on ne pouvait pas appeler mt.exe depuis la console (exécution batch) sans faire un cd "chemin\de\mt.exe" Malgré l'inclusion dans la variable PATH de ce chemin. Par contre si l'on lance cmd.exe , cela marche sans problème, donc il faut créer un fichier .bat dans votre dossier Release puis ajouter dans VS Menu Projet->Propriétés. Dans la fenêtre suivante Propriété de génération-> Evènements de génération->Evènement après génération et mettre dans la ligne commande le chemin de votre .bat .
    Dans mon .bat, pour moi , il y a:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    cd "D:\Program Files\Microsoft SDKs\Windows\v7.0\Bin"
    mt /outputresource:"D:\Users\sywesk\Documents\Visual Studio 2008\Projects\Sytech\Release\Sytech.exe;#1" /manifest "D:\Users\sywesk\Documents\Visual Studio 2008\Projects\Sytech\Release\Sytech.exe.intermediate.manifest" /nologo
    Le chemin de cd varie selon votre SDK. Pour moi c'est le SDK v7.0 pour windows 7.
    Pour trouver la ligne de commande à exécuter, regardez votre buildlog.html et comparez a ma ligne de commande , vous trouverez tout de suite.

    @+ !
    PS : Je sais que le post date de 2007, mais on ne sait jamais, ça peut servir!

+ Répondre à la discussion
Cette discussion est résolue.
Page 1 sur 2 12 DernièreDernière

Discussions similaires

  1. Réponses: 1
    Dernier message: 03/12/2009, 16h27
  2. Réponses: 7
    Dernier message: 02/08/2006, 08h54

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo