IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

PHP & Base de données Discussion :

Répondre à un envoi de formulaire


Sujet :

PHP & Base de données

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    mai 2021
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : mai 2021
    Messages : 2
    Points : 1
    Points
    1
    Par défaut Répondre à un envoi de formulaire
    Bonjour à tous et toutes, je me présente rapidement, Mike 40ans de Belgique, je découvre petit à petit le PHP et j'ai créé mon premier script pour envoyer un formulaire de contact par mail. J'ai fais quelques recherches mais ne parviens pas à trouver mon bonheur (soit je fais mal ma recherche soit je ne comprends vraiment rien), c'est pour cela que je crée cette discussion. Je m'excuse d'avance pour le doublon éventuel que ce post pourrait faire

    Après avoir chargé le site, je parviens à envoyer le formulaire, je le reçois également les informations sur l'adresse mail saisie mais deux questions se posent à moi :

    1°) lorsque le formulaire est complété, je ne comprends pas comment faire pour que le script dise "Merci (éventuellement récupérer le prénom de l'expéditeur), votre formulaire a bien été envoyé." et d'y ajouter un bouton de retour à la page d'accueil

    2°) seconde question, quelqu'un pourrait-il également m'aider pour l'utilisation de la fonction htmlspecialchars car j'ai fait plusieurs manipulations et essais et rien ne fonctionne :/ Je suis un simple débutant en la matière, veuillez m'excuser du manque de connaissances en PhP

    Merci d'avance pour vos réponses et votre aide

    Voici la copie de mon script fonctionnel (j'ai volontairement remplacé l'adresse mail par des *** pour des raisons de sécurité comme vous vous en doutez) :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    <?php
     
    $to = "info@***.be";
    $from = $_REQUEST['email'];
    $name = $_REQUEST['name'];
    $fname = $_REQUEST['fname'];
    $number = $_REQUEST['number'];
    $cmessage = $_REQUEST['message'];
     
    $headers = "From: $from";
    $headers = "From: " . $from . "\r\n";
    $headers .= "Reply-To: ". $from . "\r\n";
    $headers .= "MIME-Version: 1.0\r\n";
    $headers .= "Content-Type: text/html; charset=utf-8\r\n";
     
    $subject = "Message du site *****.";
     
    $logo = 'images/logo2.png';
    $link = '#';
     
    $body = "<!DOCTYPE html><html lang='fr'><head><meta charset='UTF-8'><title>Express Mail</title></head><body>";
    $body .= "<table style='width: 100%;'>";
    $body .= "<thead style='text-align: center;'><tr><td style='border:none;' colspan='2'>";
    $body .= "<a href='{$link}'><img src='{$logo}' alt=''></a><br><br>";
    $body .= "</td></tr></thead><tbody><tr>";
    $body .= "<td style='border:none;'><strong>Nom:</strong> {$name}</td>";
    $body .= "<td style='border:none;'><strong>Prénom:</strong> {$fname}</td>";
    $body .= "<td style='border:none;'><strong>Email:</strong> {$from}</td>";
    $body .= "<td style='border:none;'><strong>Téléphone:</strong> {$number}</td>";
    $body .= "</tr>";
    $body .= "<tr><td style='border:none;'><strong>Message:</strong> {$csubject}</td></tr>";
    $body .= "<tr><td></td></tr>";
    $body .= "<tr><td colspan='2' style='border:none;'>{$cmessage}</td></tr>";
    $body .= "</tbody></table>";
    $body .= "</body></html>";
     
    $send = mail($to, $subject, $body, $headers);
     
    ?>

  2. #2
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    8 114
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 8 114
    Points : 12 632
    Points
    12 632
    Par défaut
    pour la 1re question, vous pouvez rediriger vers une page à la fin de votre code comme cela :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    header("Location: https://serveur/repertoire/message_bien_envoye.php");
    exit();
    pour la 2e question, je ne suis pas sur d'avoir tout compris. mais si cela n'a rien à voir avec l'affichage du message "e-mail envoyé", vous pouvez créer une nouvelle discussion pour expliquer le souci, montrer le code que vous avez essayé et expliquer le résultat souhaité.

  3. #3
    Nouveau Candidat au Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    mai 2021
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : mai 2021
    Messages : 2
    Points : 1
    Points
    1
    Par défaut
    Merci Mathieu pour ta réponse, je vais modifier et tester cela de suite

    Concernant la seconde question, c'est de voir comment je dois procéder pour utiliser la fonction htmlspecialchars car je ne comprends pas trop

Discussions similaires

  1. [HTML] Envoi dun formulaire avec un lien au lieu d'un bouton
    Par Mysticlolly dans le forum Balisage (X)HTML et validation W3C
    Réponses: 8
    Dernier message: 19/05/2010, 12h30
  2. Réponses: 5
    Dernier message: 23/10/2005, 17h34
  3. Probleme d'envoie de formulaire
    Par wollverine dans le forum Balisage (X)HTML et validation W3C
    Réponses: 6
    Dernier message: 02/02/2005, 16h29
  4. [HTML] Problème d'envoi de formulaire
    Par autumn319 dans le forum ASP
    Réponses: 26
    Dernier message: 03/09/2003, 10h06

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo