Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Nouveau membre du Club
    Carateres speciaux dans script via transfert ftp
    Bonjour,

    Quand je transfere un script ksh via filezilla, le carate ^M se retrouve ajouté a la fin de chaque ligne alors que sous Notepad dans windows il n'y en a pas.

    Comment faire ?


    Merci

  2. #2
    Expert éminent sénior
    Bonjour

    La fin de ligne de fichiers texte est différente sur Windows, Apple, et Unix/Linux.
    Windows : CR LF Carriage Return Line Feed, "\r\n", 0d0a en hexa.
    Apple : CR Carriage Return, "\r", 0d en hexa.
    Linux : LF Line Feed, "\n", 0a en hexa.

    le carate ^M se retrouve ajouté a la fin de chaque ligne
    Je voudrais bien savoir comment tu le sais puisque Windows n'affiche rien et Unix interprète \r. Comment fais-tu afficher ^M ?

    Quoiqu'il en soit, il faut modifier cette fin de ligne.

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    sed -i 's/\r$//' fichier.ksh
    Cette réponse vous apporte quelque chose ? Cliquez sur en bas à droite du message.

  3. #3
    Nouveau membre du Club
    merci pour la solution.

    EN fait je m'en suis sorti en faisant un FTP en ligne de commande avec l'option bin. C'est le file trasfert filezilla qui engendrait cela je pense.

###raw>template_hook.ano_emploi###