Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Servlets/JSP Java Discussion :

Problème d'accès à des fichiers uploadés


Sujet :

Servlets/JSP Java

  1. #1
    Futur Membre du Club
    Problème d'accès à des fichiers uploadés
    Bonjour,
    je développe actuellement un prototype sous Eclipse, Tomcat et Java 7, dans lequel j'utilise un formulaire d'enregistrement pour renseigner des données textuelles et aussi uploader des images. Tout se passe bien, y compris l'upload des images avec commons-fileupload (les fichiers sont visibles dans le répertoire cible qui se trouve dans un répertoire "web/images" du projet Eclipse) mais ces images ne sont pas accessibles (et donc pas affichables) avant d'avoir réalisé un refresh à la main du répertoire "images" en question !

    Je voudrai que sitôt après l'upload, les fichiers image soient visibles par Tomcat, car après cet enregistrement ma servlet redirige vers une page qui affiche les données que je viens d'entrer, y compris les images uploadées. Avez-vous une idée de comment régler le problème ?

    Merci d'avance,

  2. #2
    Membre émérite
    Salut,

    J'avais posé exactement la même question que la tienne mais personne ne m'a répondu, sauf que moi j'utilise jQuery.ajax pour transmettre les images et j'ai remarqué qu'elles ne peuvent pas être accessible par tomcat seulement si tu les enregistre encore une fois dans le dossier build/web/images.

    C'est l'occasion pour éclaircir tout ça, je me demande si on est toujours obligé d'enregistrer les images dans deux endroits, le 1er est le dossier web/images et le deuxième est build/web/images.

  3. #3
    Futur Membre du Club
    Merci pour ta réponse

    C'est un comportement étrange et embêtant puisqu'en principe, on ne peut accéder aux fichiers en dehors de la webapp pour des questions de sécurité.

    Je vais tester ta manip'. Je vais essayer de ne les copier que dans le répertoire build/web/images dans un premier temps, même si j'imagine que tu as fait le même genre de test

    Je me demande si ce problème n'est pas spécifique à un Tomcat sous Eclipse... Peut-être ne retrouve-t-on pas ce problème en production. Je vais tester dès que possible.

  4. #4
    Membre émérite
    Tu as compris la manipulation oui, j'ai commencé par mettre une balise
    Code html :Sélectionner tout -Visualiser dans une fenêtre à part
    <img src="images/nom_image" />
    dans une page jsp, et quand je supprime l'image du dossier build/web/images elle est introuvable même si elle existe bien dans web/images.