IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Code::Blocks Discussion :

Problème de compilateur avec Code::Blocks


Sujet :

Code::Blocks

  1. #1
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2019
    Messages
    32
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2019
    Messages : 32
    Points : 10
    Points
    10
    Par défaut Problème de compilateur avec Code::Blocks
    Bonsoir.

    Je me rends bien sur le site de Code::Blocks, onglet Download the binary release, puis partie Windows XP/Vista/7/8.x/10 et je télécharge codeblocks-17.12mingw_fortran-setup.exe pour tout avoir, je lance le .exe, j'installe. Tout s'est bien passé jusqu'à présent.
    Je débute sur C et donc je crée un nouveau projet sur console d'application, je coche les deux cases qui s'offrent à moi après l'insertion du nom de projet. Je trouve un fichier main.c et quand j'essaye de le compiler et de l'exécuter, le message suivant s'affiche :

    Project/Target: "New - Debug":
    The compiler's setup (GNU GCC Compiler) is invalid, so Code::Blocks cannot find/run the compiler.
    Probably the toolchain path within the compiler options is not setup correctly?!
    Do you have a compiler installed?
    Goto "Settings->Compiler...->Global compiler settings->GNU GCC Compiler->Toolchain executables" and fix the compiler's setup.

    Tried to run compiler executable 'C:\MinGW/bin/mingw32-gcc.exe', but failed!

    Skipping...
    Nothing to be done (all items are up-to-date).

    Et juste au lancement de Code::Blocks, j'avais eu le message d'erreur ju :
    Environment error : Can't find compiler executable in your configured search path's for GNU GCC Compiler.
    Je suis débutant comme je l'ai précisé avant, et je n'ai aucune idée d'où peut provenir le problème. Je ne comprends pas la nature du problème aussi, je pense que tout ce qui est en relation avec PATH pose problème car j'avais essayé d'installer Anaconda pour Python et j'avais un problème de créations de menus lors de l'installation et lorsque j'ai cherché j'ai trouvé que c'était quelque chose en relation avec ce "PATH" mais j'ai abandonné la recherche de solution car Pyzo avait marché...

    J'espère que vous pourrez m'aider afin que je puisse débuter ma programmation tranquillement.

  2. #2
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    septembre 2019
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Bénin

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Industrie

    Informations forums :
    Inscription : septembre 2019
    Messages : 2
    Points : 3
    Points
    3
    Par défaut
    Euh... effectivement, j'ai aussi le même problème.
    En effet, le mien a débuté depuis que j'ai changer de poste et j'avoue que je n'ai pas tellement progresser (avec celui installer sur l'ancien poste). Ce qui m'étonne le pus est que c'est le même Block::code que j'ai installer sur le nouveau poste et il ne marche pas. J'ai dû le télécharger à nouveau mais le problème persiste. Enfin bref, si t'as déjà trouvé une solution à ce problème, aide-moi.

  3. #3
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    septembre 2019
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Bénin

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Industrie

    Informations forums :
    Inscription : septembre 2019
    Messages : 2
    Points : 3
    Points
    3
    Par défaut Solution
    J'ai la solution !!!
    C'était pourtant très simple. Il suffit de faire
    settings>compiler>Global compiler settings et dans la fenêtre qui s'ouvre, cliqué sur "Reset defaults"

Discussions similaires

  1. Problème de compilation avec Code Block
    Par med19972004 dans le forum Code::Blocks
    Réponses: 2
    Dernier message: 16/09/2011, 16h32
  2. Problème de compilation avec Code::Blocks
    Par xvid110 dans le forum OpenCV
    Réponses: 12
    Dernier message: 13/06/2011, 23h12
  3. Problème de compilation avec Code Block
    Par med19972004 dans le forum C++
    Réponses: 5
    Dernier message: 04/02/2011, 23h49
  4. Problème de fonctionnement avec Code::Blocks
    Par turbo225 dans le forum Code::Blocks
    Réponses: 1
    Dernier message: 20/12/2008, 12h14
  5. Problème de librairie avec code blocks sous Linux
    Par philmor34 dans le forum Code::Blocks
    Réponses: 1
    Dernier message: 31/10/2008, 13h25

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo