Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Raspberry Pi Discussion :

Changer de version de Lazarus


Sujet :

Raspberry Pi

  1. #1
    Membre confirmé
    Avatar de ChPr
    Homme Profil pro
    Inscrit en
    septembre 2005
    Messages
    1 331
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 73
    Localisation : France, Val d'Oise (Île de France)

    Informations forums :
    Inscription : septembre 2005
    Messages : 1 331
    Points : 567
    Points
    567
    Par défaut Changer de version de Lazarus
    Bonjour à toutes et à tous,

    Sur mon Raspberry Pi 3B, j'ai installé Lazarus 1.6.2 qui était dans les dépôts (je ne me souviens plus de la procédure, mais rien de particulier sinon qu'une simple commande).

    Pour harmoniser mes versions, je souhaite installer la version 1.6.4 que j'ai par ailleurs sur mon PC sous Windows et sous Ubuntu.

    Je suppose que c'est cette version qu'il faut que je télécharge.

    Je suppose aussi qu'il faut que je supprime totalement la version installée (fichiers de configuration compris). Comment fait-on ?

    Et aussi, après avoir téléchargé les fichiers *.deb, comment fait-on pour les installer ?

    Merci de votre aide.

    Pierre

  2. #2
    Expert éminent sénior
    Avatar de Auteur
    Profil pro
    Inscrit en
    avril 2004
    Messages
    7 193
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 7 193
    Points : 10 065
    Points
    10 065
    Par défaut
    Citation Envoyé par ChPr Voir le message
    Sur mon Raspberry Pi 3B, j'ai installé Lazarus 1.6.2 qui était dans les dépôts (je ne me souviens plus de la procédure, mais rien de particulier sinon qu'une simple commande).
    sans doute quelque chose qui ressemble à
    Code shell : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo apt-get install lazarus

    Citation Envoyé par ChPr Voir le message
    Pour harmoniser mes versions, je souhaite installer la version 1.6.4 que j'ai par ailleurs sur mon PC sous Windows et sous Ubuntu.
    il y a des différences significatives enre ls deux versions ?

    Citation Envoyé par ChPr Voir le message
    Je suppose que c'est cette version qu'il faut que je télécharge.
    non. La version qui est proposée sur le site est pour un PC (processeur architecture AMD) or le Raspberry Pi a un processeur de type ARM. Les deux sont incompatibles. Il est probable que tu sois obligé de télécharger le code source du logiciel et de le compiler toi-même pour Raspberry. Sinon essaye de trouver une version pour le Pi.

    Citation Envoyé par ChPr Voir le message
    Je suppose aussi qu'il faut que je supprime totalement la version installée (fichiers de configuration compris). Comment fait-on ?
    une commande de la forme
    Code shell : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo apt-get remove --auto-remove lazarus
    . Mais si tu l'as installé via synaptic tu dois pouvoir le supprimer de la même manière.

  3. #3
    Membre confirmé
    Avatar de ChPr
    Homme Profil pro
    Inscrit en
    septembre 2005
    Messages
    1 331
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 73
    Localisation : France, Val d'Oise (Île de France)

    Informations forums :
    Inscription : septembre 2005
    Messages : 1 331
    Points : 567
    Points
    567
    Par défaut
    Citation Envoyé par Auteur Voir le message
    sans doute quelque chose qui ressemble à
    Code shell : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo apt-get install lazarus
    Oui, je pense que ce devait être ça.

    Citation Envoyé par Auteur Voir le message
    ... il y a des différences significatives entre les deux versions ? ...
    Tout ce que j'ai pu vérifier est qu'il n'était pas possible d'installer la bibliothèque BGRABitmap. Je ne sais pas si c'est lié aux "helper" ? Pour l'instant, l'auteur de cette bibliothèque a fait une dernière version supportant fpc 3.0.0 alors qu'avant, il fallait la 3.0.2 qui est avec Lazarus 1.6.4

    Citation Envoyé par Auteur Voir le message
    ...non. La version qui est proposée sur le site est pour un PC (processeur architecture AMD) or le Raspberry Pi a un processeur de type ARM. Les deux sont incompatibles. Il est probable que tu sois obligé de télécharger le code source du logiciel et de le compiler toi-même pour Raspberry. Sinon essaye de trouver une version pour le Pi. ...
    Ouh la la, dans la précipitation d'avoir trouvé quelque chose, j'ai cofondu AMD et ARM.

    Citation Envoyé par Auteur Voir le message
    ... une commande de la forme
    Code shell : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo apt-get remove --auto-remove lazarus
    ...
    Oui.

    Citation Envoyé par Auteur Voir le message
    Mais si tu l'as installé via synaptic tu dois pouvoir le supprimer de la même manière.
    Synaptic n'est pas installé sur mon Raspberry. Par le menu en haut et à gauche de l'écran, j'ai menu --> préférences --> Add / Remove Software. Étant allé dans cette application, j'ai cru comprendre qu'il suffisait de décocher ce qui y était déjà coché pour le supprimer. Je suppose que cela doit aussi supprimer les fichiers de configuration ?

    Cordialement.

    Pierre

  4. #4
    Expert éminent sénior
    Avatar de Auteur
    Profil pro
    Inscrit en
    avril 2004
    Messages
    7 193
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 7 193
    Points : 10 065
    Points
    10 065
    Par défaut
    réponse très tardive

    Citation Envoyé par ChPr Voir le message
    Synaptic n'est pas installé sur mon Raspberry. Par le menu en haut et à gauche de l'écran, j'ai menu --> préférences --> Add / Remove Software. Étant allé dans cette application, j'ai cru comprendre qu'il suffisait de décocher ce qui y était déjà coché pour le supprimer. Je suppose que cela doit aussi supprimer les fichiers de configuration ?
    cela fait partie des options, tu peux demander une désinstallation complète.

    Mais avant d'installer une nouvelle version renseigne toi bien pour voir déjà si elle est disponible pour Raspberry Pi et surtout si la bibliothèque BGRABitmap sera compatible.

Discussions similaires

  1. [Lazarus] [Lazarus+Ubuntu] Fiabilité : fait pas bon changer de versions
    Par Invité dans le forum Lazarus
    Réponses: 11
    Dernier message: 11/01/2009, 10h14
  2. [FEDORA] Changer ma version de gcc
    Par Jérémy Lefevre dans le forum RedHat / CentOS / Fedora
    Réponses: 1
    Dernier message: 10/11/2006, 14h24
  3. Changer la version de gcc fedora c5
    Par Jérémy Lefevre dans le forum Administration système
    Réponses: 1
    Dernier message: 10/11/2006, 14h06
  4. [Débutant] Changer de version de java
    Par sunchai dans le forum Langage
    Réponses: 2
    Dernier message: 07/04/2006, 21h52
  5. Réponses: 3
    Dernier message: 20/03/2006, 11h38

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo