Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Discussion: [Selenium] - [Behat]

  1. #1
    Membre du Club
    Homme Profil pro
    Consultant informatique
    Inscrit en
    février 2013
    Messages
    116
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : février 2013
    Messages : 116
    Points : 55
    Points
    55

    Par défaut [Selenium] - [Behat]

    Bonjour la communauté.

    Débutant avec les outils Selenium/Behat/Mink, je viens vers vous pour de l'aide.
    J'effectue le test suivant dans mon fichier google.feature

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
     
    @ui
    Feature: Bing
     
      Scenario: Homepage
        Given I am on the homepage
        Then  I should see "Bing"
        And I should see "Images"
        And I should see "Office Online"
     
    @javascript
      Scenario: Search
        Given I am on the homepage
        When I fill in "sb_form_q" with "seleniumhq"
        And I wait for 1 seconds
        Then I should see "Selenium - Web Browser Automation"
    Le premier scénario fonctionne correctement, mais quand arrive le test via selenium pour ouvrir le browser et tester la recherche....
    Le test met un peu plus de 8min et failed.

    Ma question: comment faire en sorte que selenium ouvre le browser et simule mon second scénario ?

    Merci de votre aide

  2. #2
    Membre expérimenté

    Homme Profil pro
    développeur
    Inscrit en
    octobre 2013
    Messages
    1 298
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Oise (Picardie)

    Informations professionnelles :
    Activité : développeur

    Informations forums :
    Inscription : octobre 2013
    Messages : 1 298
    Points : 1 607
    Points
    1 607

    Par défaut

    Salut,

    tu as une erreur plus précise? As tu essayé sur un autre attribut que cette input en particulier?

  3. #3
    Membre du Club
    Homme Profil pro
    Consultant informatique
    Inscrit en
    février 2013
    Messages
    116
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : février 2013
    Messages : 116
    Points : 55
    Points
    55

    Par défaut

    Salut Kevin254kl,

    Suite à ce précédent problème, je viens d'en résoudre une partie dans le sens ou la synchro entre behat/selenium/browser fonctionne.
    Maintenant le dernier problème qui ce pose par rapport au scénario javascript est le suivant:

    Nom : Untitled.png
Affichages : 19
Taille : 33,4 Ko

    Merci de ton aide

    Cordialement

  4. #4
    Membre expérimenté

    Homme Profil pro
    développeur
    Inscrit en
    octobre 2013
    Messages
    1 298
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Oise (Picardie)

    Informations professionnelles :
    Activité : développeur

    Informations forums :
    Inscription : octobre 2013
    Messages : 1 298
    Points : 1 607
    Points
    1 607

    Par défaut

    As tu bien chrome d'installé, le chemin vers l'executable chrome est bien dans ton path? L'erreur dit qu'il ne trouve pas l’exécutable de ton navigateur.

  5. #5
    Membre du Club
    Homme Profil pro
    Consultant informatique
    Inscrit en
    février 2013
    Messages
    116
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : février 2013
    Messages : 116
    Points : 55
    Points
    55

    Par défaut

    Salut Kev,

    Suite à de multiple check/test de mon côté, j'ai finalement réussi (seulement le link entre les webdriver et behat).
    Maintenant je bataille pour faire fonctionner mes tests.
    Problème de compatibilité ou je ne sais quoi !!!

    Nom : Untitled.png
Affichages : 7
Taille : 25,9 Ko

Discussions similaires

  1. [Selenium] Utilisation de Selenium
    Par hocinema dans le forum Tests et Performance
    Réponses: 3
    Dernier message: 18/04/2013, 10h34
  2. Selenium : activer un javascript
    Par tiger33 dans le forum Firefox
    Réponses: 6
    Dernier message: 30/08/2007, 14h04
  3. [test] étendre selenium ide
    Par tiger33 dans le forum Autres
    Réponses: 1
    Dernier message: 30/08/2007, 12h14
  4. [Selenium] Utiliser xpath avec Selenium
    Par khaled69100 dans le forum Tests et Performance
    Réponses: 2
    Dernier message: 13/08/2007, 09h50
  5. Maven2 + Selenium
    Par houzecl dans le forum Maven
    Réponses: 4
    Dernier message: 24/07/2007, 23h14

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo