IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Beamer Discussion :

Utilisation du package xstring


Sujet :

Beamer

  1. #1
    Membre habitué
    Homme Profil pro
    Webmaster
    Inscrit en
    mars 2008
    Messages
    164
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Sarthe (Pays de la Loire)

    Informations professionnelles :
    Activité : Webmaster

    Informations forums :
    Inscription : mars 2008
    Messages : 164
    Points : 154
    Points
    154
    Par défaut Utilisation du package xstring
    Bonjour,

    J'essaye d'utiliser le package xstring avec beamer.

    Malheureusement, je bute sur une difficulté que je n'arrive pas à comprendre

    Un petit ECM valant mieux qu'un long discourt:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
     
    \documentclass{beamer}
     
    \usepackage[french]{babel}
    \usepackage[utf8]{inputenc}
    \usepackage[T1]{fontenc}
    \usepackage{xstring}
    \usepackage{ifthen}
     
    \newcommand*\slide[2]{
    	\frame{
    		\StrGobbleLeft{#1}{2}[\instA]
    		#2
     
    		\instA
     
    		\frametitle{\instA}
    	}
    }
     
    \begin{document}
    	\slide{b=d}{essai}
    \end{document}
    Si je commente la ligne 17 (\frametitle{\instA}) pas de soucis. Par contre, si elle est active, Beamer m'indique pour \instA : "! Undefined control sequence."

    La ligne 15 (\instA) passe dans les deux cas

    Si vous avez une solution ou une piste à suivre....

    Cordialement

  2. #2
    Responsable LaTeX

    Avatar de -Nikopol-
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2013
    Messages
    2 168
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 47
    Localisation : France, Haute Marne (Champagne Ardenne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2013
    Messages : 2 168
    Points : 11 266
    Points
    11 266
    Billets dans le blog
    5
    Par défaut
    Bonjour, il suffit de sortir la commande \StrGobbleLeft{#1}{2}[\instA] de la frame.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    \documentclass{beamer}
     
    \usepackage[french]{babel}
    \usepackage[utf8]{inputenc}
    \usepackage[T1]{fontenc}
    \usepackage{xstring}
    \usepackage{ifthen}
     
    \newcommand*\slide[2]{%
    	\StrGobbleLeft{#1}{2}[\instA]
    	\frame{%	
    		#2
    		\instA
    		\frametitle{\instA}
    	}
    }
     
    \begin{document}
    	\slide{b=d}{essai}
    \end{document}

  3. #3
    Membre habitué
    Homme Profil pro
    Webmaster
    Inscrit en
    mars 2008
    Messages
    164
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Sarthe (Pays de la Loire)

    Informations professionnelles :
    Activité : Webmaster

    Informations forums :
    Inscription : mars 2008
    Messages : 164
    Points : 154
    Points
    154
    Par défaut
    Merci beaucoup.

    Cela fonctionne parfaitement

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 4
    Dernier message: 17/07/2009, 17h25
  2. Pb d'utilisation de package !!
    Par Senia31 dans le forum Langage
    Réponses: 2
    Dernier message: 28/12/2005, 17h45
  3. [SAX] Utilisation du package contenant org.apache.xerces.par
    Par Sphost dans le forum Eclipse Java
    Réponses: 1
    Dernier message: 17/01/2005, 11h07
  4. [CR] Utilisation des package Oracle ??
    Par sboober dans le forum SAP Crystal Reports
    Réponses: 3
    Dernier message: 06/12/2004, 07h37
  5. prob avec utilisation de package
    Par martijan dans le forum Modules
    Réponses: 13
    Dernier message: 11/07/2003, 09h37

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo