1. #1
    Nouveau membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2014
    Messages
    40
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2014
    Messages : 40
    Points : 27
    Points
    27

    Par défaut [Debian - Deepin 15] Impossible de lancer Eclipse avec jdk 9

    Amis du jour, bonjour !

    Je suis en train de tester une distri très intriguante qui est Deepin basé sur Debian.
    Sauf qu'il m'est impossible de lancer Eclipse avec Java 9 d'installé pourtant j'ai bien paramétré Eclipse...

    Mon eclipse.ini :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    -startup
    plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
    --launcher.library
    /home/platon/.p2/pool/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.551.v20171108-1834
    -product
    org.eclipse.epp.package.java.product
    -showsplash
    org.eclipse.epp.package.common
    --launcher.defaultAction
    openFile
    --launcher.appendVmargs
    -vm
    /usr/lib/jvm/java-9-openjdk-amd64/bin
    -vmargs
    -Dosgi.requiredJavaVersion=1.8
    -Dosgi.instance.area.default=@user.home/eclipse-workspace
    -XX:+UseG1GC
    -XX:+UseStringDeduplication
    --add-modules=ALL-SYSTEM
    -Dosgi.requiredJavaVersion=1.8
    -Xms256m
    -Xmx1024m
    --add-modules=ALL-SYSTEM
    -Declipse.p2.max.threads=10
    -Doomph.update.url=http://download.eclipse.org/oomph/updates/milestone/latest
    -Doomph.redirection.index.redirection=index:/->http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/
    Et voici les logs que me sort Eclipse quand je tente de la lancer :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    !SESSION 2018-01-29 17:18:14.684 -----------------------------------------------
    eclipse.buildId=4.7.2.M20171130-0510
    java.version=9-Debian
    java.vendor=Oracle Corporation
    BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=fr_FR
    Framework arguments:  -product org.eclipse.epp.package.java.product
    Command-line arguments:  -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.java.product
     
    !ENTRY org.eclipse.osgi 4 0 2018-01-29 17:19:25.968
    !MESSAGE Application error
    !STACK 1
    org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
    	at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:410)
    	at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:318)
    	at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
    	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:491)
    	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:505)
    	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:204)
    	at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:614)
    	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
    	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:594)
    	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
    	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:151)
    	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    	at java.base/java.lang.reflect.Method.invoke(Method.java:564)
    	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
    	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
    	at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
    	at org.eclipse.equinox.launcher.Main.main(Main.java:1472)
    Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
    	at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:124)
    	at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:399)
    	... 23 more
    Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
    	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
    	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
    	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
    	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
    	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
    	... 25 more
     
    !ENTRY org.eclipse.e4.ui.workbench 4 0 2018-01-29 17:19:25.981
    !MESSAGE FrameworkEvent ERROR
    !STACK 0
    java.lang.NoClassDefFoundError: javax/annotation/PreDestroy
    	at org.eclipse.e4.core.internal.di.InjectorImpl.disposed(InjectorImpl.java:450)
    	at org.eclipse.e4.core.internal.di.Requestor.disposed(Requestor.java:156)
    	at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier$ContextInjectionListener.update(ContextObjectSupplier.java:78)
    	at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.update(TrackableComputationExt.java:111)
    	at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.handleInvalid(TrackableComputationExt.java:74)
    	at org.eclipse.e4.core.internal.contexts.EclipseContext.dispose(EclipseContext.java:178)
    	at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.dispose(EclipseContextOSGi.java:99)
    	at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.bundleChanged(EclipseContextOSGi.java:141)
    	at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent(BundleContextImpl.java:908)
    	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    	at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
    	at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEventPrivileged(EquinoxEventPublisher.java:213)
    	at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:120)
    	at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:112)
    	at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor.publishModuleEvent(EquinoxContainerAdaptor.java:168)
    	at org.eclipse.osgi.container.Module.publishEvent(Module.java:476)
    	at org.eclipse.osgi.container.Module.doStop(Module.java:634)
    	at org.eclipse.osgi.container.Module.stop(Module.java:498)
    	at org.eclipse.osgi.container.SystemModule.stop(SystemModule.java:202)
    	at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule$1.run(EquinoxBundle.java:165)
    	at java.base/java.lang.Thread.run(Thread.java:844)
    Caused by: java.lang.ClassNotFoundException: javax.annotation.PreDestroy cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
    	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
    	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
    	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
    	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
    	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
    	... 21 more
    J'ai essayé un peu toutes les solutions trouvées sur le net et rien ne marche :/
    Et bien sur, je suis obligé de rester sur java 9 sinon ça serait trop simple :/

    Je vous remercie pour votre attention et bonne soirée !

  2. #2
    Membre émérite
    Avatar de Mickael_Istria
    Homme Profil pro
    Développeur Expert Eclipse RCP
    Inscrit en
    juillet 2008
    Messages
    1 106
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Expert Eclipse RCP
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2008
    Messages : 1 106
    Points : 2 315
    Points
    2 315

    Par défaut

    La version d'Eclipse IDE que tu essayes de demarrer est trop vieille pour avoir le support pour Java 9. Telecharges une version plus recente.
    Tu fais du JEE/Web/Mobile dans Eclipse? Essaye JBoss Tools !
    Read my blog about Eclipse | Follow me on twitter

  3. #3
    Nouveau membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2014
    Messages
    40
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 23
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2014
    Messages : 40
    Points : 27
    Points
    27

    Par défaut

    Où puis-je trouver cette version ?
    Pourtant j'ai l'impression d'avoir pris la dernière depuis le site d'éclipse...: /

  4. #4
    Membre émérite
    Avatar de Mickael_Istria
    Homme Profil pro
    Développeur Expert Eclipse RCP
    Inscrit en
    juillet 2008
    Messages
    1 106
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Expert Eclipse RCP
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2008
    Messages : 1 106
    Points : 2 315
    Points
    2 315

    Par défaut

    Ah oui, au temps pour moi. C'est une version assez recente, j'avais mal lu... Donc elle est compatible Java 9.
    Est-ce que tu as essaye avec une autre distro Java 9 genre OpenJDK ?
    Tu fais du JEE/Web/Mobile dans Eclipse? Essaye JBoss Tools !
    Read my blog about Eclipse | Follow me on twitter

Discussions similaires

  1. Impossible de lancer Eclipse
    Par Ousmane Ngom dans le forum Eclipse
    Réponses: 1
    Dernier message: 31/01/2014, 02h30
  2. [EPF] Impossible de lancer Eclipse RCP "error code -1"
    Par olivier57b dans le forum Eclipse Platform
    Réponses: 0
    Dernier message: 14/04/2012, 21h16
  3. Impossible de lancer Eclipse
    Par enzostar dans le forum Eclipse
    Réponses: 2
    Dernier message: 14/05/2010, 10h12
  4. Impossible de lancer Eclipse
    Par jonnyboy dans le forum Eclipse Platform
    Réponses: 9
    Dernier message: 29/05/2007, 11h35
  5. [Install]Impossible de lancer eclipse
    Par kaishef dans le forum Eclipse Java
    Réponses: 1
    Dernier message: 10/05/2005, 11h02

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo