IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Windows Serveur Discussion :

Déploiement lien internet sur le bureau [WS 2003]


Sujet :

Windows Serveur

  1. #1
    Membre actif Avatar de Altor
    Homme Profil pro
    Développeur C#.NeT / Administrateur S.I. en alternance / Étudiant CS2I à Nevers
    Inscrit en
    septembre 2012
    Messages
    103
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 27
    Localisation : France, Nièvre (Bourgogne)

    Informations professionnelles :
    Activité : Développeur C#.NeT / Administrateur S.I. en alternance / Étudiant CS2I à Nevers
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2012
    Messages : 103
    Points : 238
    Points
    238
    Par défaut Déploiement lien internet sur le bureau
    Mesdames, messieurs, bonjour

    Travaillant sur Windows Serveur 2003, mon responsable m'a demandé de déployer un lien internet sur le bureau de tous les utilisateurs.

    J'ai donc créé un script *.vbs à placer dans une GPO, ce que j'ai fait.

    Même après un gpupdate /force ce lien n'apparaît sur aucun des bureaux.

    Voici une version du script, dont les données confidentielles ont été remplacées par (...) :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    ' Langage du script :       VISUAL BASIC SCRIPT | *.vbs
    ' Script édité par :        (...)
    ' En qualité de :           (...)
    ' Emplacement :             (...)
    ' Contact :                 (...)
    '   -----   -----   -----   -----   -----
    ' Date de création :        05/10/2017
    ' Description :             Fonction script de création d'un lien internet sur le bureau, 
    '                           pointant sur (...)
    
    ' Déclaration du nom exact du lien
    sLinkName = "\(...).lnk"
    ' Déclaration d'une instance de Shell
    Set oShell = WScript.CreateObject("WScript.Shell")
    ' Déclaration d'une instance du système de fichier
    Set oFileSystem = WScript.CreateObject("Scripting.FileSystemObject")
    ' Réccupération du chemin vers le bureau
    sDesktopFolder = oShell.SpecialFolders("Desktop")
    
    ' Si le lien existe déjà; Quitter le script.
    if oFileSystem.FileExists(sDesktopFolder & sLinkName) then
        Wscript.Quit
    end if
    
    ' Déclaration du nouveau raccourci
    Set oShortcut = oShell.CreateShortcut(sDesktopFolder & sLinkName)
    ' Déclaration de la cible du raccourci
    oShortcut.TargetPath = "(...)"
    ' Selection de l'icône du raccourci 
    oShortcut.IconLocation = "(...)"
    ' Sauvegarde du raccourci
    oShortcut.Save
    Au niveau de la configuration du GPO, je me suis inspiré de celle que l'on utilise pour déployer OCS Agent sur les postes.

    Zone d'effet :
    Nom : cs1.png
Affichages : 73
Taille : 3,0 Ko

    Fichier de script placé dans le répertoire par défaut et lié à la GPO :
    Nom : cs2.png
Affichages : 107
Taille : 17,5 Ko

    Lancé à partir de :
    Configuration Utilisateur > Paramètre Windows > Scripts > Ouverture de Session


    Et visiblement, je dois faire quelque chose pas correctement dans ma méthode car ça ne fonctionne toujours pas.

    Merci d'avance pour votre aide

  2. #2
    Membre actif Avatar de Altor
    Homme Profil pro
    Développeur C#.NeT / Administrateur S.I. en alternance / Étudiant CS2I à Nevers
    Inscrit en
    septembre 2012
    Messages
    103
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 27
    Localisation : France, Nièvre (Bourgogne)

    Informations professionnelles :
    Activité : Développeur C#.NeT / Administrateur S.I. en alternance / Étudiant CS2I à Nevers
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2012
    Messages : 103
    Points : 238
    Points
    238
    Par défaut
    Solution trouvée, j'ai honte que ce soit aussi nul xD

    En fait mon UO n'était pas lié à la GPO, elle était en attente d'activation... Un petit glissé/déposé sur le domaine pour l'appliquer et hop ça à marché...

    Une erreur de noob, t'y crois pas, quel naze je fait des fois xD

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. raccourci lien internet sur bureau ne fonctionne pas
    Par willytito dans le forum Windows XP
    Réponses: 5
    Dernier message: 19/04/2012, 15h35
  2. Lien hypertexte sur bureau a distance
    Par hellboy20 dans le forum Performance Web
    Réponses: 0
    Dernier message: 26/07/2011, 23h24
  3. Question sur lien internet sur page jsp
    Par endbegins dans le forum Servlets/JSP
    Réponses: 2
    Dernier message: 26/01/2011, 18h25
  4. Lien Internet sur un menu
    Par f6dqm1 dans le forum Langage
    Réponses: 2
    Dernier message: 21/11/2010, 09h42
  5. lien marche sur internet explorer et non sur autre
    Par xman_genius dans le forum Général JavaScript
    Réponses: 6
    Dernier message: 25/04/2006, 19h11

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo