1. #1
    Membre du Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2013
    Messages
    99
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : Industrie

    Informations forums :
    Inscription : août 2013
    Messages : 99
    Points : 54
    Points
    54

    Par défaut [Blender]Add-on OpenStreetMap erreur lors de l'activation

    Bonjour à tous.

    J'ai pour projet de reproduire des villes sous Blender et j'ai trouvé un outil formidable pour cela : OpenStreetMap, il s'agit d'une cartographie du monde réalisée depuis 2004, on peut alors récupérer une cartographie au moyen de fichiers .osm.

    Seulement, pour que cela soit compatible avec Blender, il faut télécharger et activer un add-on. J'ai pu le télécharger sur ce site : https://gumroad.com/l/blender-osm, mais lorsque je cherche à l'activer dans Blender via "Users Preferences", j'obtiens ce message d'erreur :

    Nom : Erreur Blender OpenStreetMap.jpg
Affichages : 66
Taille : 65,9 Ko

    La version que j'ai téléchargée semble être la plus récente, je ne vois pas d'où peut bien provenir ce bug d'autant plus que ça semble fonctionner chez d'autres personnes. J'aimerais bien arranger cela car j'ai payé pour télécharger cet add-on.

    Version de Blender : v2.73
    Système : Windows 8 64 bits

    En vous remerciant par avance.

  2. #2
    Expert éminent

    Profil pro
    Fabricant et casseur d'avions
    Inscrit en
    avril 2004
    Messages
    3 525
    Détails du profil
    Informations personnelles :
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Fabricant et casseur d'avions
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : avril 2004
    Messages : 3 525
    Points : 6 417
    Points
    6 417

    Par défaut

    Salut

    Citation Envoyé par KevinduC Voir le message
    Version de Blender : v2.73
    The addon requires at least Blender 2.76
    Source: https://github.com/vvoovv/blender-os.../Documentation

    On va déjà commencer par ça, en espérant que ça soit la cause unique et principale.

    Au passage, Blender en est à la version 2.79, c'est exprès que tu en es resté à la 2.73?
    "Errare humanum est, sed perseverare diabolicum"

    Ma page sur DVP.com

  3. #3
    Membre du Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2013
    Messages
    99
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : Industrie

    Informations forums :
    Inscription : août 2013
    Messages : 99
    Points : 54
    Points
    54

    Par défaut

    Merci pour la réponse, effectivement j'ai téléchargé la version 2.79 de Blender et j'ai pu activer l'add-on. Mais je ne peux toujours pas importer de fichiers .osm, le format n'apparaît pas dans le menu Import. Pourtant j'ai bien coché la case dans Users Preferences et j'ai bien cliqué sur Save User Settings, redémarré le logiciel, recommencé la manip plusieurs fois ...

  4. #4
    Expert éminent

    Profil pro
    Fabricant et casseur d'avions
    Inscrit en
    avril 2004
    Messages
    3 525
    Détails du profil
    Informations personnelles :
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Fabricant et casseur d'avions
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : avril 2004
    Messages : 3 525
    Points : 6 417
    Points
    6 417

    Par défaut

    Va faire un tour sur la documentation (lien que j'ai mis dans mon message précédent), on ne passe pas par file/import pour importer un fichier osm...
    "Errare humanum est, sed perseverare diabolicum"

    Ma page sur DVP.com

  5. #5
    Membre du Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2013
    Messages
    99
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : Industrie

    Informations forums :
    Inscription : août 2013
    Messages : 99
    Points : 54
    Points
    54

    Par défaut

    J'ai suivi les étapes indiquées dans la doc mais lorsque je sélectionne Import dans l'onglet OSM, ça m'affiche "urlopen error [Errno 11001] getaddrinfo failed"

  6. #6
    Modérateur
    Avatar de wax78
    Homme Profil pro
    Chef programmeur
    Inscrit en
    août 2006
    Messages
    3 498
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : Belgique

    Informations professionnelles :
    Activité : Chef programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2006
    Messages : 3 498
    Points : 6 871
    Points
    6 871

    Par défaut

    Citation Envoyé par KevinduC Voir le message
    J'ai suivi les étapes indiquées dans la doc mais lorsque je sélectionne Import dans l'onglet OSM, ça m'affiche "urlopen error [Errno 11001] getaddrinfo failed"
    Le fichier OSM il est en local ? (donc pas sur le net, bien que les 2 soient normalement possible)
    (Les "ça ne marche pas", même écrits sans faute(s), vous porteront discrédit ad vitam æternam et malheur pendant 7 ans)

    N'oubliez pas de consulter les FAQ Java et les cours et tutoriels Java

  7. #7
    Membre du Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2013
    Messages
    99
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : Industrie

    Informations forums :
    Inscription : août 2013
    Messages : 99
    Points : 54
    Points
    54

    Par défaut

    J'avais ajouté une réponse pour signaler que j'avais résolu le problème mais apparemment y'a eu un bug. Le problème était tout bête : Blender me disait qu'il n'y avait pas d'accès à Internet et en effet, mon PC était en mode avion. Il m'a suffi de sélectionner "File" pour aller chercher le fichier. Merci quand même.

  8. #8
    Modérateur
    Avatar de wax78
    Homme Profil pro
    Chef programmeur
    Inscrit en
    août 2006
    Messages
    3 498
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : Belgique

    Informations professionnelles :
    Activité : Chef programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2006
    Messages : 3 498
    Points : 6 871
    Points
    6 871

    Par défaut

    Non, ce n'est pas bug.

    Cala t'as permis de donner une réponses qui pourrait éventuellement aiguiller un autre (bien que cela soit un cas particulier ^^).
    (Les "ça ne marche pas", même écrits sans faute(s), vous porteront discrédit ad vitam æternam et malheur pendant 7 ans)

    N'oubliez pas de consulter les FAQ Java et les cours et tutoriels Java

  9. #9
    Membre du Club
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2013
    Messages
    99
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : Industrie

    Informations forums :
    Inscription : août 2013
    Messages : 99
    Points : 54
    Points
    54

    Par défaut

    ????

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 1
    Dernier message: 09/07/2008, 09h43
  2. message d'erreur lors de l'activation de tquery
    Par rostomides dans le forum Bases de données
    Réponses: 5
    Dernier message: 07/04/2006, 19h04
  3. Erreur lors de l'execution d'un script jsp
    Par tuxor dans le forum Servlets/JSP
    Réponses: 4
    Dernier message: 06/08/2004, 12h35
  4. Erreur lors de modification d'une table
    Par seb.49 dans le forum SQL
    Réponses: 11
    Dernier message: 13/01/2003, 17h16
  5. [VB6] Erreur lors de l'ouverture d'un document Word
    Par Marco le Pouillot dans le forum VB 6 et antérieur
    Réponses: 3
    Dernier message: 03/01/2003, 09h30

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo