1. #1
    Nouveau membre du Club Avatar de A2ll_
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2017
    Messages : 61
    Points : 39
    Points
    39

    Par défaut Nagios : CRITICAL - Socket timeout pour check_nt request

    Salut !


    je rencontre depuis plusieurs jours des problèmes avec Nagios :

    Pour résumer, j'ai une VM ubuntu 16.04.2 sur un Windows Server 2008 R2. Tout fonctionne correctement avec cette configuration (je supervise avec NSCP (j'ai installé NSCP-0.5.0.62 ) tout les services que je veux).

    Actuellement, j'essaie de communiquer avec un autre serveur (qui lui aussi est un Windows Server 2008 R2) avec cette même VM et j'ai reçu ce message pour toute les requêtes check_nt:
    CRITICAL - Socket timeout
    notez bien que je n'ai pas après 10/30 seconde ( dont on trouve des résolutions sur internet (et que j'ai essayé d'abord)). En version terminal ca donne le même résultat.
    J'ai aussi une requete check_HTTP qui elle marche bien (message sur la page nagios de ma VM : OK bla bla) . J'en déduis que ce n'est pas un problème de connectivité mais plus un problème lié a check_nt.
    J'ai essayé de désactiver les firewall ( car oui il y en a sur les 2 serveurs) mais le resultat reste inchangé.
    La dernière manip que j'ai tenté a été de mettre -t 30 a la fin d'une requête sur terminal ce qui m'a retourné :
    connect to address IP_of_my_server and port 12489 : connexion refusé
    et j'avais bien désactivé les firewall :/


    Ci-dessous un exemple de service que j'ai défini pour le nouveau serveur :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
     
    define service{
    use        generic-service
    host_name        sol
    service_description        Firewall
    check_command        check_nt!SERVICESTATE!-d SHOWALL -l MpsSvc
    check_period        24x7
    notifications_enabled        1
    notification_interval        0
    notification_period        24x7
    notification_options        w,c,r
    contacts        nagiosadmin
    }
    J'aimerai savoir si quelqu'un avait déjà rencontré ce problème et s'il y a une solution, car la je desespère

  2. #2
    Modérateur
    Avatar de ggnore
    Profil pro
    Inscrit en
    juillet 2004
    Messages
    2 433
    Détails du profil
    Informations personnelles :
    Âge : 38
    Localisation : France

    Informations forums :
    Inscription : juillet 2004
    Messages : 2 433
    Points : 3 954
    Points
    3 954

    Par défaut

    Bonjour,

    nsclient fonctionne sur la machine interrogée ? tu as d'autres services qui répondent en s'appuyant aussi sur check_nt ?
    Ton fichier de configuration ressemble à ça ? tu as renseigné allowed_hosts avec l'ip du serveur ?
    [NSClient]
    allowed_hosts=
    port=12489
    bind_to_address=
    socket_timeout=30
    Toutes les vertus des hommes se perdent dans l’intérêt comme les fleuves se perdent dans la mer.
    N'oubliez pas de consulter les FAQ Linux et les cours et tutoriels Linux

  3. #3
    Nouveau membre du Club Avatar de A2ll_
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2017
    Messages : 61
    Points : 39
    Points
    39

    Par défaut

    Salut,

    Merci de ta réponse.

    En ce qui concerne le service nsclient , il est demarré sur le serveur.
    J'ai rajouté ça ce matin car on m'a fait remarquer que ca n'y était pas, mais sans plus de résultat :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
     
    [/settings/NSClient/server]
     
    ; ENABLE SSL ENCRYPTION - This option controls if SSL should be enabled.
    use ssl = 0
     
    ; PERFORMANCE DATA - Send performance data back to Nagios (set this to 0 to remove all performance data).
    performance data = 1
     
    ; PORT NUMBER - Port to use for check_nt.
    port = 12489
    Mais est-ce la même chose que ce que tu m'as montré ?
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    [NSClient]
    allowed_hosts=
    port=12489
    bind_to_address=
    socket_timeout=30
    Tout les services de ce serveur utilisant check_nt ne marchent pas. :/

  4. #4
    Modérateur
    Avatar de ggnore
    Profil pro
    Inscrit en
    juillet 2004
    Messages
    2 433
    Détails du profil
    Informations personnelles :
    Âge : 38
    Localisation : France

    Informations forums :
    Inscription : juillet 2004
    Messages : 2 433
    Points : 3 954
    Points
    3 954

    Par défaut

    https://docs.nsclient.org/installing/
    Il faut que tu renseignes allowed_hosts. Je n'ai jamais utilisé nsclient mais pour nrpe, il faut aussi renseigner une variable allowed_hosts sinon ça ne marche pas.
    Tu peux aussi ajouter 127.0.0.1 et appeler le service localement pour tester.
    Toutes les vertus des hommes se perdent dans l’intérêt comme les fleuves se perdent dans la mer.
    N'oubliez pas de consulter les FAQ Linux et les cours et tutoriels Linux

  5. #5
    Nouveau membre du Club Avatar de A2ll_
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2017
    Messages : 61
    Points : 39
    Points
    39

    Par défaut

    en plus du [/settings/default] que j'ai deja ?


    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
     
    [/settings/default]
     
    ; Undocumented key
    password = mdp
     
    ; Undocumented key
    allowed hosts = 127.0.0.1,::1,+IP de ma VM
     
    ; CACHE ALLOWED HOSTS - If host names (DNS entries) should be cached, improves speed and security somewhat but won t allow you to have dynamic IPs for your Nagios server.
    cache allowed hosts = 1
     
    ; TIMEOUT - Timeout when reading packets on incoming sockets. If the data has not arrived within this time we will bail out.
    timeout = 30
    Et comment je peux l'appeler localement s'il te plait ?

  6. #6
    Nouveau membre du Club Avatar de A2ll_
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2017
    Messages : 61
    Points : 39
    Points
    39

    Par défaut

    salut,

    Je viens de tenter de réinstaller nsclient, mais rien n'y fait, j'ai toujours cette erreur.
    Parcontre j'ai remarqué que je pouvais ping de ma VM (qui est sur le serveur A) vers le serveur B , mais l'inverse n'est pas possible : je ne peux pas ping ma VM depuis le serveur B. Je ne sais pas si c'est lié a ce problème.

    J'en ai marre de tourner en rond

  7. #7
    Nouveau membre du Club Avatar de A2ll_
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2017
    Messages : 61
    Points : 39
    Points
    39

    Par défaut

    Je viens de faire un netstat -an |grep -i 12489 sur ma VM et j'obtiens ca ci-joint.
    Du coup je me suis renseigné sur le SYN_SENT et j'ai vu que cela pouvait venir d'un problème de firewall(http://karunsubramanian.com/network/...socket-status/). Sauf que même en le désactivant j'ai toujours le même problème. :/

    J'ai réssayé peu après en spammant un peu la commande et elle m'a donné ca :
    Nom : netstat2.PNG
Affichages : 44
Taille : 19,3 Ko

    Je sais pas quoi en penser
    Images attachées Images attachées  

  8. #8
    Nouveau membre du Club Avatar de A2ll_
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2017
    Messages : 61
    Points : 39
    Points
    39

    Par défaut

    Quelqu'un a t'il une idée ?

  9. #9
    Modérateur
    Avatar de ggnore
    Profil pro
    Inscrit en
    juillet 2004
    Messages
    2 433
    Détails du profil
    Informations personnelles :
    Âge : 38
    Localisation : France

    Informations forums :
    Inscription : juillet 2004
    Messages : 2 433
    Points : 3 954
    Points
    3 954

    Par défaut

    Peut être que ta vm et ton serveur ne s'atteignent pas correctement parce que tu as mal choisi tes paramètres réseau pour ta vm.
    Toutes les vertus des hommes se perdent dans l’intérêt comme les fleuves se perdent dans la mer.
    N'oubliez pas de consulter les FAQ Linux et les cours et tutoriels Linux

  10. #10
    Nouveau membre du Club Avatar de A2ll_
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2017
    Messages : 61
    Points : 39
    Points
    39

    Par défaut

    bah j'ai un service qui marche entre les 2 machines : le service http

    definition du service :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
     
     
    define service{
    use        generic-service
    host_name        sol
    service_description        http
    check_command        check_http
    check_period        24x7
    notifications_enabled        1
    notification_interval        0
    notification_period        24x7
    notification_options        w,c,r
    contacts        nagiosadmin
    }
    et la commande est celle de base :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
     
    define command{
    command_name check_http
    command_line $USER1$/check_http -I $HOSTADDRESS$
    }
    Et pour ce qui est de la connexion, la VM est en "filaire 1" alors que sur les parametres VM je lui ai demandé de se mettre en NAT


    edit : je rajoute un imprime écran de la connexion réseau activé sur la VM :

    Nom : Connexion.PNG
Affichages : 37
Taille : 17,3 Ko

    edit edit : Je rajoute un imprime écran de l'interface de nagios :
    Nom : NagiosHttpOk.PNG
Affichages : 37
Taille : 17,5 Ko

  11. #11
    Modérateur
    Avatar de ggnore
    Profil pro
    Inscrit en
    juillet 2004
    Messages
    2 433
    Détails du profil
    Informations personnelles :
    Âge : 38
    Localisation : France

    Informations forums :
    Inscription : juillet 2004
    Messages : 2 433
    Points : 3 954
    Points
    3 954

    Par défaut

    Ton http test ne s'appuie par sur nc/check_nt.
    Donc à priori t'as bien un souci de communication sur ce port.

    Tu peux faire des tests de communication sur un port avec nc.
    sur le serveur tu fais :
    sur le client tu fais
    Si tu tapes des choses sur le client, ça doit apparaître sur le serveur.
    Toutes les vertus des hommes se perdent dans l’intérêt comme les fleuves se perdent dans la mer.
    N'oubliez pas de consulter les FAQ Linux et les cours et tutoriels Linux

  12. #12
    Nouveau membre du Club Avatar de A2ll_
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2017
    Messages : 61
    Points : 39
    Points
    39

    Par défaut

    la commande nc n'est pas reconnu sous windows :/

    Edit : j 'ai installé "Download nc111nt_safe.zip (password:nc) - Netcat for Windows (without -e)" sur mon pc ( pas sur les serveurs et j'ai essayé de communiquer avec la vm situé sur le serveur A -> à chaque fois que je fait nc -L @IPVM -p 12489, le cmd se ferme (avant j'apercois un message mais il se ferme trop vite avant que j'arrive à le lire(je pense que c'est un message d erreur)).

    Edit edit : j'ai utilisé une VM sur mon pc pour essayer de communiquer avec la VM qui est sur le serveur en utilisant la manipulation que vous m'avez conseillé. Cela ne donne rien : sur la VM du serveur je ne recois pas les messages que j'envoi depuis la VM sur mon PC

  13. #13
    Nouveau membre du Club Avatar de A2ll_
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : mai 2017
    Messages : 61
    Points : 39
    Points
    39

    Par défaut

    Pour ceux que ca interesse, j'ai trouvé la solution :
    Il s'est avéré qu'il n'y avait pas de "bridge" définit sur le serveur, ce qui explique le fait que j'avais que des Time out.
    Merci pour l'aide que vous m'avez apporté

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Rendre socket timeout non critique Nagios
    Par flo21470 dans le forum Supervision
    Réponses: 1
    Dernier message: 01/07/2014, 17h26
  2. timeout pour socket en .NET
    Par toutounesan dans le forum VB.NET
    Réponses: 0
    Dernier message: 25/08/2011, 11h41
  3. Timeout pour socket UDP
    Par parabole33 dans le forum C++
    Réponses: 5
    Dernier message: 15/10/2010, 21h22
  4. [C#] [Sockets] Eclaircissements pour connexions asynchrones
    Par Sinclair dans le forum Windows Forms
    Réponses: 6
    Dernier message: 08/06/2004, 18h50
  5. [Sockets] Timeout sur accept() ?
    Par MikB dans le forum Développement
    Réponses: 2
    Dernier message: 30/12/2003, 18h22

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo