1. #1
    Membre du Club
    Avatar de michelgard
    Homme Profil pro
    Formateur
    Inscrit en
    mars 2015
    Messages
    28
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Formateur

    Informations forums :
    Inscription : mars 2015
    Messages : 28
    Points : 48
    Points
    48
    Billets dans le blog
    3

    Par défaut Installation Kolab Debian 7

    Bonjour,

    J'essaie de suivre cette installation : https://kolabsys.com/installation-guide/kolab-3.4/debian-7-community-3.4.html tout va bien jusqu'au apt-get update tout va bien.

    J'ai une erreur :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    Err http://obs.kolabsys.com ./ Release.gpg
      Temporary failure resolving 'obs.kolabsys.com'
    Err http://obs.kolabsys.com ./ Release.gpg
      Temporary failure resolving 'obs.kolabsys.com'
    Reading package lists... Done
    W: Failed to fetch http://obs.kolabsys.com/repositories/Kolab:/3.4/Debian_7.0/./Release.gpg  Temporary failure resolving 'obs.kolabsys.com'
     
    W: Failed to fetch http://obs.kolabsys.com/repositories/Kolab:/3.4:/Updates/Debian_7.0/./Release.gpg  Temporary failure resolving 'obs.kolabsys.com'
     
    W: Some index files failed to download. They have been ignored, or old ones used instead.
    Pourtant la phase GPG ne me fait pas d'erreur.

    Je suis sur un CloupVPS en Debian 7

    Merci

  2. #2
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    7 484
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 7 484
    Points : 16 098
    Points
    16 098

    Par défaut

    Utilises plutôt ce tuto plus à jour :
    https://docs.kolab.org/installation-guide/debian-8.html

    Pas sûr que les sources pour Debian 7 soient toujours dispos (tu as des erreurs d'accès aux dépôts) ni qu'un version debian 7 soit toujours dispo.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutoriels/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  3. #3
    Membre du Club
    Avatar de michelgard
    Homme Profil pro
    Formateur
    Inscrit en
    mars 2015
    Messages
    28
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Formateur

    Informations forums :
    Inscription : mars 2015
    Messages : 28
    Points : 48
    Points
    48
    Billets dans le blog
    3

    Par défaut

    Bonjour
    Merci Chrtophe,

    J'ai suivie le tuto pour debian 8 je vais un peu plus loin mais au setup-kelob j'ai :
    -bash: setup-kolab: command not found

    Mais je pense que le aptitude -y install kolab n'est pas bon :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    120
    121
    122
    123
    124
    125
    126
    127
    128
    129
    130
    131
    132
    133
    134
    135
    136
    137
    138
    139
    140
    141
    142
    143
    144
    145
    146
    147
    148
    149
    150
    151
    152
    153
    154
    155
    156
    157
    158
    159
    160
    161
    aptitude -y install kolab
    The following NEW packages will be installed:
      altermime{a} amavisd-new{a} aspell{a} aspell-en{a} augeas-lenses{a}
      chwala{ab} clamav{a} clamav-base{a} clamav-daemon{a} clamav-freshclam{a}
      cyrus-imapd{ab} dictionaries-common{a} guam{ab} irony{a} kolab
      kolab-cli{a} kolab-conf{a} kolab-freebusy{ab} kolab-imap{a} kolab-ldap{a}
      kolab-mta{a} kolab-saslauthd{a} kolab-schema{a} kolab-server{a}
      kolab-syncroton{a} kolab-webadmin{ab} kolab-webclient{a} kolab-xml{ab}
      libaio1{a} libapache2-mod-php5{a} libarchive-zip-perl{a}
      libasn1-8-heimdal{a} libaspell15{a} libaugeas0{a} libberkeleydb-perl{a}
      libclamav7{a} libconvert-binhex-perl{a} libconvert-tnef-perl{a}
      libconvert-uulib-perl{a} libcrypt-openssl-bignum-perl{a}
      libcrypt-openssl-rsa-perl{a} libcurl3{a} libdbd-mysql-perl{a}
      libdbi-perl{a} libdigest-hmac-perl{a} libgd2-xpm{a} libicu48{a}
      libio-multiplex-perl{a} libio-socket-inet6-perl{a} libio-stringy-perl{a}
      libjpeg8{a} libkolabxml1{ab} libllvm3.0{a} libmail-dkim-perl{a}
      libmail-spf-perl{a} libmcrypt4{a} libmime-tools-perl{a} libmozldap-0d{ab}
      libmysqlclient18{a} libnet-cidr-perl{a} libnet-dns-perl{a}
      libnet-ip-perl{a} libnet-server-perl{a} libnetaddr-ip-perl{a} libonig2{a}
      libpython2.7{a} libqdbm14{a} libroken18-heimdal{a} libsasl2-modules{a}
      libslp1{a} libsocket6-perl{a} libsys-hostname-long-perl{a}
      libunix-syslog-perl{a} libx11-6{a} libxau6{a} libxcb1{a} libxdmcp6{a}
      libxpm4{a} mozldap-tools{ab} mysql-client{a} mysql-client-5.5{a}
      mysql-common{a} mysql-server{a} mysql-server-5.5{a}
      mysql-server-core-5.5{a} pax{a} php-auth-sasl{a} php-mail-mime{a}
      php-mail-mimedecode{a} php-mdb2{a} php-mdb2-driver-mysql{a}
      php-net-ldap2{a} php-net-ldap3{a} php-net-sieve{a} php-net-smtp{a}
      php-net-socket{a} php-pear{a} php-sabre-dav-2.1{a} php-sabre-event{a}
      php-sabre-http-3{a} php-sabre-vobject-3{a} php5{a} php5-cli{a}
      php5-common{a} php5-gd{a} php5-intl{a} php5-ldap{a} php5-mcrypt{a}
      php5-mysql{a} php5-pspell{a} postfix{ab} postfix-ldap{a} pykolab{ab}
      python-augeas{a} python-cheetah{a} python-dateutil{a} python-gnupg{a}
      python-kolabformat{ab} re2c{a} ripole{a} roundcubemail{a}
      roundcubemail-plugin-contextmenu{a} roundcubemail-plugins-kolab{ab}
      roundcubemail-skin-chameleon{a} slapd{a} spamassassin{a} spamc{a}
      wallace{ab} zendframework{a}
    0 packages upgraded, 129 newly installed, 0 to remove and 3 not upgraded.
    Need to get 79.5 MB of archives. After unpacking 320 MB will be used.
    The following packages have unmet dependencies:
     mozldap-tools : Depends: libc6 (>= 2.14) but 2.13-38+deb7u11 is installed.
                     Depends: libnspr4 (>= 2:4.9-2~) but it is not going to be installed. or
                              libnspr4-0d (>= 1.8.0.10) but it is not going to be installed.
                     Depends: libnss3 (>= 2:3.13.4-2~) but it is not going to be installed. or
                              libnss3-1d (>= 3.12.0~beta2) but it is not going to be installed.
                     Depends: libsvrcore0 (>= 1:4.0.4) but it is not going to be installed.
     postfix : Conflicts: mail-transport-agent which is a virtual package.
     libkolabxml1 : Depends: libboost-system1.55.0 which is a virtual package.
                    Depends: libboost-thread1.55.0 which is a virtual package.
                    Depends: libc6 (>= 2.14) but 2.13-38+deb7u11 is installed.
                    Depends: libstdc++6 (>= 4.9) but 4.7.2-5 is installed.
                    Depends: libxerces-c3.1 but it is not going to be installed.
     chwala : Depends: php-http-request2 which is a virtual package.
              Depends: smarty3 (>= 3.1.7) but it is not going to be installed.
     pykolab : Depends: python-icalendar which is a virtual package.
               Depends: python-mysqldb but it is not going to be installed.
               Depends: python-kolab but it is not going to be installed.
               Depends: python-ldap but it is not going to be installed.
               Depends: python-pyasn1 but it is not going to be installed.
               Depends: python-pyasn1-modules which is a virtual package.
               Depends: python-sqlalchemy but it is not going to be installed.
     cyrus-imapd : Depends: libc6 (>= 2.14) but 2.13-38+deb7u11 is installed.
                   Depends: libdb5.3 which is a virtual package.
                   Depends: libgssapi3-heimdal (>= 1.4.0+git20110226) but it is not going to be installed.
                   Depends: libjansson4 (>= 2.0.1) but it is not going to be installed.
                   Depends: libkrb5-26-heimdal (>= 1.4.0+git20110226) but it is not going to be installed.
                   Depends: libpci3 (>= 1:3.2.1-1) but it is not going to be installed.
                   Depends: libpcre3 (>= 1:8.35) but 1:8.30-5 is installed.
                   Depends: libsnmp30 (>= 5.7.2.1+dfsg-1~dfsg) which is a virtual package.
                   Depends: libzephyr4 but it is not going to be installed.
                   Depends: perl (>= 5.20.2-3+deb8u6) but 5.14.2-21+deb7u4 is installed.
                   Depends: perlapi-5.20.2 which is a virtual package.
     kolab-freebusy : Depends: php-monolog which is a virtual package.
     roundcubemail-plugins-kolab : Depends: php-http-request2 which is a virtual package.
                                   Depends: php-net-url2 but it is not going to be installed.
                                   Depends: php5-curl but it is not going to be installed.
                                   Depends: php-endroid-qrcode but it is not going to be installed.
                                   Depends: php-kolab (>= 0.5) but it is not going to be installed.
                                   Depends: php-kolabformat (>= 1.1) but it is not going to be installed.
                                   Depends: php-spomky-labs-otphp but it is not going to be installed.
                                   Depends: php-enygma-yubikey but it is not going to be installed.
     kolab-webadmin : Depends: php-http-request2 which is a virtual package.
                      Depends: php-mail but it is not going to be installed.
                      Depends: php-net-url2 but it is not going to be installed.
                      Depends: smarty3 (>= 3.1.7) but it is not going to be installed.
     sendmail-bin : Conflicts: mail-transport-agent which is a virtual package.
     wallace : Depends: python-icalendar which is a virtual package.
               Depends: python-tzlocal but it is not going to be installed.
     guam : Depends: init-system-helpers (>= 1.18~) which is a virtual package.
            Depends: erlang-base (>= 17.4) but it is not going to be installed. or
                     erlang-base-hipe (>= 17.4) but it is not going to be installed.
            Depends: erlang-eimap (>= 0.1.2) but it is not going to be installed.
            Depends: erlang-goldrush but it is not going to be installed.
            Depends: erlang-lager but it is not going to be installed.
            Depends: erlang-lager-syslog but it is not going to be installed.
     libmozldap-0d : Depends: libc6 (>= 2.14) but 2.13-38+deb7u11 is installed.
                     Depends: libnspr4 (>= 2:4.9-2~) but it is not going to be installed. or
                              libnspr4-0d (>= 1.8.0.10) but it is not going to be installed.
                     Depends: libnss3 (>= 2:3.13.4-2~) but it is not going to be installed. or
                              libnss3-1d (>= 3.12.0~beta2) but it is not going to be installed.
                     Depends: libnss3-1d but it is not going to be installed.
                     Depends: libsvrcore0 but it is not going to be installed.
     python-kolabformat : Depends: libc6 (>= 2.14) but 2.13-38+deb7u11 is installed.
     rmail : Conflicts: postfix but 2.9.6-2 is to be installed.
     kolab-xml : Depends: python-icalendar which is a virtual package.
                 Depends: python-tzlocal but it is not going to be installed.
    The following actions will resolve these dependencies:
     
          Keep the following packages at their current version:
    1)      chwala [Not Installed]
    2)      cyrus-imapd [Not Installed]
    3)      guam [Not Installed]
    4)      irony [Not Installed]
    5)      kolab [Not Installed]
    6)      kolab-cli [Not Installed]
    7)      kolab-conf [Not Installed]
    8)      kolab-freebusy [Not Installed]
    9)      kolab-imap [Not Installed]
    10)     kolab-mta [Not Installed]
    11)     kolab-saslauthd [Not Installed]
    12)     kolab-server [Not Installed]
    13)     kolab-syncroton [Not Installed]
    14)     kolab-webadmin [Not Installed]
    15)     kolab-webclient [Not Installed]
    16)     kolab-xml [Not Installed]
    17)     libkolabxml1 [Not Installed]
    18)     libmozldap-0d [Not Installed]
    19)     mozldap-tools [Not Installed]
    20)     postfix [Not Installed]
    21)     postfix-ldap [Not Installed]
    22)     pykolab [Not Installed]
    23)     python-kolabformat [Not Installed]
    24)     roundcubemail-plugins-kolab [Not Installed]
    25)     wallace [Not Installed]
     
     
     
    The following NEW packages will be installed:
      libio-socket-inet6-perl{a} libsasl2-modules{a} libsocket6-perl{a}
    0 packages upgraded, 3 newly installed, 0 to remove and 3 not upgraded.
    Need to get 160 kB of archives. After unpacking 392 kB will be used.
    Get: 1 http://ftp.debian.org/debian/ wheezy/main libsocket6-perl amd64 0.23-1+b2 [26.4 kB]
    Get: 2 http://ftp.debian.org/debian/ wheezy/main libio-socket-inet6-perl all 2.69-2 [17.1 kB]
    Get: 3 http://ftp.debian.org/debian/ wheezy/main libsasl2-modules amd64 2.1.25.dfsg1-6+deb7u1 [116 kB]
    Fetched 160 kB in 0s (1852 kB/s)
    debconf: unable to initialize frontend: Dialog
    debconf: (No usable dialog-like program is installed, so the dialog based frontend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 76, <> line 3.)
    debconf: falling back to frontend: Readline
    Selecting previously unselected package libsocket6-perl.
    (Reading database ... 32445 files and directories currently installed.)
    Unpacking libsocket6-perl (from .../libsocket6-perl_0.23-1+b2_amd64.deb) ...
    Selecting previously unselected package libio-socket-inet6-perl.
    Unpacking libio-socket-inet6-perl (from .../libio-socket-inet6-perl_2.69-2_all.deb) ...
    Selecting previously unselected package libsasl2-modules:amd64.
    Unpacking libsasl2-modules:amd64 (from .../libsasl2-modules_2.1.25.dfsg1-6+deb7u1_amd64.deb) ...
    Processing triggers for man-db ...
    debconf: unable to initialize frontend: Dialog
    debconf: (No usable dialog-like program is installed, so the dialog based frontend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 76.)
    debconf: falling back to frontend: Readline
    Setting up libsocket6-perl (0.23-1+b2) ...
    Setting up libio-socket-inet6-perl (2.69-2) ...
    Setting up libsasl2-modules:amd64 (2.1.25.dfsg1-6+deb7u1) ...
    Je dois installer des packages avant ?

    Merci

  4. #4
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    7 484
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 7 484
    Points : 16 098
    Points
    16 098

    Par défaut

    Essayes l'install depuis une Debian 8.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur la création d'un système : http://chrtophe.developpez.com/tutoriels/minisysteme/
    Mon article sur le P2V : http://chrtophe.developpez.com/tutoriels/p2v/
    Consultez nos FAQ : Windows, Linux, Virtualisation

  5. #5
    Membre du Club
    Avatar de michelgard
    Homme Profil pro
    Formateur
    Inscrit en
    mars 2015
    Messages
    28
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Formateur

    Informations forums :
    Inscription : mars 2015
    Messages : 28
    Points : 48
    Points
    48
    Billets dans le blog
    3

    Par défaut

    Bonsoir

    Oui ca marche mieux pour l'installation.
    Mais maintenant j'ai un soucis sur le setup-kolab

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    [17/02/15:22:36:42] - [Setup] Info Could not copy file '/etc/dirsrv/config/certmap.conf' to
    '/etc/dirsrv/slapd-blog-de-michel/certmap.conf'.  Error: Aucun fichier ou dossier de ce type
    [17/02/15:22:36:42] - [Setup] Fatal Error: Could not create directory server instance 'blog-de-michel'.
    [17/02/15:22:36:42] - [Setup] Fatal Exiting . . .
    J'ai peut être une idée : https://docs.kolab.org/installation-...tname-and-fqdn
    J'ai pas de eth0 dans ma config.

    j'ai ça:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
     
    lo        Link encap:Boucle locale
              inet adr:127.0.0.1  Masque:255.0.0.0
              adr inet6: ::1/128 Scope:Hôte
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:1041 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1041 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 lg file transmission:0
              RX bytes:57829 (56.4 KiB)  TX bytes:57829 (56.4 KiB)
     
    venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
              inet adr:127.0.0.2  P-t-P:127.0.0.2  Bcast:0.0.0.0  Masque:255.255.255.255
              UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
              RX packets:1624 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1545 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 lg file transmission:0
              RX bytes:244149 (238.4 KiB)  TX bytes:146750 (143.3 KiB)
     
    venet0:0  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
              inet adr:1xx.xx.xx.x8  P-t-P:1xx.xx4.xx.x8  Bcast:1xx.xx.xx.x8  Masque:255.255.255.255
              UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
    Merci

  6. #6
    Membre du Club
    Avatar de michelgard
    Homme Profil pro
    Formateur
    Inscrit en
    mars 2015
    Messages
    28
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Formateur

    Informations forums :
    Inscription : mars 2015
    Messages : 28
    Points : 48
    Points
    48
    Billets dans le blog
    3

    Par défaut

    Bonjour,

    Après plusieurs essais d'installation de Kolab sans succès j'ai fini par cerner le problème c'est l'installation de 389-ds-base qui n'est pas bonne.
    J'ai cette erreur au moment de l'installation :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    Paramétrage de 389-ds-base (1.3.3.5-4) ...
    adduser*: Attention*! Le répertoire personnel «*/var/lib/dirsrv*» n'appartient pas à l'utilisateur que vous êtes en train                        de créer.
    Job for dirsrv-snmp.service failed. See 'systemctl status dirsrv-snmp.service' and 'journalctl -xn' for details.
    Et dans systemctl il y a : ● dirsrv-snmp.service loaded failed failed 389 Directory Server SNMP Subagent.
    et dans journalctl -xn j'ai :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    y
    févr. 19 15:18:18 blog-de-michel systemd[1]: Starting 389 Directory Server.
    févr. 19 15:18:18 blog-de-michel systemd[1]: Reached target 389 Directory Server.
    févr. 19 15:18:18 blog-de-michel ldap-agent[9567]: ldap-agent: No server instances defined in config file
    févr. 19 15:18:18 blog-de-michel systemd[1]: dirsrv-snmp.service: control process exited, code=exited status=1
    févr. 19 15:18:18 blog-de-michel systemd[1]: Failed to start 389 Directory Server SNMP Subagent..
    févr. 19 15:18:18 blog-de-michel systemd[1]: Unit dirsrv-snmp.service entered failed state.
    Merci de votre aide

Discussions similaires

  1. Installation de Debian par le réseau !
    Par Franck.H dans le forum Debian
    Réponses: 27
    Dernier message: 24/09/2006, 15h20
  2. Problème d'installation Linux Debian
    Par Myth_Titans dans le forum Debian
    Réponses: 7
    Dernier message: 12/07/2006, 13h54
  3. Problème reboot après install sous Debian
    Par getupa dans le forum Administration système
    Réponses: 8
    Dernier message: 27/01/2006, 17h19
  4. Montage du CD-ROM à l'installation sur Debian Sarge
    Par Bidouille dans le forum Administration système
    Réponses: 9
    Dernier message: 24/09/2004, 21h43

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo