IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Mint Discussion :

pkgProblem::Resolve a généré des ruptures


Sujet :

Mint

  1. #1
    Membre régulier
    Profil pro
    Inscrit en
    janvier 2011
    Messages
    128
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : janvier 2011
    Messages : 128
    Points : 86
    Points
    86
    Par défaut pkgProblem::Resolve a généré des ruptures
    Bonjour à tous,

    Je souhaite mettre à jour ma distribution Linux (LMDE 1) vers la version LMDE 2.

    Pour cela, je suis les instructions que j'ai pu trouver [ici](https://community.linuxmint.com/tutorial/view/2013).

    Malheureusement, je rencontre un problème au moment de saisir la commande suivante :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo apt install blueberry
    Voici ce que me répond mon terminal :

    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Certains paquets ne peuvent être installés. Ceci peut signifier
    que vous avez demandé l'impossible, ou bien, si vous utilisez
    la distribution unstable, que certains paquets n'ont pas encore
    été créés ou ne sont pas sortis d'Incoming.
    L'information suivante devrait vous aider à résoudre la situation :

    Les paquets suivants contiennent des dépendances non satisfaites :
    dpkg : Casse: cups (< 1.7.5-10~) mais 1.6.4-2 devra être installé
    modemmanager : Casse: network-manager (< 0.9.8.2-1) mais 0.9.8.0-5 devra être installé
    ppp : Casse: network-manager (< 0.9.8.8-7~) mais 0.9.8.0-5 devra être installé
    E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
    Après quelques recherches sur internet, j'ai tenté pas mal de choses et notamment :

    • ouvrir le gestionnaire de paquets graphique Synaptic et cliquer sur Edition > Réparer les paquets cassés
    • saisir la commande `sudo apt-get update && upgrade`


    Malheureusement le résultat est le même

    Avez-vous une idée de comment réparer cette erreur ?

    D'avance merci !

  2. #2
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 727
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 727
    Points : 34 080
    Points
    34 080
    Par défaut
    Ton installation se bloque car ce que tu souhaites installer veut downgrader des paquets.

    En regardant ton lien, je vois que la procédure d'upgrade mélange des dépôts linuxmint et debian, pas top pour les dépendances ça.

    Si tu n'en as pas besoin, n'insistes pas.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  3. #3
    Membre régulier
    Profil pro
    Inscrit en
    janvier 2011
    Messages
    128
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : janvier 2011
    Messages : 128
    Points : 86
    Points
    86
    Par défaut
    Bonjour chrtophe,

    Merci pour la réponse. Si je comprends bien, le plus simple, si je souhaite vraiment mettre à jour ma distribution est tout simplement de repartir from scratch ?

  4. #4
    Membre régulier
    Profil pro
    Inscrit en
    janvier 2011
    Messages
    128
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : janvier 2011
    Messages : 128
    Points : 86
    Points
    86
    Par défaut
    J'ai finalement creusé le forum officiel de la distribution Mint et je suis tombé sur ce post dans lequel un utilisateur rencontre le même soucis. La solution proposée est la suivante :

    The issue for me was that I had two sources.list files. There was both /etc/apt/sources.list (which is an older way of doing the sources.list file) and /etc/apt/sources.list.d/official-package-repositories.list (as described in the upgrade tutorial).

    You should only be using the second of those files, with the entires described in the upgrade tutorial. I just renamed the older source.list file in /etc/apt to "sources.list.bak" (you could probably just delete it, but i renamed it and held onto it, just to be on the safe side). Then I ran apt update again and proceded following the steps in the tutorial. All was fine.
    Pour le moment ça semble effectivement régler le problème. La commande
    apt install sysvinit-core adwaita-icon-theme blueberry
    va plus loin.

    Je continue ma MAJ et passerai le sujet en résolu si tout se passe bien

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réorganiser le code généré des beans
    Par osopardo dans le forum NetBeans
    Réponses: 1
    Dernier message: 24/05/2007, 16h52
  2. Inserer des ruptures Excel VBA
    Par hka75 dans le forum Macros et VBA Excel
    Réponses: 3
    Dernier message: 02/04/2007, 20h00
  3. Réponses: 19
    Dernier message: 21/11/2006, 11h57
  4. Message erreur: MSACCESS a généré des erreurs
    Par Wardog dans le forum Access
    Réponses: 2
    Dernier message: 11/07/2006, 13h10
  5. msaccess.exe a généré des erreurs etc...
    Par stigma dans le forum Access
    Réponses: 2
    Dernier message: 13/04/2006, 08h03

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo