Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Langage PHP Discussion :

Not Found The Requested URL


Sujet :

Langage PHP

  1. #1
    Futur Membre du Club
    Not Found The Requested URL
    Bonjour,
    J'ai créé un script index.php sur mon localhost qui fonctionne parfaitement (c'est un script pour se connecter avec Facebook utilisant Composer et SDK).
    Je souhaite maintenant le mettre sur un serveur virtuel et comme je n'ai pas tout les droits...je l'ai mis dans un dossier "public_html", bien sûr j'ai préalablement effectué toutes les installations nécessaires etc.

    Cependant à l'exécution j'obtiens cela:

    Not Found
    The requested URL /~aaurelie/< was not found on this server.
    Et avec cette erreur dans la barre d'adresse j'ai cela: http://@IP/~aaurelie/<?=$helper->getLoginUrl();?>

    Il m'affiche donc la dernière ligne de mon script comme s'il ne l'exécutait pas...

    Avez-vous une idée de la source du problème?
    Merci d'avance pour vos réponses ! (ou questions).

  2. #2
    Modérateur

    Il est possible que le PHP ne soit pas interpreté dans public_html, c'est à voir du côté de ton hebergement.
    N'oubliez pas de consulter les FAQ PHP et les cours et tutoriels PHP

  3. #3
    Futur Membre du Club
    Merci de ta réponse !
    J'ai trouvé la solution ! Je le poste au cas où cela peut aider quelqu'un. En fait dans le dossier public_html, php est désactivé par défaut !
    Pour l'activer:

    Dans /etc/apache2/mods-enabled/php5.conf, il faut commenter les lignes suivantes:

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
        # To re-enable php in user directories comment the following lines
        # (from <IfModule ...> to </IfModule>.) Do NOT set it to On as it
        # prevents .htaccess files from disabling it.
        #<IfModule mod_userdir.c>
        #    <Directory /home/*/public_html>
        #        php_admin_value engine Off
        #    </Directory>
        #</IfModule>