IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

SDL Discussion :

Fenêtre qui ne se lance pas et seg fault


Sujet :

SDL

  1. #1
    Futur Membre du Club
    Homme Profil pro
    Analyste programmeur
    Inscrit en
    août 2013
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Togo

    Informations professionnelles :
    Activité : Analyste programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2013
    Messages : 6
    Points : 7
    Points
    7
    Par défaut Fenêtre qui ne se lance pas et seg fault
    Bonjour, Bonsoir tout le monde
    Bon voilà, j'ai créer un petit progrmma avec la SDL.
    Le programme s'utilise en ligne de commande et l'utilisateur doit spécifier un dossier contenant des images (oui ça affiche des images). Ensuite le programme fait un listing des images, et l'utilisateur choisi un nombre correspondant à une image.
    Mais à la saisi d'un nombre valide le programme n'évolue plus, de plus quand j'appuie sur entrée, j'ai un segfault.
    Je suis sous linux (elemntary OS freya 64 bits)
    Le programme est écrit en C et C++.
    le code source https://drive.google.com/file/d/0B8Z...p=docslist_api

  2. #2
    Membre émérite Avatar de Cirrus Minor
    Homme Profil pro
    Développeur .NET
    Inscrit en
    mars 2014
    Messages
    946
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Allemagne

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : mars 2014
    Messages : 946
    Points : 2 495
    Points
    2 495
    Par défaut
    Citation Envoyé par varel Voir le message
    Mais à la saisi d'un nombre valide le programme n'évolue plus, de plus quand j'appuie sur entrée, j'ai un segfault.
    Et bien, c'est le moment d'utiliser un debugger
    Si l'erreur se produit systématiquement, elle devrait être facile à trouver.

Discussions similaires

  1. Tâche qui ne se lance pas avec cron
    Par bugalood dans le forum Administration système
    Réponses: 3
    Dernier message: 17/10/2005, 19h13
  2. Réponses: 3
    Dernier message: 16/09/2005, 11h01
  3. mmc.exe qui ne se lance pas
    Par r0d dans le forum Autres Logiciels
    Réponses: 2
    Dernier message: 27/04/2005, 18h11
  4. [MFC] Ces fenêtres qui ne s'affichent pas..
    Par Davide dans le forum MFC
    Réponses: 3
    Dernier message: 19/11/2003, 12h30

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo