Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

NHibernate Discussion :

Probleme de reference


Sujet :

NHibernate

  1. #1
    Membre averti Avatar de Seth77
    Homme Profil pro
    Développeur .NET
    Inscrit en
    octobre 2005
    Messages
    1 428
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : octobre 2005
    Messages : 1 428
    Points : 411
    Points
    411
    Par défaut Probleme de reference
    Salut

    J ai compile la derniere version de NHibernate ; mais quand je veux l utiliser il me dit :

    Error 25 The type 'NHibernate.Driver.OleDbDriver' is defined in an assembly that is not referenced. You must add a reference to assembly 'NHibernate, Version=4.0.0.4000, Culture=neutral, PublicKeyToken=aa95f207798dfdb4'.

    Pourtant j ai bien mis la reference .....

    merci d avance

  2. #2
    Membre éprouvé Avatar de worm83
    Homme Profil pro
    Architecte logiciel
    Inscrit en
    février 2010
    Messages
    459
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Architecte logiciel
    Secteur : Conseil

    Informations forums :
    Inscription : février 2010
    Messages : 459
    Points : 1 090
    Points
    1 090
    Par défaut
    Salut,

    Si tu as bien mis la référence, il est probable que ce soit dû à la version du Framework avec laquelle tu compile qui est infèrieure a celle de Nhibernate.

    A confirmer
    "Le train de tes injures roule sur le rail de mon indifférence."

    "Monde de merde !!"

    Georges Abitbol.

  3. #3
    Membre averti Avatar de Seth77
    Homme Profil pro
    Développeur .NET
    Inscrit en
    octobre 2005
    Messages
    1 428
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : octobre 2005
    Messages : 1 428
    Points : 411
    Points
    411
    Par défaut
    Salut

    Oui merci j avais verifier la version du framework et de la la plateforme.

    En fait le probleme venait du fait qu une autre DDL avais une reference du NHibernate ; j ai du recompiler la DLL (NHibernate.JetDriver)

    Je pense qu il fait egalement la verification sur le public token ; et pas que sur la version de la dll.

    Encore merci

  4. #4
    Membre éprouvé Avatar de worm83
    Homme Profil pro
    Architecte logiciel
    Inscrit en
    février 2010
    Messages
    459
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Architecte logiciel
    Secteur : Conseil

    Informations forums :
    Inscription : février 2010
    Messages : 459
    Points : 1 090
    Points
    1 090
    Par défaut
    Tu n'utilise pas la packages nuget?
    Parce que si ce n'ai pas le cas je t'y engage vivement.
    "Le train de tes injures roule sur le rail de mon indifférence."

    "Monde de merde !!"

    Georges Abitbol.

  5. #5
    Membre averti Avatar de Seth77
    Homme Profil pro
    Développeur .NET
    Inscrit en
    octobre 2005
    Messages
    1 428
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : octobre 2005
    Messages : 1 428
    Points : 411
    Points
    411
    Par défaut
    Citation Envoyé par worm83 Voir le message
    Tu n'utilise pas la packages nuget?
    Parce que si ce n'ai pas le cas je t'y engage vivement.
    Si, mais la j ai besoin de debugger NHibernate ...
    Il n y a pas de .pdb avec les packages NuGet.

  6. #6
    Membre éprouvé Avatar de worm83
    Homme Profil pro
    Architecte logiciel
    Inscrit en
    février 2010
    Messages
    459
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Architecte logiciel
    Secteur : Conseil

    Informations forums :
    Inscription : février 2010
    Messages : 459
    Points : 1 090
    Points
    1 090
    Par défaut
    Ok, je vois,

    je te donne une solution qui marchait très bien, c'est la configuration du serveur de symboles, cela te permet de conserver les packages nugets.

    http://talkingincode.com/2014/12/15/...debug-symbols/
    "Le train de tes injures roule sur le rail de mon indifférence."

    "Monde de merde !!"

    Georges Abitbol.

  7. #7
    Membre averti Avatar de Seth77
    Homme Profil pro
    Développeur .NET
    Inscrit en
    octobre 2005
    Messages
    1 428
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Développeur .NET
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : octobre 2005
    Messages : 1 428
    Points : 411
    Points
    411
    Par défaut
    Citation Envoyé par worm83 Voir le message
    Ok, je vois,

    je te donne une solution qui marchait très bien, c'est la configuration du serveur de symboles, cela te permet de conserver les packages nugets.

    http://talkingincode.com/2014/12/15/...debug-symbols/
    Merci

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 9
    Dernier message: 01/09/2012, 02h50
  2. Réponses: 1
    Dernier message: 19/07/2007, 16h09
  3. pti probleme de reference
    Par nassu dans le forum VBA Access
    Réponses: 4
    Dernier message: 07/05/2006, 22h09
  4. Probleme de references symboliques...
    Par Invité dans le forum Langage
    Réponses: 5
    Dernier message: 06/09/2005, 19h23
  5. Probleme heritage : References sur la table parente
    Par Belgar dans le forum PostgreSQL
    Réponses: 3
    Dernier message: 03/05/2005, 23h11

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo