Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

wxWidgets Discussion :

Lancement impossible


Sujet :

wxWidgets

  1. #1
    Membre à l'essai
    Lancement impossible
    Bonjour,

    J'avis déja évoqué mon problème et je le reprécise, car j'ai pu l'isoler.

    C'est trés simple je teste un programme minimal sou wxWdgets.
    Dans la fonction Onabout j'appelle une fonction f.

    Si

  2. #2
    Membre à l'essai
    Je reprend, excusez moi. Ca devient une mauvaise habitude. Désolé. Donc :

    - Si f est déclarée dans le projet tout se passe bien et f est bien executée lorsque je passe par la commande About.

    - Si f n'est pas déclarée dans le projet et appartient à une librairie statique lf.a (f étant d'ailleurs seule dans sa librairie), alors je linke avec lf.a, mais le run ne se lance pas. (et pas d'ereur au build).

    Je dois surement oublier quelque chose, peut-etre avec l'environnement wxWidhets faut -il déclarer une librairie quelque part ailleurs ?

    Ps : J'ai aussi essayé avec une librairie dynamique (.dll) mais exactement le meme comportement : Rien ne se passe au run et pourtant pas d'erreur au build.

  3. #3
    Membre averti
    Salut.

    Comment fais-tu pour exécuter la fonction f depuis l'application si elle n'est pas déclarée ?

  4. #4
    Membre à l'essai
    Dans le 1er scenario, la fonction f est attachée directement au projet (et déclarée dans l'application).
    Dans ce cas, je ne linke donc pas avec le librairie qui la contient. Le run fonctionne et je passe normalement par f à l’exécution.

    Dans le second scenario, celui qui pose problème, la fonction f n'est plus attachée au projet (mais toujours déclarée dans le code de l'appli bien sur).
    Ainsi, pour la retrouver, je linke cette fois avec la librairie qui la contient. Le build ne voit d'ailleurs aucune référence irrésolue, c'est donc bien qu'il la voit dans sa librairie.
    Le problème c'est que le run ne fait plus rien (et pas de message d'erreur).