IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Android Discussion :

Rendre mon application compatible au version<3.0


Sujet :

Android

  1. #1
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    septembre 2013
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2013
    Messages : 16
    Points : 15
    Points
    15
    Par défaut Rendre mon application compatible au version<3.0
    Bonsoir ,

    je travail sur un projet qui se base sur les fragments , le problème c'est que mon application s’exécute que avec les version d'android=>3.0 et non pas avec les versions<3.0 , vous pouvez m'aidez a adapter mon application aux version <3.0 et merci infiniment

  2. #2
    Nouveau membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    avril 2012
    Messages
    24
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : avril 2012
    Messages : 24
    Points : 33
    Points
    33
    Par défaut Support V4
    Bonjour,

    Les fragments ont apparus dans Android à partir de la version 3.x.Ainsi, l'utilisation des fragments et les nouveautés d'android sur les versions 2.x reste possible à travers la support v4 développées par Google et la support V7 aussi.
    Tu trouvera plus de détail http://developer.android.com/referen.../Fragment.html


    Donc il suffit de changer le imports des fragments en celle de la support V4.

    MErci

  3. #3
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    septembre 2013
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : septembre 2013
    Messages : 16
    Points : 15
    Points
    15
    Par défaut
    merci ,oui j import les fragments du support v4 et je change le minSdkVersion de 14 vers 8 puis quand j'execute une erreur est survenu .

    voila le projet sur lequel se base mon application http://www.androidhive.info/2013/10/...eable-views-1/ juste moi j'ai créer mon projet en :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     
    <uses-sdk
            android:minSdkVersion="11"
            android:targetSdkVersion="19" />

Discussions similaires

  1. Rendre mon application compatible tous devices
    Par Ghunter59 dans le forum Android
    Réponses: 6
    Dernier message: 13/10/2010, 18h04
  2. Comment rendre mon application installable ?
    Par hamadi_insat dans le forum Outils
    Réponses: 19
    Dernier message: 04/12/2007, 23h21
  3. rendre mon application authentifiable
    Par casaoui dans le forum ASP.NET
    Réponses: 4
    Dernier message: 18/06/2007, 09h40
  4. Réponses: 1
    Dernier message: 11/09/2006, 23h47
  5. Rendre mon application Access exécutable
    Par gaelj dans le forum Runtime
    Réponses: 3
    Dernier message: 31/08/2006, 15h39

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo