Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Zend_Form PHP Discussion :

Les caractères spéciaux empêchent l'affichage


Sujet :

Zend_Form PHP

  1. #1
    Nouveau membre du Club
    Profil pro
    Inscrit en
    octobre 2008
    Messages
    31
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2008
    Messages : 31
    Points : 25
    Points
    25
    Par défaut Les caractères spéciaux empêchent l'affichage
    Bonjour,

    Je ne sais pas si c'est un problème d'encodage, mais lorsque j'ai un accent dans un champ, je n'ai aucune valeur qui s'affiche.

    Pour afficher mes valeurs, je fais un :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    [lang=php]
    Controller :
    // $data array liste de mes champs + valeurs stockée dans la BDD
    $form->populate($data);
     
    View :
    echo $this->form;
    Le code fonctionne parfaitement sur un serveur, mais pas sur l'autre, mais impossible de trouvé la différence de config !

    Auriez-vous une solution ?

    Merci,
    Florent

  2. #2
    Membre régulier Avatar de Schaublore
    Homme Profil pro
    Manuel
    Inscrit en
    octobre 2014
    Messages
    61
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Manuel
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : octobre 2014
    Messages : 61
    Points : 93
    Points
    93
    Par défaut
    Salut Florent,

    J'ai deux piste:

    1) Si tu utilise l'IP 127.0.0.1 pour acceder a ton server ton navigateur peut prendre un comportement different qu'un IP WWW
    2) Jete un coup d'oeil sur tes locale


    T'chüss
    f(x) = y

Discussions similaires

  1. Réponses: 2
    Dernier message: 06/12/2010, 11h52
  2. [SAX] Problème avec les caractères spéciaux
    Par abdou.sahraoui dans le forum XML
    Réponses: 1
    Dernier message: 18/07/2005, 11h07
  3. [C#][ADO] Enlever les caractère spéciaux
    Par Oberown dans le forum Windows Forms
    Réponses: 3
    Dernier message: 10/01/2005, 19h38
  4. [Jsp] Supprimer les caractère spéciaux d'une chaine
    Par PeteMitchell dans le forum Servlets/JSP
    Réponses: 4
    Dernier message: 13/05/2004, 12h11
  5. Traiter les caractères spéciaux
    Par ricola dans le forum Langage
    Réponses: 2
    Dernier message: 20/02/2003, 10h23

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo