IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Langage PHP Discussion :

Pas d'accès au port avec easyPHP


Sujet :

Langage PHP

  1. #1
    Membre du Club
    Homme Profil pro
    Chargé d'affaire
    Inscrit en
    juillet 2011
    Messages
    40
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Chargé d'affaire
    Secteur : Distribution

    Informations forums :
    Inscription : juillet 2011
    Messages : 40
    Points : 44
    Points
    44
    Par défaut Pas d'accès au port avec easyPHP
    Bonjour à tous,
    Je n'arrive pas à accéder au port avec easyPHP.
    Mon code :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
     
    <?php
     exec("mode com15: BAUD=9600 PARITY=n DATA=8 STOP=1 to=off dtr=on rts=off");
     $fp =fopen("com15", "w");
     //$fp = fopen('/dev/ttyUSB0','r+'); //use this for Linux
    sleep(5);
     fwrite($fp,"1"); //write string to serial
    sleep(5);
     fclose($fp);
    ?>
    Je veux envoyer vers mon port COM15 un 1 pour allumer une led sur une arduino.
    Quand je le fais sous arduino, pas de soucis.
    Mais sous php, je vois la connection se faire mais rien pas de réaction ensuite.
    Si quelqu'un a une idée. Je sèche depuis hier dessus.
    Merci d'avance
    Stéphane

  2. #2
    Membre éprouvé Avatar de Shuty
    Homme Profil pro
    Ingénieur en développement
    Inscrit en
    octobre 2012
    Messages
    630
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Ingénieur en développement
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : octobre 2012
    Messages : 630
    Points : 1 172
    Points
    1 172
    Par défaut
    As tu créé une règle sur ton firewall ?

    A titre d'information, une connexion série, c'est tout simplement un fichier texte.
    On lit, on ecrit etc...

    Vérifie ton firewall, baudrate, bit stop/start etc..
    Agence web Dim'Solution, créateur de solutions numériques
    Sites internet, ecommerce, logiciels, applications mobiles, référencement (SEO), plugin Prestashop, Magento, WordPress, Joomla!...

    Cours de trading gratuit | Envoyer des sms gratuitement | Envoyer des fax gratuitement | Plateforme de Fax à l'international

  3. #3
    Membre du Club
    Homme Profil pro
    Chargé d'affaire
    Inscrit en
    juillet 2011
    Messages
    40
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Chargé d'affaire
    Secteur : Distribution

    Informations forums :
    Inscription : juillet 2011
    Messages : 40
    Points : 44
    Points
    44
    Par défaut
    mais j'ai toujours le même comportement.
    Lorsque je lance ma page, la connection s'ouvre car je vois la led s'allumer brièvement mais rien ne se passe ensuite.

    Si tu as des exemples qui marche, je suis preneur.
    Stéphane

  4. #4
    Membre éprouvé Avatar de Shuty
    Homme Profil pro
    Ingénieur en développement
    Inscrit en
    octobre 2012
    Messages
    630
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Ingénieur en développement
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : octobre 2012
    Messages : 630
    Points : 1 172
    Points
    1 172
    Par défaut
    Je recommence, as tu désactivé ton firewall ?

    Est tu sure que la connexion se fait bien ? As tu la bonne config au niveau du port série ?
    Agence web Dim'Solution, créateur de solutions numériques
    Sites internet, ecommerce, logiciels, applications mobiles, référencement (SEO), plugin Prestashop, Magento, WordPress, Joomla!...

    Cours de trading gratuit | Envoyer des sms gratuitement | Envoyer des fax gratuitement | Plateforme de Fax à l'international

Discussions similaires

  1. Réponses: 2
    Dernier message: 08/10/2009, 15h26
  2. Souci avec VS 2008, pas d'accès à certaines classes
    Par tortuegenie dans le forum Visual Studio
    Réponses: 1
    Dernier message: 20/05/2008, 10h24
  3. Conflit de port avec Apache (easyPHP)
    Par Erwan31 dans le forum IIS
    Réponses: 4
    Dernier message: 07/02/2008, 23h11
  4. MySQL : acces avec EasyPHP
    Par rockingstone dans le forum Requêtes
    Réponses: 3
    Dernier message: 05/07/2006, 19h40
  5. Comment changer le port de MySQL avec EasyPHP ?
    Par Yakurena dans le forum Installation
    Réponses: 1
    Dernier message: 29/04/2006, 21h29

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo