IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eric Python Discussion :

Paramétrer Eric5 sous Linux pour faire du PyQt5


Sujet :

Eric Python

  1. #1
    Membre régulier
    Homme Profil pro
    Inscrit en
    mai 2013
    Messages
    89
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2013
    Messages : 89
    Points : 91
    Points
    91
    Par défaut Paramétrer Eric5 sous Linux pour faire du PyQt5
    Bonjour,

    Je viens juste d'installer Eric 5 sous ma Manjaro en version 5.3.7-1 et lors du 1er démarrage, il me demande de sélectionner un menu. En lisant la doc suivante http://ceg.developpez.com/tutoriels/...et-qtdesigner/, je me rends compte que je dois finaliser l'installation.
    Vu que je veux coder en PyQT5, je me demandes ce qu je dois faire. Dans tous les cas, que dois-je faire (ou ne rien faire )

    Le détail de ma fenêtre de configuration sachant que j'ai PyQt4 et PyQt5 d'installer.


    Par avance Merci

    PS J’espère que la taille de l'image n'est pas trop grosse. Si c'est le cas, je peux mettre une miniature.

  2. #2
    Rédacteur/Modérateur

    Avatar de Jiyuu
    Homme Profil pro
    Développeur amateur
    Inscrit en
    janvier 2007
    Messages
    2 456
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Loire (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur amateur
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 2 456
    Points : 6 456
    Points
    6 456
    Billets dans le blog
    15
    Par défaut


    Pour coder avec Eric 5, je pense que tu n'as aucun réglage à faire. L'avantage d'être sous linux est que tu peux avoir PyQt 4 et PyQt 5 d'installer sur la même machine (enfin il me semble, j'avoue ne même pas avoir fait le test ).

    Par contre pour utiliser toutes les fonctionnalités de cet EDI ou en tout cas les principales je ne suis pas sûr que ça soit possible. Eric 5 est prévu pour être utilisé avec PyQt 4 et comme il y a pas mal de changement entre les deux versions de ce binding je crains qu'il y est quelques difficultés.

    La première sera de "traduire" correctement en *.py les *.ui.
    En effet, je pense (mais ne suis pas sûr) que Qt Designer est le même que tu sois en Qt 5 ou Qt 4, par contre la "traduction" en code Python ne sera pas du tout la même, il faut donc que tu utilises le bon outil. (bonne version de pyuic).

    Une fois ceci fait, il ne te restera plus qu'à faire des tests et surtout voir si au moment de générer Python depuis le fichier Qt Designer tu as bien la possibilité d'y ajouter les slots voulus (voir la fin de mon article).

    À l'occasion je ferai aussi des tests de mon coté, ça permettra de mettreà jour l'article.

    Bonne continuation.
    Initiation à Qt Quick et QML : Partie 1 - Partie 2
    En cas de besoin, pensez à la
    Mon site et mes tutoriaux sur Developpez.com
    Pas de question technique par MP... Les forums sont là pour ça

  3. #3
    Membre régulier
    Homme Profil pro
    Inscrit en
    mai 2013
    Messages
    89
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2013
    Messages : 89
    Points : 91
    Points
    91
    Par défaut
    Merci pour tes réponses.

    Et moi qui avait compris qu'Eric5 permettait de faire du QT 5.

    Je confirme que tu peux avoir sous Linux PyQt4 et PyQt5 installés en même temps à condition qu'un soit au moins compilé (du moins c'est sur pour PyQt5), vu que je suis sous Manjaro...................pas de problèmes.

  4. #4
    Rédacteur/Modérateur

    Avatar de Jiyuu
    Homme Profil pro
    Développeur amateur
    Inscrit en
    janvier 2007
    Messages
    2 456
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Loire (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur amateur
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 2 456
    Points : 6 456
    Points
    6 456
    Billets dans le blog
    15
    Par défaut
    A la base Eric 5 c'était pour différencier une installation nécessitant Python 2.x ou 3.x.
    Après je ne dis pas qu'il n'est pas possible de coder avec un programme en PyQt 5. J'ai juste un doute sur les fonctions qui font qu'Eric est un excellent outil de développement d'application PyQt.

    Le mieux est d'essayer
    Initiation à Qt Quick et QML : Partie 1 - Partie 2
    En cas de besoin, pensez à la
    Mon site et mes tutoriaux sur Developpez.com
    Pas de question technique par MP... Les forums sont là pour ça

Discussions similaires

  1. Live CD Linux pour faire du clustering
    Par developpeuse20 dans le forum Contribuez
    Réponses: 1
    Dernier message: 23/02/2010, 02h46
  2. Les logiciels sous Linux pour remplacer ceux sous Windows
    Par Nightfall dans le forum Contribuez
    Réponses: 23
    Dernier message: 15/02/2009, 23h21
  3. commande javac sous linux pour compiler
    Par root76 dans le forum Langage
    Réponses: 2
    Dernier message: 20/02/2007, 13h46
  4. [Perf]Eclipse rame sous linux, Que faire ?
    Par Zapan dans le forum Eclipse Java
    Réponses: 4
    Dernier message: 15/01/2006, 16h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo