IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre du Club
    Profil pro
    Inscrit en
    mars 2011
    Messages
    82
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2011
    Messages : 82
    Points : 67
    Points
    67
    Par défaut [Ubuntu 12.04 / Gnome 3.2.1 / Helios] Problème d'affichage de la documentation des fonctions
    Bonjour,

    J'ai un problème d'affichage de la documentation des fonctions :


    A noter que le bouton Open Web Browser ne fonctionne pas non plus apparemment.

    Je ne pense pas que ce soit un réel bug. Je pense qu'Eclipse attend un paramètre dans la config. Lequel ? et où ?

    Quelqu'un saurait-il m'indiquer comment résoudre ce problème ?

    Merci d'avance pour votre aide.
    Images attachées Images attachées  

  2. #2
    Membre du Club
    Profil pro
    Inscrit en
    mars 2011
    Messages
    82
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2011
    Messages : 82
    Points : 67
    Points
    67
    Par défaut
    Je pense avoir trouvé le fond du problème. Par contre, je ne vois comment le résoudre.

    En faisant des petites recherches plus poussées, J'ai configuré le bouton open web browser. Maintenant le bouton est fonctionnel. Par contre, ce n'est pas fonctionnel dans l'IDE. En voulant afficher une page web dans l'IDE, j'ai ceci comme message :
    embedded browser not available
    Lorsque je clique sur le bouton détail de l'erreur :
    No more handles [MOZILLA_FIVE_HOME='/usr/lib/xulrunner-addons'] (java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
    /opt/eclipse/configuration/org.eclipse.osgi/bundles/245/1/.cp/libswt-mozilla-gtk-3650.so: libxpcom.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
    no swt-mozilla-gtk in java.library.path
    /tmp/swtlib-32/libswt-mozilla-gtk-3650.so: libxpcom.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
    Can't load library: /tmp/swtlib-32/libswt-mozilla-gtk.so
    )
    org.eclipse.swt.SWTError: No more handles [MOZILLA_FIVE_HOME='/usr/lib/xulrunner-addons'] (java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
    /opt/eclipse/configuration/org.eclipse.osgi/bundles/245/1/.cp/libswt-mozilla-gtk-3650.so: libxpcom.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
    no swt-mozilla-gtk in java.library.path
    /tmp/swtlib-32/libswt-mozilla-gtk-3650.so: libxpcom.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
    Can't load library: /tmp/swtlib-32/libswt-mozilla-gtk.so
    )
    at org.eclipse.swt.SWT.error(SWT.java:4109)
    at org.eclipse.swt.browser.Mozilla.initMozilla(Mozilla.java:1703)
    at org.eclipse.swt.browser.Mozilla.create(Mozilla.java:637)
    at org.eclipse.swt.browser.Browser.<init>(Browser.java:119)
    at org.eclipse.ui.internal.browser.BrowserViewer.<init>(BrowserViewer.java:225)
    at org.eclipse.ui.internal.browser.WebBrowserEditor.createPartControl(WebBrowserEditor.java:78)
    at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)
    at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)
    at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
    at org.eclipse.ui.internal.EditorReference.getEditor(EditorReference.java:289)
    at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2863)
    at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2768)
    at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2760)
    at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2711)
    at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2707)
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2691)
    at org.eclipse.ui.actions.OpenWithMenu.openEditor(OpenWithMenu.java:331)
    at org.eclipse.ui.actions.OpenWithMenu$3.handleEvent(OpenWithMenu.java:215)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1258)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3552)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3171)
    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2629)
    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2593)
    at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2427)
    at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:670)
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:663)
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
    Caused by: java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
    /opt/eclipse/configuration/org.eclipse.osgi/bundles/245/1/.cp/libswt-mozilla-gtk-3650.so: libxpcom.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
    no swt-mozilla-gtk in java.library.path
    /tmp/swtlib-32/libswt-mozilla-gtk-3650.so: libxpcom.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
    Can't load library: /tmp/swtlib-32/libswt-mozilla-gtk.so

    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:267)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:174)
    at org.eclipse.swt.browser.Mozilla.initMozilla(Mozilla.java:1688)
    ... 41 more
    <<<EDIT
    En recherchant sur le web, je crois avoir trouvé le fond du problème. La version du browser qu'attend Eclipse n'est pas la même installée. Ce qui crée un conflit
    EDIT;

    Cependant, pouvez vous m'indiquer s'il y a une solution à ce souci ? Est ce quelqu'un a rencontré ce souci et comment y remédier ?

    Par avance merci

  3. #3
    Expert éminent
    Homme Profil pro
    Kebab manager
    Inscrit en
    septembre 2002
    Messages
    3 289
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : Belgique

    Informations professionnelles :
    Activité : Kebab manager

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 289
    Points : 6 030
    Points
    6 030
    Par défaut
    Salut,

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    /tmp/swtlib-32/libswt-mozilla-gtk-3650.so: libxpcom.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
    Can't load library: /tmp/swtlib-32/libswt-mozilla-gtk.so
    La librairies paratagée libxpcom.so n'est pas trouvée sur ton système. Tu peux rechercher la package ubuntu contenant cette libraire à l'aide de la commande apt-file.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
     
    #vérifier si le package apt-file est installé
    dpkg -l | grep -i apt-file
     
    #Si le package n'est pas installé
    sudo apt-get install apt-file 
     
    #Mettre à jour la base de données apt-file
    sudo apt-file update
     
    #effectuer une recherche de la librairies libxpcom.so
    sudo apt-file search libxpcom.so
    Alea Jacta Test!

Discussions similaires

  1. Problème d'affichage avec firefox (Ubuntu 7.10)
    Par GibertM dans le forum Débuter
    Réponses: 1
    Dernier message: 25/05/2008, 00h03
  2. [UBUNTU] Problème d'affichage obtiens un ecran bleue
    Par lionel34 dans le forum Ubuntu
    Réponses: 1
    Dernier message: 29/04/2007, 11h54
  3. [UBUNTU] Problème d'affichage avec Gnome
    Par cadurc dans le forum Ubuntu
    Réponses: 1
    Dernier message: 12/04/2007, 20h51
  4. Problème d'affichage sous Ubuntu
    Par bigben89 dans le forum OpenGL
    Réponses: 9
    Dernier message: 18/05/2006, 13h06

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo