IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eric Python Discussion :

[Eric 5] - Pythonw ne répond plus


Sujet :

Eric Python

  1. #1
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut [Eric 5] - Pythonw ne répond plus
    Bonjour
    Je suis sous Seven pro 64bits, j'ai installé Eric5, l'installation se passe très bien (python 3 et les autres dépendances sont installées)
    Dès que je lance eric5.bat, j'ai l'interface qui se charge mais tout de suite derrière j'ai le message d'erreur Windows comme quoi pythonw ne réponds plus.
    J'ai tenté les autre "bat" et ils fonctionnent (config etc.)
    Une idée?
    D'avance merci
    ps : je débute totalement dans ce monde python...

  2. #2
    Expert éminent

    Homme Profil pro
    Inscrit en
    octobre 2008
    Messages
    4 170
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2008
    Messages : 4 170
    Points : 6 547
    Points
    6 547
    Par défaut
    Salut,

    Lances-le dans une console pour voir si un message d'erreur apparaît.

    Copies le contenu du fichier bat sans les guillemets.

  3. #3
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut
    Bonjour
    J'ai lancé la commande sans passer par le .bat, sans guillemet et sans les "\\" remplacé par des "\"
    Aucun message d'erreur

  4. #4
    Expert éminent

    Homme Profil pro
    Inscrit en
    octobre 2008
    Messages
    4 170
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2008
    Messages : 4 170
    Points : 6 547
    Points
    6 547
    Par défaut
    Et l'inteface se referme aussitot ?


    Essayes avec l'option --debug en plus de la commande

  5. #5
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut
    L'interface reste en arrière plan, grissé tant que je n'ai pas cliquer sur fermer de l'alerte Windows.
    Avec --debug je n'ai rien de plus qui apparait dans la console

    Par contre je suis passé par "Python.exe" et non "Pythonw.exe" pour voir, le debug me donne comme erreur à la fin ceci:
    QWindowsWindow::setGeometry: Unable to set geometry 1280x1024+0+0 on 'UserInterf
    aceClassWindow'. Resulting geometry: 1280x1002+0+0 (frame: 8, 30, 8, 8).

  6. #6
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut
    Pour info, les bat pour sqlbrower, webbrowser editor et configure fonctionne sans problème.

  7. #7
    Expert éminent

    Homme Profil pro
    Inscrit en
    octobre 2008
    Messages
    4 170
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2008
    Messages : 4 170
    Points : 6 547
    Points
    6 547
    Par défaut
    Moi J'obtiens ceci :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
     
    vincent@djoliba:~$ eric5 --debug
    DEBUG:root:Importing Preferences
    Warning: translation file 'eric5_fr_FR'could not be loaded.
    Using default.
    DEBUG:root:Importing packages...
    DEBUG:root:Generating Main Window...
    DEBUG:root:Initializing Plugin Manager...
    DEBUG:root:Generating Main User Interface...
    DEBUG:root:Creating Layout...
    DEBUG:root:Creating Viewmanager...
    DEBUG:root:Creating sidebars...
    DEBUG:root:Creating Project Browser...
    DEBUG:root:Creating Multiproject Browser...
    DEBUG:root:Creating Template Viewer...
    DEBUG:root:Creating Debug Viewer...
    DEBUG:root:Creating Terminal...
    DEBUG:root:Creating Task Viewer...
    DEBUG:root:Creating Log Viewer...
    DEBUG:root:Creating Shell...
    DEBUG:root:Creating central widget...
    DEBUG:root:Created Layout
    DEBUG:root:Creating Debugger UI...
    DEBUG:root:Setting up connections...
    DEBUG:root:Initializing Tools...
    DEBUG:root:Registering Objects...
    DEBUG:root:Initializing Actions...
    DEBUG:root:Initializing Menus...
    DEBUG:root:Initializing Toolbars...
    DEBUG:root:Initializing Statusbar...
    DEBUG:root:Activating Plugins...
    DEBUG:root:Restoring Toolbarmanager...
    DEBUG:root:Setting View Profile...
    DEBUG:root:Reading Tasks...
    DEBUG:root:Reading Templates...
    DEBUG:root:Starting Debugger...
    Montres tout, il y a peut-être une ligne instructive au début du log

  8. #8
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut
    J'ai exactement la même chose avec en plus juste après le problème de résolution de fenêtre
    Un bug de mes pilotes graphiques?

  9. #9
    Expert éminent

    Homme Profil pro
    Inscrit en
    octobre 2008
    Messages
    4 170
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2008
    Messages : 4 170
    Points : 6 547
    Points
    6 547
    Par défaut
    Non je ne pense pas, ce problème devrait apparaître avec d'autres programme.


    Est-ce que dans ton dossier ...python3.x\site-packages\eric5\ tu as un fichier eric5config.py ?

    Je pose la question parce que j'ai eu le cas. Le fichier avait été créé à l'installation mais pas placé dans le bon dossier. Cela empêchait le démarrage du programme.

  10. #10
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut
    Le fichier en question est dans :
    C:\Python33\Lib\site-packages
    Je l'ai déplacé dans:
    C:\Python33\Lib\site-packages\eric5
    mais ça ne change rien, toujours un plantage

    Y aurait-il une option pour ne pas démarrer l'application en plein écran (enfin en mode étendu à l'espace de travail)
    C'est quand même bizarre cette erreur de taille de fenêtre dans le debug.

  11. #11
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut
    j'ai tenté avec les options --debug et --plugin, ça charge plus lentement et ça confirme que le plantage arrive quand l'erreur que j'ai indiqué plus haut arrive.

  12. #12
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut
    Ah bah j'avance
    Avec l'option --nosplash j'arrive à lancer l'appli
    ça me donne un message d'alerte type
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    QWindowsNativeFileDialogBase::selectNameFilter: Invalid parameter 'Dossiers' not found in 'Tous les fichiers (*)'.
    Avec la possibilité de choisir un répertoire

  13. #13
    Expert éminent

    Homme Profil pro
    Inscrit en
    octobre 2008
    Messages
    4 170
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2008
    Messages : 4 170
    Points : 6 547
    Points
    6 547
    Par défaut
    Salut,

    Le fichier config qui n'est pas copié à la bonne place à l'installation, pour moi c'est un bug.

    La dimension minimale de l'appli est effectivement exagérée, sur certains écran (i.e. 21 pouces) on déborde toujours.

    Normalement au premier démarrage tu devrais avoir la boîte de dialogue des préférences qui s'affiche, un fois tes préférences enregistrées, les prochains démarrages devraient s'exécuter normalement.

  14. #14
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut
    Le plantage apparait dès qu'une fenêtre de choix de fichier ou dossier est chargée
    Au démarrage c'était pour le dossier des projets.
    Là l'appli charge, dès que je veux ouvrir un projet, ça plante à ce moment là.
    Pourquoi ça plantait plus avant je ne sais pas, mais ce matin c'était le cas.
    Je vais retenter l'installation sur un autre poste au boulot avec seven 64bits aussi pour voir.

  15. #15
    Membre régulier
    Homme Profil pro
    Inscrit en
    février 2006
    Messages
    240
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Secteur : Industrie

    Informations forums :
    Inscription : février 2006
    Messages : 240
    Points : 93
    Points
    93
    Par défaut
    J'ai utilisé la méthode bourrin : virtualbox + ubuntu 12.10 + eric5 version linux. Ca fonctionne et pour ce que je vais en faire c'est suffisant (je débute dans la programmation python)
    On verra bien

Discussions similaires

  1. [Eclipse plantage]ne répond plus
    Par agougeon dans le forum Eclipse Java
    Réponses: 3
    Dernier message: 31/05/2006, 15h24
  2. Table qui ne répond plus, toutes operations impossible
    Par imer5 dans le forum PostgreSQL
    Réponses: 4
    Dernier message: 11/05/2006, 17h26
  3. MySQL ne répond plus ...
    Par Ickou dans le forum Outils
    Réponses: 19
    Dernier message: 10/05/2006, 19h01
  4. Programme ne répond plus.
    Par twizell dans le forum VB 6 et antérieur
    Réponses: 12
    Dernier message: 14/11/2005, 20h46
  5. Le dataset.bof ne répond plus.
    Par fplanglois dans le forum Bases de données
    Réponses: 6
    Dernier message: 23/03/2004, 10h45

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo