IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Bibliothèques et frameworks PHP Discussion :

Lib pour authentification google/facebook/etc


Sujet :

Bibliothèques et frameworks PHP

  1. #1
    Membre émérite
    Avatar de ymoreau
    Homme Profil pro
    Ingénieur étude et développement
    Inscrit en
    septembre 2005
    Messages
    1 154
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur étude et développement
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2005
    Messages : 1 154
    Points : 2 834
    Points
    2 834
    Par défaut Lib pour authentification google/facebook/etc
    Bonjour !
    Je crée un site assez simple, et j'aurais besoin que les utilisateurs puissent s'identifier, mais je n'ai pas envie de les obliger à se créer un compte. Je voudrais donc qu'ils puissent se connecter avec leur compte google/facebook/twitter etc.

    J'ai rapidement vu que chaque site propose une API pour faire ça. Mais j'aimerais savoir s'il existe une bibliothèque simple qui pourrait gérer ça. J'ai trouvé HybridAuth qui semble très complète (même trop) ; sauf que j'héberge le site chez free et que la version de PHP n'est pas assez récente (5.2 minimum selon l'erreur d'install).

    Est-ce qu'il existe d'autres lib susceptibles de fonctionner ? (et plus simplistes)
    Merci de vos suggestions :)

  2. #2
    Expert éminent sénior

    Profil pro
    Inscrit en
    septembre 2010
    Messages
    7 920
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : septembre 2010
    Messages : 7 920
    Points : 10 726
    Points
    10 726
    Par défaut
    regarde vers OAuth, je crois (mais pas sûr) qu'ils l'implementent tous

  3. #3
    Membre émérite
    Avatar de ymoreau
    Homme Profil pro
    Ingénieur étude et développement
    Inscrit en
    septembre 2005
    Messages
    1 154
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur étude et développement
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2005
    Messages : 1 154
    Points : 2 834
    Points
    2 834
    Par défaut
    La plupart l'implémentent oui. Mais ça reste juste un protocole, j'ai trouvé des lib php pour ça mais rien qui soit un peu "clé en main" comme l'est HybridAuth.

    Il y a une lib qui semble légère pour OpenId lightopenid (requiert PHP 5.1 seulement) ou bien php-openid qui semble un peu plus complexe, mais difficile de voir la différence en fonctionnalités à vue d'oeil. L'équivalent de oauth-php pour OAuth.

    Dans les deux cas c'est juste une lib qui permet l'utilisation du protocole, pas une lib qui automatiserait les connexions aux différents services, et l'interface HTML.

    Je crains qu'à part HybridAuth il n'existe pas de solution aussi simple à utiliser.

  4. #4
    Membre du Club
    Homme Profil pro
    Webmaster
    Inscrit en
    août 2011
    Messages
    68
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 27
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Webmaster

    Informations forums :
    Inscription : août 2011
    Messages : 68
    Points : 45
    Points
    45
    Par défaut
    Citation Envoyé par ymoreau Voir le message
    la version de PHP n'est pas assez récente (5.2 minimum selon l'erreur d'install).
    a ma connaissance, hybridauth utilise la 5.2 juste pour quelques fonctions telque json_endode et json_decode

    trouve le moyen de les rewrapper (pear.php.net/Services_JSON par exemple) sur votre version de php (>= 5.poussiere) et le tour est joué
    Je signe donc je suis

Discussions similaires

  1. Réponses: 3
    Dernier message: 03/04/2013, 09h56
  2. Microsoft et Facebook s'allient pour contrer Google+
    Par Gordon Fowler dans le forum Facebook
    Réponses: 21
    Dernier message: 13/07/2011, 12h36
  3. Réponses: 11
    Dernier message: 31/01/2011, 13h37
  4. servlet pour authentification sur google apps
    Par houssem-biz dans le forum Servlets/JSP
    Réponses: 1
    Dernier message: 02/05/2008, 13h50

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo