Publicité
+ Répondre à la discussion
Page 2 sur 2 PremièrePremière 12
Affichage des résultats 21 à 27 sur 27
  1. #21
    Inactif
    Inscrit en
    juillet 2007
    Messages
    4 555
    Détails du profil
    Informations forums :
    Inscription : juillet 2007
    Messages : 4 555
    Points : 5 009
    Points
    5 009

    Par défaut

    Citation Envoyé par GodGives Voir le message
    Code :
    1
    2
    3
    MsgBox SysInfo1.OSVersion (Réponse: 6)
    MsgBox SysInfo1.OSVersion (Réponse: 6)
    MsgBox SysInfo1.OSBuild (Réponse: 6000)
    Ben voilà ...

    Onb a trouvé :

    Si Sysinfo1.OsBuild >= 6000 ===>> ton Os est Vista ...

    A toi de continuer, maintenant (c'est l'heure de ma sieste).

  2. #22
    Membre habitué Avatar de GodGives
    Inscrit en
    août 2007
    Messages
    456
    Détails du profil
    Informations personnelles :
    Âge : 28

    Informations forums :
    Inscription : août 2007
    Messages : 456
    Points : 121
    Points
    121

    Par défaut

    Citation Envoyé par ucfoutu Voir le message
    Si Sysinfo1.OsBuild >= 6000 ===>> ton Os est Vista ...

    A toi de continuer, maintenant (c'est l'heure de ma sieste).
    Merci et bonne sieste à toi!!!
    je te laisserai de bonnes nouvelles quand tu reviendras; c'est promis!!!
    Les problèmes les plus complexes requièrent parfois les solutions les plus simples ...
    ________________________________________________________________________________________________________________________________________
    "Le plus fort n'est jamais assez fort pour être le maître, s'il ne transforme pas sa force en droit et son obéissance en devoir." J.J. Rousseau

  3. #23
    Membre habitué Avatar de GodGives
    Inscrit en
    août 2007
    Messages
    456
    Détails du profil
    Informations personnelles :
    Âge : 28

    Informations forums :
    Inscription : août 2007
    Messages : 456
    Points : 121
    Points
    121

    Par défaut

    Quand on n'est en mode test avec VB, le code d'activation ne marche qu'après fermeture du projet VB. Par contre, avec l'exécutable, le problème ne se pose pas!

    Comme je n'est pas encore trouvé le code qui me permet de savoir si AERO est activé ou pas, j'ai enlevé de mon projet, tous les codes et toutes les déclarations que j'ai apportés de nouveau, relatifs au problème d'activation de AERO; mais grande fut ma surprise de constater que même sans les codes, l'application, à son lancement, désactive AERO et l'active à sa fermeture.

    C'est magique ça! C'est dû à quoi? selon vous!
    Les problèmes les plus complexes requièrent parfois les solutions les plus simples ...
    ________________________________________________________________________________________________________________________________________
    "Le plus fort n'est jamais assez fort pour être le maître, s'il ne transforme pas sa force en droit et son obéissance en devoir." J.J. Rousseau

  4. #24
    Responsable Visual Basic

    Avatar de bbil
    Profil pro
    Inscrit en
    juin 2003
    Messages
    12 651
    Détails du profil
    Informations personnelles :
    Âge : 47
    Localisation : France, Ariège (Midi Pyrénées)

    Informations forums :
    Inscription : juin 2003
    Messages : 12 651
    Points : 21 958
    Points
    21 958

    Par défaut

    Citation Envoyé par GodGives Voir le message
    ....

    C'est magique ça! C'est dû à quoi? selon vous!

  5. #25
    Inactif
    Inscrit en
    juillet 2007
    Messages
    4 555
    Détails du profil
    Informations forums :
    Inscription : juillet 2007
    Messages : 4 555
    Points : 5 009
    Points
    5 009

    Par défaut

    Si vraiment ce n'est pas ton code qui le désactive (en es-tu vraiment certain ? tu ne fais pas de sous-classement pouvant troubler des drivers ? ou provoquer des instabilités d'affichage graphique , etc...)...
    Si ton code utilise le sous-classement : aurais-tu eu la mauvaise idée d'y mettre une instruction END ici ou là ?
    ===>> si donc, c'est VRAIMENT "spontané", cette question ne relève plus de VB, mais de la section de ce forum traitant de Windows et de Vista.
    Mais je n'y crois pas, car personne ne s'est jamais plaint, à ma connaissance !

    En ce qui me concerne, le sujet que tu as ouvert sous VB peut maintenant être fermé.

  6. #26
    Membre habitué Avatar de GodGives
    Inscrit en
    août 2007
    Messages
    456
    Détails du profil
    Informations personnelles :
    Âge : 28

    Informations forums :
    Inscription : août 2007
    Messages : 456
    Points : 121
    Points
    121

    Par défaut

    Le problème, c'est que ce n'est pas moi qui vais utiliser l'application! donc je peux tout en oeuvre pour faciliter la vie aux utilisateurs finaux!!!

    Néanmoins, merci pour la proposition!!!

    Ce problème ne se posait pas avant que je ne mette les codes dans le projet. Et curieusement, malgré que j'ai enlevé tous les codes, le programma marche comme s'ils demeurent toujours!!!
    Les problèmes les plus complexes requièrent parfois les solutions les plus simples ...
    ________________________________________________________________________________________________________________________________________
    "Le plus fort n'est jamais assez fort pour être le maître, s'il ne transforme pas sa force en droit et son obéissance en devoir." J.J. Rousseau

  7. #27
    Responsable Visual Basic

    Avatar de bbil
    Profil pro
    Inscrit en
    juin 2003
    Messages
    12 651
    Détails du profil
    Informations personnelles :
    Âge : 47
    Localisation : France, Ariège (Midi Pyrénées)

    Informations forums :
    Inscription : juin 2003
    Messages : 12 651
    Points : 21 958
    Points
    21 958

    Par défaut

    tu as regardé la case à cocher : "Désactiver la composition du Bureau" ?

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •