Publicité
+ Répondre à la discussion Actualité déjà publiée
Affichage des résultats 1 à 3 sur 3
  1. #1
    Rédacteur
    Avatar de danielhagnoul
    Homme Profil pro Daniel Hagnoul
    Étudiant perpétuel
    Inscrit en
    février 2009
    Messages
    4 519
    Détails du profil
    Informations personnelles :
    Nom : Homme Daniel Hagnoul
    Âge : 63
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant perpétuel
    Secteur : Enseignement

    Informations forums :
    Inscription : février 2009
    Messages : 4 519
    Points : 16 468
    Points
    16 468

    Par défaut Avalanche de nouveautés jQuery

    Avalanche de nouveautés jQuery
    Sortie de jQuery 1.9.0, du plugin jQuery Migrate 1.0.0 et de jQuery 2.0.0 bêta

    N'oubliez pas de lire les informations contenues dans le guide de mise à niveau.

    jQuery 1.9 et 2.0 ont la même API, plusieurs fonctionnalités obsolètes ont été retirées des deux versions.

    jQuery 1.9 fonctionne sur les navigateurs obsolètes à partir d'IE6.

    jQuery 2.0 est débarrassé des rustines nécessaires pour être compatibles avec les navigateurs obsolètes, IE8 et moins. Il est moins "lourd" et plus rapide que la version 1.9.

    Les deux versions seront maintenues en parallèle.

    Le plugin Migrate sert à détecter les fonctionnalités obsolètes, il permet, mais c'est un pis aller, de faire fonctionner du vieux code avec les nouvelles versions de jQuery.

    Code :
    1
    2
    <script src="http://code.jquery.com/jquery-1.9.0.js"></script>
    <script src="http://code.jquery.com/jquery-migrate-1.0.0.js"></script>
    Code :
    1
    2
    <script src="http://code.jquery.com/jquery-2.0.0b1.js"></script>
    <script src="http://code.jquery.com/jquery-migrate-1.0.0.js"></script>
    N'oubliez pas d'activer la console pour voir les messages "JQMIGRATE".

    Il faudra plusieurs semaines pour inclure toutes les nouveautés dans la documentation officielle.

    Pour les nouveautés, merci de relire dans l'ordre :
    1. Annonces concernant l'évolution du noyau de jQuery
    2. jQuery 1.9.0 b1 est disponible pour tests
    3. jQuery 1.9.0 rc1 et le plugin Migrate 1.0.0 rc1 sont disponibles pour tests


    La version 2.0.0 bêta est le résultat d'un grand nettoyage, elle est 10 % moins "lourde" que la version 1.9.0. Mais le travail de nettoyage et la modification du code pour utiliser toutes les nouveautés disponibles dans les navigateurs non obsolètes sont loin d'être terminés.

    Références

    Liste des modifications

    Source

    Propositions de Q/R pour la FAQ jQuery

    plugin dialogModal

    Si un message vous a aidé ou vous semble pertinent, votez pour lui !

  2. #2
    Membre éclairé
    Avatar de Kenaryn
    Homme Profil pro Aurélien PLAZZOTTA
    En formation continue Concepteur-Développeur RNCP niveau II
    Inscrit en
    juillet 2006
    Messages
    128
    Détails du profil
    Informations personnelles :
    Nom : Homme Aurélien PLAZZOTTA
    Âge : 29
    Localisation : France, Loiret (Centre)

    Informations professionnelles :
    Activité : En formation continue Concepteur-Développeur RNCP niveau II

    Informations forums :
    Inscription : juillet 2006
    Messages : 128
    Points : 315
    Points
    315

    Par défaut

    Merci pour l'article

    la 2.0.0 10% moins lourde que la 1.9.0 et c'est pas terminé ? whaou

    Sinon, petite question un peu hors sujet : "savez-vous pourquoi google n'héberge plus jquery depuis la 1.3.2?"

    EDIT:
    Merci au m'sieur du dessous :p

  3. #3
    Rédacteur
    Avatar de danielhagnoul
    Homme Profil pro Daniel Hagnoul
    Étudiant perpétuel
    Inscrit en
    février 2009
    Messages
    4 519
    Détails du profil
    Informations personnelles :
    Nom : Homme Daniel Hagnoul
    Âge : 63
    Localisation : Belgique

    Informations professionnelles :
    Activité : Étudiant perpétuel
    Secteur : Enseignement

    Informations forums :
    Inscription : février 2009
    Messages : 4 519
    Points : 16 468
    Points
    16 468

    Par défaut

    Citation Envoyé par Kenaryn Voir le message
    google n'héberge plus jquery depuis la 1.3.2
    Si ! Voir : https://developers.google.com/speed/libraries/devguide

    Propositions de Q/R pour la FAQ jQuery

    plugin dialogModal

    Si un message vous a aidé ou vous semble pertinent, votez pour lui !

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •