+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Invité de passage
    Homme Profil pro
    Webmaster
    Inscrit en
    juin 2011
    Messages
    15
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Webmaster
    Secteur : Service public

    Informations forums :
    Inscription : juin 2011
    Messages : 15
    Points : 3
    Points
    3

    Par défaut API Twitter en php bis

    Bonjour,

    j'utilise la bibliothèque php pour twitter : TwitterOAuth.php

    Elle fonctionne très bien avec un script.

    Mais avec un second script, elle ne fonctionne plus

    Le message d'erreur :

    Parse error: syntax error, unexpected T_CONST, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homez.119/lokazion/www/lagazette/TwitterOAuth.php on line 15

    La ligne concernée est dans TwitterOAuth.php :
    const VERSION = 0.621;

    Je ne comprends pas pourquoi cela fonctionne avec un script et non avec l'autre alors que je n'ai rien changé...

    Si vous pouvez m'éclairer ?

    Par avance merci

    cordialement

  2. #2
    Modérateur
    Avatar de grunk
    Homme Profil pro
    Dév. Web / Android
    Inscrit en
    août 2003
    Messages
    3 187
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : France, Côte d'Or (Bourgogne)

    Informations professionnelles :
    Activité : Dév. Web / Android
    Secteur : Industrie

    Informations forums :
    Inscription : août 2003
    Messages : 3 187
    Points : 7 646
    Points
    7 646

    Par défaut

    La solution ici

    C'est juste que tu utilise pas php 5.
    Pry Framework php5

  3. #3
    Invité de passage
    Homme Profil pro
    Webmaster
    Inscrit en
    juin 2011
    Messages
    15
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Webmaster
    Secteur : Service public

    Informations forums :
    Inscription : juin 2011
    Messages : 15
    Points : 3
    Points
    3

    Par défaut

    D'accord, autant pour moi. Cela fonctionne en activant php5 sur ovh (en ajoutant le 5 à .php).

    Mais mon script précédent tourne en .php, donc en 4.4.9 si j'en crois mon phpinfo(), sur le même serveur, dans le même dossier.

    En te remerciant.

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •