IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Langage Java Discussion :

Niveau source pas disponibles


Sujet :

Langage Java

  1. #1
    Membre habitué Avatar de Epica84
    Profil pro
    Étudiant
    Inscrit en
    décembre 2008
    Messages
    164
    Détails du profil
    Informations personnelles :
    Âge : 31
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : décembre 2008
    Messages : 164
    Points : 187
    Points
    187
    Par défaut Niveau source pas disponibles
    Bonjour,

    Je fais une application sous l'environnement Eclipse mais j'ai un souci de typage ...

    J'ai déjà tester les codes suivants :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    import java.util.ArrayList;
    class NomDeCaClasseEnCours
    {
    static ArrayList<Client> LesClients;
    public ArrayList<Client> LesClients;
    private ArrayList<Client> LesClients;
    }
    J'ai bien créer une feuille dans le même projet une feuille Client.java, mais rien à faire j'ai toujours la petite croix rouge qui m'indique "Erreur de syntaxe : les types paramétrés sont uniquement disponibles si le niveau source est 1.5 ".

    Si quelqu'un à une idée à me proposer je suis preneur.

    Cordialement Christophe
    ARLES, du 02 au 05 Avril 2010, Féria de Pâques.

  2. #2
    Membre éclairé Avatar de Heimdal
    Profil pro
    Inscrit en
    avril 2006
    Messages
    549
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2006
    Messages : 549
    Points : 718
    Points
    718
    Par défaut
    Salut c'est un problème de compilateur, il doit être réglé en 1.4.

    > clic droit sur ton projet
    > Propriétés
    > Java Compiler
    > Vérifie les infos du panel JDK Compliance
    tu devrais avoir 'compiler compliance level' > 1.5 (les génériques sont apparus en 1.5) et 'use default compliance setting' coché

  3. #3
    Membre habitué Avatar de Epica84
    Profil pro
    Étudiant
    Inscrit en
    décembre 2008
    Messages
    164
    Détails du profil
    Informations personnelles :
    Âge : 31
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : décembre 2008
    Messages : 164
    Points : 187
    Points
    187
    Par défaut
    Merci, pour le moment j'ai plus d'erreur je vais voir au moment de la compilation si sa marche ...

    Je vous tiens au courant.

    Merci pour l'aide si rapide
    ARLES, du 02 au 05 Avril 2010, Féria de Pâques.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 3
    Dernier message: 31/05/2012, 15h09
  2. [SOAP] ressource /rpcrouter pas disponible
    Par thanathz dans le forum XML/XSL et SOAP
    Réponses: 4
    Dernier message: 23/11/2005, 12h19
  3. erreur 1722 le serveur RPC n'est pas disponible
    Par StyleXP dans le forum Windows XP
    Réponses: 1
    Dernier message: 13/11/2005, 20h23
  4. [Servlet action n'est pas disponible]
    Par JauB dans le forum Servlets/JSP
    Réponses: 3
    Dernier message: 04/11/2005, 09h23
  5. [Tomcat] [Eclipse] : Servlet n'est pas disponible
    Par mmed dans le forum Eclipse Java
    Réponses: 1
    Dernier message: 13/01/2005, 11h44

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo