IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

EDI, CMS, Outils, Scripts et API PHP Discussion :

Installation de Joomla sur mon serveur [Joomla!]


Sujet :

EDI, CMS, Outils, Scripts et API PHP

  1. #1
    Membre habitué
    Profil pro
    Inscrit en
    juin 2005
    Messages
    487
    Détails du profil
    Informations personnelles :
    Localisation : Canada

    Informations forums :
    Inscription : juin 2005
    Messages : 487
    Points : 132
    Points
    132
    Par défaut Installation de Joomla sur mon serveur
    Bonjour,

    je n'arrive pas à configurer xampp pour qu'il accède à ma base de données chez mon hébergeur.

    Est-ce qu'on peut utiliser joomla sans installer xampp, wamp ou easyphp ?

    Merci!

  2. #2
    Rédacteur
    Avatar de RideKick
    Homme Profil pro
    Directeur technique
    Inscrit en
    septembre 2006
    Messages
    5 914
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Directeur technique
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : septembre 2006
    Messages : 5 914
    Points : 12 572
    Points
    12 572
    Par défaut
    Joomla est un script fait en PHP , l'environnement associé a PHP est obligatoire pour que ledit PHP soit interprété !

    Qu'est ce que tu n'arrive pas a faire ?
    Pas de questions techniques en MP please

    Mon site perso

    Mon profil Viadeo

  3. #3
    Membre habitué
    Profil pro
    Inscrit en
    juin 2005
    Messages
    487
    Détails du profil
    Informations personnelles :
    Localisation : Canada

    Informations forums :
    Inscription : juin 2005
    Messages : 487
    Points : 132
    Points
    132
    Par défaut
    Merci de ton aide!

    J'ai installé Xampp et ça semble fonctionné mais je voudrais accéder à mes tables chez mon hébergeur et je n'y arrive pas.

    J'ai installé joomla et après avoir complété l'installation, je reçois ce message:
    N'OUBLIEZ PAS DE SUPPRIMER COMPLÈTEMENT LE RÉPERTOIRE 'INSTALLATION'
    . Vous ne pourrez pas aller au delà de cette étape tant que le répertoire d'installation ne sera pas supprimé. Ceci pour des raisons de sécurité de Joomla!.
    Cliquer ici lorsque le répertoire aura été supprimé

    J'ai effacé le répertoire installation du répertoire joomla et je clique sur cliquer ici...

    rien ne se passe!

  4. #4
    Membre averti
    Avatar de opware2000
    Profil pro
    Inscrit en
    octobre 2006
    Messages
    243
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2006
    Messages : 243
    Points : 367
    Points
    367
    Par défaut
    supprime le fichier install.php également

  5. #5
    Rédacteur
    Avatar de RideKick
    Homme Profil pro
    Directeur technique
    Inscrit en
    septembre 2006
    Messages
    5 914
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Directeur technique
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : septembre 2006
    Messages : 5 914
    Points : 12 572
    Points
    12 572
    Par défaut
    mais tu installe joomla en local ou chez ton hebergeur ?

    de toute façon tu dois supprimer le répertoire installation dans le répertoire joomla de ton site web !
    Pas de questions techniques en MP please

    Mon site perso

    Mon profil Viadeo

  6. #6
    Membre habitué
    Profil pro
    Inscrit en
    juin 2005
    Messages
    487
    Détails du profil
    Informations personnelles :
    Localisation : Canada

    Informations forums :
    Inscription : juin 2005
    Messages : 487
    Points : 132
    Points
    132
    Par défaut
    J'ai installé joomla sur mon poste.

  7. #7
    Membre habitué
    Profil pro
    Inscrit en
    juin 2005
    Messages
    487
    Détails du profil
    Informations personnelles :
    Localisation : Canada

    Informations forums :
    Inscription : juin 2005
    Messages : 487
    Points : 132
    Points
    132
    Par défaut
    J'ai aussi effacé le fichier install.php et j'Ai encore le même message sans pouvoir aller plus loin.

  8. #8
    Membre averti
    Avatar de opware2000
    Profil pro
    Inscrit en
    octobre 2006
    Messages
    243
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2006
    Messages : 243
    Points : 367
    Points
    367
    Par défaut
    Citation Envoyé par fourniey Voir le message
    J'ai installé Xampp et ça semble fonctionné mais je voudrais accéder à mes tables chez mon hébergeur et je n'y arrive pas.
    euh attend j'ai pas tout compris là

    si tu utilise Xampp c'est que tu es en local, donc les tables de ta base de donnée sont locales elles aussi.
    sinon tu travailles chez ton hébergeur et là tu fais tout à distance.

  9. #9
    Membre habitué
    Profil pro
    Inscrit en
    juin 2005
    Messages
    487
    Détails du profil
    Informations personnelles :
    Localisation : Canada

    Informations forums :
    Inscription : juin 2005
    Messages : 487
    Points : 132
    Points
    132
    Par défaut
    Je travaille en local mais j'aimerais essayé le tout avec mes tables actuellement chez mon hébergeur.

  10. #10
    Membre averti
    Avatar de opware2000
    Profil pro
    Inscrit en
    octobre 2006
    Messages
    243
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2006
    Messages : 243
    Points : 367
    Points
    367
    Par défaut
    le plus simple alors est de tout installer chez ton hébergeur
    Xampp ne sert à créer un serveur sur ton ordi local

  11. #11
    Membre habitué
    Profil pro
    Inscrit en
    juin 2005
    Messages
    487
    Détails du profil
    Informations personnelles :
    Localisation : Canada

    Informations forums :
    Inscription : juin 2005
    Messages : 487
    Points : 132
    Points
    132
    Par défaut
    Je voulais pouvoir travailler avec mon portable ou je n'ai pas accès à internet.

  12. #12
    Membre averti
    Avatar de opware2000
    Profil pro
    Inscrit en
    octobre 2006
    Messages
    243
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2006
    Messages : 243
    Points : 367
    Points
    367
    Par défaut
    Donc ca résout ton probleme : les tables doivent être elles aussi en local.
    d'ailleurs c'est très rare les hébergeurs qui autorisent des utilisateurs distant à se connecter à leurs base mysql.

  13. #13
    Membre habitué
    Profil pro
    Inscrit en
    juin 2005
    Messages
    487
    Détails du profil
    Informations personnelles :
    Localisation : Canada

    Informations forums :
    Inscription : juin 2005
    Messages : 487
    Points : 132
    Points
    132
    Par défaut
    Comment je peux transférer mes tables de mon hébergeur à chez-moi ?

  14. #14
    Membre averti
    Avatar de opware2000
    Profil pro
    Inscrit en
    octobre 2006
    Messages
    243
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2006
    Messages : 243
    Points : 367
    Points
    367
    Par défaut
    grace à phpmyadmin, tu fait Exporter au format SQL zippé
    et sur phpmyadmin local tu fait un import

  15. #15
    Membre habitué
    Profil pro
    Inscrit en
    juin 2005
    Messages
    487
    Détails du profil
    Informations personnelles :
    Localisation : Canada

    Informations forums :
    Inscription : juin 2005
    Messages : 487
    Points : 132
    Points
    132
    Par défaut
    Citation Envoyé par opware2000 Voir le message
    grace à phpmyadmin, tu fait Exporter au format SQL zippé
    et sur phpmyadmin local tu fait un import
    J'ai fait cela mais tous mes accents ont été massacré ...

  16. #16
    Membre averti
    Avatar de opware2000
    Profil pro
    Inscrit en
    octobre 2006
    Messages
    243
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Loire (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2006
    Messages : 243
    Points : 367
    Points
    367
    Par défaut
    aie ta base sur ton ordi perso est dans un format différent de celle distante, vérifie les l'une est en utf-8, l'autre en iso-8859-1 (latin1), change celle locale pour quelle soit du même type que celle distante

  17. #17
    Membre habitué
    Profil pro
    Inscrit en
    juin 2005
    Messages
    487
    Détails du profil
    Informations personnelles :
    Localisation : Canada

    Informations forums :
    Inscription : juin 2005
    Messages : 487
    Points : 132
    Points
    132
    Par défaut
    Je viens de faire le transfert en local et j'obtiens cette erreur:

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 684084 bytes) in C:\xampplite\phpMyAdmin\libraries\sqlparser.lib.php on line 334

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 6
    Dernier message: 14/10/2011, 23h43
  2. Installer un kaspersky sur mon serveur de Base de Données
    Par Ashleycole dans le forum Administration
    Réponses: 0
    Dernier message: 22/06/2009, 12h43
  3. Installation de packages sur mon serveur
    Par MasterapocA dans le forum Solaris
    Réponses: 1
    Dernier message: 19/03/2008, 12h02
  4. Réponses: 0
    Dernier message: 27/02/2008, 16h21
  5. [Calendrier] Agenda a installer sur mon serveur
    Par BenoitDenis dans le forum EDI, CMS, Outils, Scripts et API
    Réponses: 3
    Dernier message: 23/06/2006, 16h31

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo