IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Langage Perl Discussion :

Lancer une commande système avec des "


Sujet :

Langage Perl

  1. #1
    Expert éminent sénior
    Avatar de Caro-Line
    Profil pro
    Inscrit en
    mars 2007
    Messages
    9 458
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 9 458
    Points : 14 827
    Points
    14 827
    Par défaut Lancer une commande système avec des "
    Bonjour,
    Je cherche à lancer une commande système qui me retourne un résultat.
    Je fais donc (par exemple) :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
     
    $LigCom = '/soft/continuus6.3/bin/ccm query "cvtype=\'task\' and task_number=\'23811\'" -f "%release"';
     
    eval
    	{my $retour = `$LigCom`;};
    if($@)
    	{ print LOG "KO : ".$@."\n";
    	exit(1);}
    qui évidemment ne fonctionne pas (à cause des " et ' de ce que j'ai compris)et me retourne :
    KO : Insecure dependency in `` while running setgid ....etc...

    ccm est une commande du logiciel SYNERGY dont je suis sûre et qui ne modifie rien.
    N'y a-t-il vraiment pas moyen de lancer cette commande ? (si j'en crois tout ce que j'ai lu, apparemment non...)
    Comment puis-je faire du coup ?

    Caroline
    Règles du Forum

    Adepte de la maïeutique

  2. #2
    Membre actif
    Profil pro
    Inscrit en
    décembre 2005
    Messages
    172
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2005
    Messages : 172
    Points : 208
    Points
    208
    Par défaut
    Salut,

    essai avec q{}
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    $LigCom = q{/soft/continuus6.3/bin/ccm query "cvtype='task' and task_number='23811'" -f "%release"};
    --
    lami20j

  3. #3
    Expert éminent sénior
    Avatar de Caro-Line
    Profil pro
    Inscrit en
    mars 2007
    Messages
    9 458
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 9 458
    Points : 14 827
    Points
    14 827
    Par défaut
    Toujours pas.
    Maintenant j'ai :
    Insecure $ENV{PATH} while running setgid at ...

    Et pourtant en ligne de commande sur le serveur ça fonctionne.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    (ccm_root@bexs71) $ perl
    my $retour=`/soft/continuus6.3/bin/ccm query "cvtype='task' and task_number='23811'" -f "%release"`;
    print $retour."\n";
    __END__
    1) BSI_GEN
    Règles du Forum

    Adepte de la maïeutique

  4. #4
    Expert éminent sénior
    Avatar de Caro-Line
    Profil pro
    Inscrit en
    mars 2007
    Messages
    9 458
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 9 458
    Points : 14 827
    Points
    14 827
    Par défaut
    OK bon comme toujours c'était sous mon nez...
    Le problème vient surtout de la personne qui lance la commande...
    En direct sur le serveur j'ai le bon identifiant, mais pas quand le script est lancé.
    Merci pour l'aide...
    Règles du Forum

    Adepte de la maïeutique

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 3
    Dernier message: 17/04/2008, 16h01
  2. lancer une commande unix avec perl
    Par dm_manu dans le forum Langage
    Réponses: 1
    Dernier message: 02/08/2006, 20h41
  3. [Système] lancer une commande système
    Par rfufu dans le forum Langage
    Réponses: 4
    Dernier message: 17/06/2006, 17h12
  4. lancer une commande système avec jbuilder
    Par xs_nady dans le forum JBuilder
    Réponses: 1
    Dernier message: 28/03/2006, 05h54
  5. Lancer une commande système avec VC++
    Par xs_nady dans le forum MFC
    Réponses: 1
    Dernier message: 17/03/2006, 15h03

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo