IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

WordPress PHP Discussion :

Recopie site wordpress d'un hébergement vers un autre


Sujet :

WordPress PHP

  1. #1
    Membre confirmé
    Profil pro
    Inscrit en
    Février 2010
    Messages
    127
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2010
    Messages : 127
    Par défaut Recopie site wordpress d'un hébergement vers un autre
    Bonjour,

    J'ai un site web sous Wordpress qui était hébergé sur OVH. J'ai changé d'hébergement pour une offre moins chère toujours sur OVH.

    1) J'ai recopié l'arborescence www sur le nouvel hébergement.
    2) J'ai recopié la base de donnée également.

    J'ai vu que cela ne fonctionnait pas car il y avait dans les fichiers une référence à l'arborescence sous la forme "home/identifiant/www/etc." or l'identifiant du nouvel hébergement était différent de celui de l'ancien. J'ai donc changé l'identifiant partout dans le code et aussi dans le script de mise à jour de la base de données.

    Malgré cela j'ai une erreur qui s'affiche au lancement :

    "Fatal error: Uncaught Error: Call to undefined function esc_sql() in /home/xirsbuu/www/wp-includes/option.php:625 Stack trace: #0 /home/xirsbuu/www/wp-includes/functions.php(1787): wp_load_alloptions() #1 /home/xirsbuu/www/wp-includes/load.php(943): is_blog_installed() #2 /home/xirsbuu/www/wp-settings.php(180): wp_not_installed() #3 /home/xirsbuu/www/wp-config.php(100): require_once('/home/xirsbuu/w...') #4 /home/xirsbuu/www/wp-load.php(50): require_once('/home/xirsbuu/w...') #5 /home/xirsbuu/www/wp-admin/admin.php(35): require_once('/home/xirsbuu/w...') #6 /home/xirsbuu/www/wp-admin/index.php(10): require_once('/home/xirsbuu/w...') #7 {main} thrown in /home/xirsbuu/www/wp-includes/option.php on line 625

    Fatal error: Uncaught Error: Call to undefined function esc_sql() in /home/xirsbuu/www/wp-includes/option.php:625 Stack trace: #0 /home/xirsbuu/www/wp-includes/option.php(164): wp_load_alloptions() #1 /home/xirsbuu/www/wp-includes/l10n.php(63): get_option('WPLANG') #2 /home/xirsbuu/www/wp-includes/l10n.php(106): get_locale() #3 /home/xirsbuu/www/wp-includes/l10n.php(153): get_user_locale() #4 /home/xirsbuu/www/wp-includes/l10n.php(954): determine_locale() #5 /home/xirsbuu/www/wp-includes/class-wp-fatal-error-handler.php(49): load_default_textdomain() #6 [internal function]: WP_Fatal_Error_Handler->handle() #7 {main} thrown in /home/xirsbuu/www/wp-includes/option.php on line 625"
    Comme si Wordpress n'avait pas pu se lancer correctement.

    Une idée ??

    Merci !

  2. #2
    Membre confirmé
    Homme Profil pro
    Enseignant
    Inscrit en
    Février 2020
    Messages
    63
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 63
    Localisation : Belgique

    Informations professionnelles :
    Activité : Enseignant

    Informations forums :
    Inscription : Février 2020
    Messages : 63
    Par défaut
    Bonjour, tout d'abord je m'étonne que vous ayez dû migrer et recopier tout le site car normalement même si on downgrade une formule (on passe d'une formule d' hébergement à une autre moins chère), on conserve le contenu avec la nouvelle formule. Ici on dirait que vous avez réinstallé une nouvelle instance de wordpress comme si vous étiez reparti de zéro avec un nouveau compte sur un nouvel hébergement.
    Ici, l'erreur provient du coeur de wordpress dont un de ses fichiers fondamentaux n'a pas chargé la fonction esc_sql() au moment où elle est appelée (au tout début du lancement).
    Je pense que recopier le coeur de wordpress en réinstallant wordpress serait intéressant: téléchargez une version de wordpress qui correspond à celle utilisée sur le site (version 7.0, 6.9 ou antérieure) et copiez les dossiers wp-admin et wp-includes via FTP et les dossiers à la racine mais attention à ne pas remplacer le dossier wp-content qui contient les données du site ni le fichier wp-config.php qu'il ne faut pas écraser.
    Ainsi vous repartirez déjà avec une base propre de wordpress et si cela n'apporte pas de résultat, il faudra tester d'autres vérifications.

  3. #3
    Membre confirmé
    Profil pro
    Inscrit en
    Février 2010
    Messages
    127
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2010
    Messages : 127
    Par défaut
    Bonjour,

    Merci de votre conseil. Je pense que je me suis lancé dans de la bidouille... Je vais tenter ce que vous suggérez et je vous dirai ce que ça donne.

    Cordialement,
    Jean-Pierre

  4. #4
    Expert confirmé
    Avatar de fred1599
    Homme Profil pro
    Lead Dev Python
    Inscrit en
    Juillet 2006
    Messages
    4 992
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Meurthe et Moselle (Lorraine)

    Informations professionnelles :
    Activité : Lead Dev Python
    Secteur : Arts - Culture

    Informations forums :
    Inscription : Juillet 2006
    Messages : 4 992
    Par défaut
    Hello,

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Fatal error: Uncaught Error: Call to undefined function esc_sql() in /home/xirsbuu/www/wp-includes/option.php:625 Stack trace: #0 /home/xirsbuu/www/wp-includes/functions.php(1787): wp_load_alloptions() #1 /home/xirsbuu/www/wp-includes/load.php(943): is_blog_installed() #2 /home/xirsbuu/www/wp-settings.php(180): wp_not_installed() #3 /home/xirsbuu/www/wp-config.php(100): require_once('/home/xirsbuu/w...') #4 /home/xirsbuu/www/wp-load.php(50): require_once('/home/xirsbuu/w...') #5 /home/xirsbuu/www/wp-admin/admin.php(35): require_once('/home/xirsbuu/w...') #6 /home/xirsbuu/www/wp-admin/index.php(10): require_once('/home/xirsbuu/w...') #7 {main} thrown in /home/xirsbuu/www/wp-includes/option.php on line 625
    Quelle version PHP utilisiez vous avant votre migration ? Quelle est la version PHP après migration ?

    En changeant d'offre d'hébergement, le nouvel espace utilise peut-être une version de PHP trop récente (par exemple PHP 8.2 ou 8.3) alors que votre version de WordPress est ancienne, ou inversement.

    https://loremipsum.re/blog/migrer-de...ovh-wordpress/

    Si vous avez quelques erreurs vous pouvez aller sur ce site -> https://wpmarmite.com/erreurs-wordpress/ et https://duplicator.com/fr/wordpress-...ter-migration/
    Celui qui trouve sans chercher est celui qui a longtemps cherché sans trouver.(Bachelard)
    La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.(Einstein)

  5. #5
    Membre confirmé
    Profil pro
    Inscrit en
    Février 2010
    Messages
    127
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2010
    Messages : 127
    Par défaut
    Finalement je laisse tomber. Merci dans tous les cas !

  6. #6
    Membre confirmé
    Homme Profil pro
    Enseignant
    Inscrit en
    Février 2020
    Messages
    63
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 63
    Localisation : Belgique

    Informations professionnelles :
    Activité : Enseignant

    Informations forums :
    Inscription : Février 2020
    Messages : 63
    Par défaut
    Citation Envoyé par jpguiche Voir le message
    Finalement je laisse tomber. Merci dans tous les cas !
    C'est dommage d'abandonner si le site était opérationnel. Il suffit de faire quelques vérifications. Si vous le souhaitez, je peux y regarder.

  7. #7
    Membre confirmé
    Profil pro
    Inscrit en
    Février 2010
    Messages
    127
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2010
    Messages : 127
    Par défaut
    Citation Envoyé par Mister Socrates Voir le message
    C'est dommage d'abandonner si le site était opérationnel. Il suffit de faire quelques vérifications. Si vous le souhaitez, je peux y regarder.
    Merci, c'est super sympa. Mais mon site était prévu pour mon activité (coaching et intelligence collective en l'occurrence) et je suis maintenant à la retraite. Mon idée est donc de garder le nom de domaine et de réécrire un site minimal d'une page pour indiquer les activités que je souhaite garder. La seule chose qui m'embête c'est que j'aurais aimé pouvoir visualiser mon ancien site (sur un serveur local). Je n'en ai qu'une sauvegarde, cela ne me permet pas de "voir" son contenu. J'ai sauvegardé l'arborescence www + la base de donnée et également fait un backup avec updraftPlus. Si éventuellement vous pouviez me dire comment à partir de là visualiser le site sur un serveur local, je suis preneur !

  8. #8
    Membre confirmé
    Homme Profil pro
    Enseignant
    Inscrit en
    Février 2020
    Messages
    63
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 63
    Localisation : Belgique

    Informations professionnelles :
    Activité : Enseignant

    Informations forums :
    Inscription : Février 2020
    Messages : 63
    Par défaut
    la méthode reste la même sur un serveur local. Vous devez installer un émulateur (càd un outil qui permettra de modifier votre pc en serveur) comme xamp (ou mamp si vous travaillez sur Mac). Vous avez donc un hébergement local appelé localhost que vous pouvez visualiser en tapant localhost dans l'url ou 192.168.1.1. Comme sur un hébergement en ligne, vous devez placer dans le dossier racine htdocs (qui correspond à www ou public_html en ligne) wordpress dézippé (il est téléchargeable sur le site de wordpress), la base de données et les fichiers. Vous obtiendrez ainsi la même arborescence de votre site.

  9. #9
    Membre confirmé
    Profil pro
    Inscrit en
    Février 2010
    Messages
    127
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : Février 2010
    Messages : 127
    Par défaut
    Merci pour ces explications très claires.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [WD-2010] Recopier certains paragraphes d'un fichier vers un autre fichier
    Par delphys dans le forum Word
    Réponses: 1
    Dernier message: 06/04/2013, 21h59
  2. Recopier des données d'une plage vers l'autre, problèmes rencontrés?
    Par nath-0-0 dans le forum Macros et VBA Excel
    Réponses: 3
    Dernier message: 10/06/2010, 15h59
  3. Recopier 2 caractères d'un edit vers un autre
    Par visualk dans le forum Débuter
    Réponses: 3
    Dernier message: 16/11/2008, 22h13
  4. Réponses: 0
    Dernier message: 29/07/2008, 17h34
  5. Recopier le contenu d'une feuille vers une autre
    Par Mimosa777 dans le forum Macros et VBA Excel
    Réponses: 1
    Dernier message: 24/03/2008, 19h42

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo