IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

XSL/XSLT/XPATH XML Discussion :

Xpath : Problème condition sur un repeater


Sujet :

XSL/XSLT/XPATH XML

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    Logisticien
    Inscrit en
    janvier 2022
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Logisticien

    Informations forums :
    Inscription : janvier 2022
    Messages : 1
    Points : 1
    Points
    1
    Par défaut Xpath : Problème condition sur un repeater
    Bonjour à tous,

    Avant toute chose je ne suis pas développeur, ce qui signifie que je suis loin d'être un expert en la matière ^^

    Pour le boulot je dois faire de l'éditique, et on travaille avec du XML et du Xpath.
    On confectionne la structure XML directement depuis notre ERP, qu'on charge ensuite dans Word grâce à un add-in.
    C'est grâce au Xpath qu'on va pouvoir mettre des attributs sur nos champs.

    Voici mon point bloquant :
    J'ai deux champs qui sont chargés dans ma structure qui sont ZUPOPN et ZZPOPN. Je veux qu'en fonction de la valeur d'un 3e champ qui s'appelle ZZALWT, ZUPOPN soit caché.
    J'ai mis un repeater sur ZUPOPN avec l'attribut suivant : /M3OutDocument/DataArea/Document/Subdocument/Lines/Line/Custom/ZZALWT[.!='6']

    Or, ça ne fonctionne pas ^^

    Si quelqu'un peut donc m'aider dans ma quête ce serait hyper sympa

    Merci d'avance à ceux qui m'aideront

  2. #2
    Membre émérite Avatar de tsuji
    Inscrit en
    octobre 2011
    Messages
    1 558
    Détails du profil
    Informations forums :
    Inscription : octobre 2011
    Messages : 1 558
    Points : 2 731
    Points
    2 731
    Par défaut
    Qu'entendez-vous attributs, repeater, caché ... Montrez le xml exemplaire, et on part de là.

Discussions similaires

  1. Problème condition sur la date
    Par iKeyyZ dans le forum Langage SQL
    Réponses: 2
    Dernier message: 02/05/2019, 09h58
  2. Réponses: 2
    Dernier message: 20/07/2012, 10h52
  3. [Batch] Problème condition sur variable et chaine de caractères
    Par Omote dans le forum Scripts/Batch
    Réponses: 1
    Dernier message: 10/10/2010, 04h37
  4. [SQL] Problème condition sur 1 table
    Par Dwain dans le forum Langage SQL
    Réponses: 3
    Dernier message: 27/02/2007, 19h51
  5. Problème: condition sur formulaire dans requête
    Par decour dans le forum Access
    Réponses: 1
    Dernier message: 17/10/2005, 23h27

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo