IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Windows Forms Discussion :

mon bouton chargeant mon form marche pas


Sujet :

Windows Forms

  1. #1
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    février 2021
    Messages
    12
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : février 2021
    Messages : 12
    Points : 4
    Points
    4
    Par défaut mon bouton chargeant mon form marche pas
    Bonsoir à vous !
    J'ai développé un code pour que mon DataGridView affiche un tableau à partir de données d'un fichier Excel et un bouton dans le même formulaire doit faire charger le tableau dans le DataGridView (qui n'est pas affiché de base).

    Malheureusement après avoir coder mon bouton, sans erreurs signalés par Visual Studio, mon bouton ne veut pas charger mes données dans le GridView.
    Avez vous des idées pour mon problème ?

    Voici le code de mon bouton:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
     
    private void btnCharger_Click(object sender, EventArgs e)
            {
                //string nomFichier ="*****.xlsx";
                //déclaration et utilisation d'un OLeDbConnection 
                    OleDbConnection Excel =
                    new OleDbConnection(@"Provider = Microsoft.ACE.OLEDB.12.0; Data Source =*****; Extended Properties = Excel 12.0 Xml;HDR=YES;");
                    Excel.Open();
                    DataTable tableDonnees = new DataTable();
                    //notre requête sélectionne toute les cellule de la Feuil1 
                    OleDbCommand cmd = new OleDbCommand("select * from [*****$]", Excel);
                    OleDbDataReader dr = cmd.ExecuteReader();
                    tableDonnees.Load(dr);
                    dtGridDonnees.DataSource = tableDonnees;
            }
    Merci à vous pour votre temps !

  2. #2
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    février 2021
    Messages
    12
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : février 2021
    Messages : 12
    Points : 4
    Points
    4
    Par défaut
    Salut à vous,
    J'ai réglé mon problème avec le designer de ma form dans Winforms, j'avais pas ça :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    this.btnCharger.Click += btnCharger_Click;
    dans le code de mon clique souris pour que l'évènement du clique sur le bouton puisse correctement se faire.

    Mais malheureusement j'ai un nouveau problème, maintenant c'est au niveau de l'ouverture de mon Excel que tout bug, j'ai utilisé le code suivant pour le connecter à mon GridView mais quand j'appuie sur le bouton dans le mode débug, une erreur compilation reviens tout le temps et m'empêche d'obtenir le résultat voulu :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    private void btnCharger_Click(object sender, EventArgs e)
            {
                //string nomFichier ="*****.xlsx";
                //déclaration et utilisation d'un OLeDbConnection 
                OleDbConnection Excel =
                    new OleDbConnection("Provider = Microsoft.ACE.OLEDB.12.0; Data Source =*****.xlsx; Extended Properties = Excel 12.0 Xml;HDR=YES;");
                    Excel.Open();
                    //notre requête sélectionne toute les cellule de la Feuil1 
                    OleDbCommand cmd = new OleDbCommand("select * from [*****$]", Excel);
                    OleDbDataReader dr = cmd.ExecuteReader();
                    tableDonnees.Load(dr);
                    dtGridDonnees.DataSource = tableDonnees;
            }
    Visual Studio me renvoi cette erreur : "System.InvalidOperationException*: 'Le fournisseur 'Microsoft.ACE.OLEDB.12.0' n'est pas inscrit sur l'ordinateur local.'
    Merci à vous pour l'aide future !

  3. #3
    Membre émérite
    Avatar de popo
    Homme Profil pro
    Analyste programmeur Delphi / C#
    Inscrit en
    mars 2005
    Messages
    1 656
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste programmeur Delphi / C#
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mars 2005
    Messages : 1 656
    Points : 2 978
    Points
    2 978
    Par défaut
    Colle ton message d'erreur sur Google et appuies sur la touche [Entrée]

  4. #4
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    février 2021
    Messages
    12
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : février 2021
    Messages : 12
    Points : 4
    Points
    4
    Par défaut
    Citation Envoyé par popo Voir le message
    Colle ton message d'erreur sur Google et appuies sur la touche [Entrée]
    Ne t'inquiète pas, j'ai trouvé le problème C'est pas avec ton message que tu m'aurai aidé.
    (PS : La prochaine avant de dire ça, dit toi que la personne a peut être chercher mais se tourne vers ce forum car il donne confiance et est accueillant au lieu de dire des choses si simple pour un senior dans le domaine)

  5. #5
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    février 2021
    Messages
    12
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 21
    Localisation : France, Bas Rhin (Alsace)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : février 2021
    Messages : 12
    Points : 4
    Points
    4
    Par défaut
    Pour régler ce genre de problèmes:
    - Vérifier que le bon formulaire et le bon outil est bien écrit en tant que fonctions/méthodes pour que l'action se fasse bien sur le bon outil.
    - Regardez dans le fichier "[VotreForm].Designer.cs" si les configurations de l'outil contiennent bien la méthode "EventHandler" (plus de détails ici : https://docs.microsoft.com/fr-fr/dot...r?view=net-5.0)
    Sinon regardez en fonction de s'il y a un code erreur ou non :)

    "Problème Résolu" pour ma part.

  6. #6
    Membre émérite
    Avatar de popo
    Homme Profil pro
    Analyste programmeur Delphi / C#
    Inscrit en
    mars 2005
    Messages
    1 656
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyste programmeur Delphi / C#
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mars 2005
    Messages : 1 656
    Points : 2 978
    Points
    2 978
    Par défaut
    Citation Envoyé par aynex Voir le message
    Salut à vous,
    J'ai réglé mon problème avec le designer de ma form dans Winforms, j'avais pas ça :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    this.btnCharger.Click += btnCharger_Click;
    dans le code de mon clique souris pour que l'évènement du clique sur le bouton puisse correctement se faire.
    ...

    Mais malheureusement j'ai un nouveau problème, maintenant c'est au niveau de l'ouverture de mon Excel que tout bug, j'ai utilisé le code suivant pour le connecter à mon GridView mais quand j'appuie sur le bouton dans le mode débug, une erreur
    Visual Studio me renvoi cette erreur : "System.InvalidOperationException*: 'Le fournisseur 'Microsoft.ACE.OLEDB.12.0' n'est pas inscrit sur l'ordinateur local.'
    Merci à vous pour l'aide future !
    Citation Envoyé par aynex Voir le message
    Ne t'inquiète pas, j'ai trouvé le problème C'est pas avec ton message que tu m'aurai aidé.
    (PS : La prochaine avant de dire ça, dit toi que la personne a peut être chercher mais se tourne vers ce forum car il donne confiance et est accueillant au lieu de dire des choses si simple pour un senior dans le domaine)
    Citation Envoyé par aynex Voir le message
    Pour régler ce genre de problèmes:
    - Vérifier que le bon formulaire et le bon outil est bien écrit en tant que fonctions/méthodes pour que l'action se fasse bien sur le bon outil.
    - Regardez dans le fichier "[VotreForm].Designer.cs" si les configurations de l'outil contiennent bien la méthode "EventHandler" (plus de détails ici : https://docs.microsoft.com/fr-fr/dot...r?view=net-5.0)
    Sinon regardez en fonction de s'il y a un code erreur ou non

    "Problème Résolu" pour ma part.
    Ton message disais que tu avais déjà réglé le problème du EventHandler.
    Ma réponse ne concernait donc pas ce problème là (puisque déjà résolu) mais celui de Microsoft.ACE.OLEDB.12.0 où justement la réponse est largement abordée sur le net (et donc facilement trouvable en tapant le message d'erreur sur Google).
    La prochaine fois avant de critiquer mes réponses dis toi que je ne suis pas dans ta tête et que je ne sais pas quels sont les termes que tu as cherché avant de poster sur le forum.
    Je t'ai donc fourni les termes à rechercher et avec lesquels j'étais certain que tu trouverais une réponse.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [AC-2003] Bouton "Click" qui ne marche pas
    Par Williamm dans le forum VBA Access
    Réponses: 2
    Dernier message: 22/07/2011, 12h02
  2. Bouton radio 'checked' ne marche pas avec echo
    Par girardeau dans le forum Langage
    Réponses: 2
    Dernier message: 24/10/2010, 01h34
  3. Bouton de commande ne marche pas
    Par monnile dans le forum IHM
    Réponses: 3
    Dernier message: 24/01/2008, 20h40
  4. Réponses: 2
    Dernier message: 22/07/2007, 22h39
  5. mon programme marche pas
    Par DindonSauvage dans le forum Langage
    Réponses: 5
    Dernier message: 16/02/2007, 12h51

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo