Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Nouveau Candidat au Club
    Mettre un proxy dans les paramètres d'un service SOAP (Angular 7)
    Bonjour à tous,

    J'utilise node-soap et ngx-soap pour utiliser un WSDL pour faire envoyer des données au travers SOAP à un Web Service, le tout codé sous Angular 7. Je débute au niveau de l'utilisation de SOAP et d'Angular 7.

    Je souhaite rajouter un proxy dans mon service soap mais j'ai du mal avec le request utilisé dans le code. Après quelques recherches, voici le code que j'ai trouvé pour mettre le proxy en place:

    Code typescript :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    var request = require('request');
    let requestWithDefaults = request.defaults({ proxy: myProxy, timeout: 5000, connection: 'keep-alive' });
    let soapClientOptions = { request: requestWithDefaults };
    this.soap
       .createClient('assets/wsdl/myWSDL.WSDL', soapClientOptions)
       .then(client => {
          client.setSecurity(new security.BasicAuthSecurity('USER', 'PASSWORD', {}));
          console.log('Client', client);
          this.client = client;
       })
       .catch(err => console.log('Error', err));


    Mais j'ai plein de messages d'erreurs de ce type :
    [FRONTEND] ERROR in ./node_modules/zlib/lib/zlib.js
    [FRONTEND] Module not found: Error: Can't resolve './zlib_bindings' in 'C:\Users\MyUser\MyProject\frontend\node_modules\zlib\lib'
    [FRONTEND] ERROR in ./node_modules/aws-sign2/index.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\aws-sign2'
    [FRONTEND] ERROR in ./node_modules/aws4/aws4.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\aws4'
    [FRONTEND] ERROR in ./node_modules/ecc-jsbn/index.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\ecc-jsbn'
    [FRONTEND] ERROR in ./node_modules/http-signature/lib/verify.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\http-signature\lib'
    [FRONTEND] ERROR in ./node_modules/http-signature/lib/signer.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\http-signature\lib'
    [FRONTEND] ERROR in ./node_modules/oauth-sign/index.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\oauth-sign'
    [FRONTEND] ERROR in ./node_modules/request/lib/helpers.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\request\lib'
    [FRONTEND] ERROR in ./node_modules/request/lib/oauth.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\request\lib'
    [FRONTEND] ERROR in ./node_modules/request/lib/hawk.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\request\lib'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/fingerprint.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/key.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/signature.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/private-key.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/certificate.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/identity.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/utils.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/dhe.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/formats/pem.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib\formats'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/formats/ssh-private.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib\formats'
    [FRONTEND] ERROR in ./node_modules/sshpk/lib/formats/openssh-cert.js
    [FRONTEND] Module not found: Error: Can't resolve 'crypto' in 'C:\Users\MyUser\MyProject\frontend\node_modules\sshpk\lib\formats'
    [FRONTEND] ERROR in ./node_modules/request/lib/har.js
    [FRONTEND] Module not found: Error: Can't resolve 'fs' in 'C:\Users\MyUser\MyProject\frontend\node_modules\request\lib'
    [FRONTEND] ERROR in ./node_modules/forever-agent/index.js
    [FRONTEND] Module not found: Error: Can't resolve 'http' in 'C:\Users\MyUser\MyProject\frontend\node_modules\forever-agent'
    [FRONTEND] ERROR in ./node_modules/http-signature/lib/signer.js
    [FRONTEND] Module not found: Error: Can't resolve 'http' in 'C:\Users\MyUser\MyProject\frontend\node_modules\http-signature\lib'
    [FRONTEND] ERROR in ./node_modules/request/request.js
    [FRONTEND] Module not found: Error: Can't resolve 'http' in 'C:\Users\MyUser\MyProject\frontend\node_modules\request'
    [FRONTEND] ERROR in ./node_modules/tunnel-agent/index.js
    [FRONTEND] Module not found: Error: Can't resolve 'http' in 'C:\Users\MyUser\MyProject\frontend\node_modules\tunnel-agent'
    [FRONTEND] ERROR in ./node_modules/forever-agent/index.js
    [FRONTEND] Module not found: Error: Can't resolve 'https' in 'C:\Users\MyUser\MyProject\frontend\node_modules\forever-agent'
    [FRONTEND] ERROR in ./node_modules/request/request.js
    [FRONTEND] Module not found: Error: Can't resolve 'https' in 'C:\Users\MyUser\MyProject\frontend\node_modules\request'
    [FRONTEND] ERROR in ./node_modules/tunnel-agent/index.js
    [FRONTEND] Module not found: Error: Can't resolve 'https' in 'C:\Users\MyUser\MyProject\frontend\node_modules\tunnel-agent'

    Mes tentatives après quelques recherches supplémentaires :

      Remplacer le
      Code typescript :Sélectionner tout -Visualiser dans une fenêtre à part
      var request = require('request');
      par un
      Code typescript :Sélectionner tout -Visualiser dans une fenêtre à part
      import * as request from 'node-modules'
      Car mon eslint n'apprécie pas quand c'est un import...
      Résultats :
      [FRONTEND] ERROR in ./node_modules/node-modules/index.js 1:0
      [FRONTEND] Module parse failed: Unexpected character '#' (1:0)
      [FRONTEND] You may need an appropriate loader to handle this file type.
      [FRONTEND] > #!/usr/bin/env node
      [FRONTEND] |
      [FRONTEND] | var request = require('request');


    Désolée si c'est un peu long mais je vous remercie tous d'avance pour des pistes pour pouvoir résoudre mon problème.


    EDIT: J'ai pu ignorer les messages d'erreurs en modifiant mon package.json en rajoutant
    Code json :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    "browser": {
        "http": false,
        "https": false,
        "crypto": false,
        "fs": false,
        "zlib": false
      }


    Mon application compile mais j'ai encore un message d'erreur:
    ERROR Error: Uncaught (in promise): ReferenceError: process is not defined
    ReferenceError: process is not defined
    at Object../node_modules/request/lib/helpers.js (helpers.js:8)
    at __webpack_require__ (bootstrap:78)
    at Object../node_modules/request/index.js (index.js:19)
    at __webpack_require__ (bootstrap:78)
    at new SOAPService (soap.service.ts:36)
    at core.js:14397
    at _callFactory (core.js:19846)
    at _createProviderInstance (core.js:19804)
    at resolveNgModuleDep (core.js:19779)
    at NgModuleRef_.push../node_modules/@angular/core/fesm5/core.js.NgModuleRef_.get (core.js:20473)
    at resolveDep (core.js:20844)
    at createClass (core.js:20724)
    at createDirectiveInstance (core.js:20595)
    at createViewNodes (core.js:21821)
    at createRootView (core.js:21735)
    at resolvePromise (zone.js:814) [angular]
    at resolvePromise (zone.js:771) [angular]
    at polyfills.js:6728:17 [angular]
    at Object.onInvokeTask (core.js:16147) [angular]
    at drainMicroTaskQueue (zone.js:595) []
    at ZoneTask.push../node_modules/zone.js/dist/zone.js.ZoneTask.invokeTask [as invoke] (zone.js:500) []
    at invokeTask (zone.js:1540) []
    at IDBRequest.globalZoneAwareCallback (zone.js:1566) []
    La ligne correspondant à mon SOAP service est
    Code typescript :Sélectionner tout -Visualiser dans une fenêtre à part
    var request = require('request');

  2. #2
    Expert éminent sénior
    T'es entrain d'essayer d'installer des dépendances pour Node.js dans un projet Angular. Ça risque pas de marcher !

    crypto, http, https, fs, font parti de l'API de Node.js, pas du navigateur.
    Un problème avec Git ? Essayez la FAQ, sinon posez votre question sur le forum.



    "Toute personne croyant qu'une croissance exponentielle peut durer indéfiniment dans un monde fini est soit un fou, soit un économiste."
    Kenneth E. Boulding

    "Les richesses naturelles sont inépuisables, car, sans cela, nous ne les obtiendrions pas gratuitement. Ne pouvant être ni multipliées ni épuisées, elles ne sont pas l’objet des sciences économiques."
    Jean-Baptiste Say, Traité d'économie politique, 1803.

    "/home/earth is 102% full ... please delete anyone you can."
    Inconnu

  3. #3
    Nouveau Candidat au Club
    Merci, j'ai pu régler ce problème mais j'ai un autre message d'erreur qui vient (cf. EDIT de mon post).

  4. #4
    Expert éminent sénior
    Masquer les erreurs ne règlera rien. Je répète, tu essaies d'utiliser des dépendances écrites pour node dans un projet front. Ça ne peut pas fonctionner.
    Un problème avec Git ? Essayez la FAQ, sinon posez votre question sur le forum.



    "Toute personne croyant qu'une croissance exponentielle peut durer indéfiniment dans un monde fini est soit un fou, soit un économiste."
    Kenneth E. Boulding

    "Les richesses naturelles sont inépuisables, car, sans cela, nous ne les obtiendrions pas gratuitement. Ne pouvant être ni multipliées ni épuisées, elles ne sont pas l’objet des sciences économiques."
    Jean-Baptiste Say, Traité d'économie politique, 1803.

    "/home/earth is 102% full ... please delete anyone you can."
    Inconnu

  5. #5
    Nouveau Candidat au Club
    Ok, mais comme je dis dans mon post d'origine, je débute avec l'utilisation d'Angular 7 et de SOAP. Comment fais-je pour appliquer mon proxy pour une requête SOAP si je ne peux pas utiliser des dépendances de node ? Est-ce que je dois tout mettre dans le backend de mon projet ?

    Quand j'ai trouvé la "solution", je ne savais pas que ça ne faisait que cacher mes erreurs et ne les résouds pas...

    EDIT: Je comprends ce que tu me dis après quelques fouilles sur le Web. Il faudrait que je suive ces indications en fait https://medium.com/code-divoire/creation-dune-application-web-avec-node-js-et-angular-v6-partie-2-frontend-820c998f6996 . Ils utilisent un exemple avec ngx-toaster.

###raw>template_hook.ano_emploi###