Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Discussion: problème avec identification [WD20]

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    TIEMELEKRO
    Inscrit en
    janvier 2015
    Messages
    88
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : TIEMELEKRO
    Secteur : Arts - Culture

    Informations forums :
    Inscription : janvier 2015
    Messages : 88
    Points : 0
    Points
    0

    Par défaut problème avec identification

    bonjour chers tous
    j'ai terminé mon projet mais j'ai un petit souci
    j'ai ma première fenêtre qui est celle de l'identification de l'utilisateur avec login et mot de passe et un bouton "Valider" dont voici le code:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    //Test champs non saisi
    SI SAI_login="" ET SAI_Mot_de_passe="" ALORS
    	Info("Veuillez saisir vos paramètres de connexion SVP!")
    	RepriseSaisie(SAI_login)
    SINON
    	SI SAI_login<>"" ET SAI_Mot_de_passe="" ALORS
    		Info("Merci de renseigner votre mot de passe!!!")
    		//replacer le curseur au niveau du champ mot de passe
    		RepriseSaisie(SAI_Mot_de_passe)
    		SINON
    		SI SAI_login="" ET SAI_Mot_de_passe<>"" ALORS
    			Info("Merci de renseigner votre login")
    			//replacer le curseur au niveau du champ login
    			RepriseSaisie(SAI_login)
    		SINON
    			//verification des infos au niveau de la base
    		HLitRecherche(Utlisateurs,Login,SAI_login)
    		SI HTrouve(Utlisateurs) ALORS
    			SI SAI_Mot_de_passe = Utlisateurs.Password ALORS
     
    				//Ferme la fenêtre et ouvre la fenêtre principale
    				Utilise(FEN_fenêtre_principale)
    				FIN
    			SINON
     
    				Info("Le mot de passe ou le login n'est pas correct")
    				SAI_login=""
    				SAI_Mot_de_passe=""
    				//replacer le curseur au niveau du champ de saisie du login
    				RepriseSaisie(SAI_login)
     
    			FIN
     
    		FIN
    	FIN
    FIN
    lors de la création de mon logiciel, j'ai inséré un login et un mot de passe standard qui doivent permettre à l'utilisateur d'accéder au logiciel
    Mon souci est que j'ai créé la procédure d'installation de l'exécutable, j'ai installé le logiciel. Quand je rentre les paramètres d'identification standards, il m'affiche ce message "Le mot de passe ou le login n'est pas correct".Je me demande si le login et le mot de passe standard n'ont pas été supprimés? si tel est le cas que dois-je faire?

  2. #2
    Rédacteur/Modérateur

    Homme Profil pro
    Ingénieur qualité méthodes
    Inscrit en
    décembre 2013
    Messages
    2 483
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur qualité méthodes
    Secteur : Conseil

    Informations forums :
    Inscription : décembre 2013
    Messages : 2 483
    Points : 5 329
    Points
    5 329

    Par défaut

    Regarde le fichier utilisateurs sur le poste en question. J'imagine qu'il est vide.
    N'oubliez pas le bouton Résolu si vous avez obtenu une réponse à votre question.

  3. #3
    Nouveau Candidat au Club
    Homme Profil pro
    TIEMELEKRO
    Inscrit en
    janvier 2015
    Messages
    88
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : TIEMELEKRO
    Secteur : Arts - Culture

    Informations forums :
    Inscription : janvier 2015
    Messages : 88
    Points : 0
    Points
    0

    Par défaut

    le fichier utilisateur n'est pas vide.
    Il contient un login et un mot de passe standard que l'utilisateur pourra changer s'il le veut une fois qu'il aura accès au logiciel.

  4. #4
    Rédacteur/Modérateur

    Homme Profil pro
    Ingénieur qualité méthodes
    Inscrit en
    décembre 2013
    Messages
    2 483
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur qualité méthodes
    Secteur : Conseil

    Informations forums :
    Inscription : décembre 2013
    Messages : 2 483
    Points : 5 329
    Points
    5 329

    Par défaut

    Au tout début de ton code, ajoute cette instruction :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    info ( utilisateurs..nomphysique, utilisateurs..repertoire)
    Ca va tedonner des informations qui vont te permettre de comprendre ce qui ne va pas.
    N'oubliez pas le bouton Résolu si vous avez obtenu une réponse à votre question.

  5. #5
    Nouveau Candidat au Club
    Homme Profil pro
    TIEMELEKRO
    Inscrit en
    janvier 2015
    Messages
    88
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : TIEMELEKRO
    Secteur : Arts - Culture

    Informations forums :
    Inscription : janvier 2015
    Messages : 88
    Points : 0
    Points
    0

    Par défaut

    j'ai placé le bout de code mais ce n'est pas ce que j'attends. il y a un message qui s'affiche
    Nom : Capture.JPG
Affichages : 52
Taille : 25,1 Ko
    j'ai l'impression que toutes les informations contenues dans les fichier lors de la création
    sont supprimées lors de la création de la procédure d'installation de l'exécutable.

  6. #6
    Rédacteur/Modérateur

    Homme Profil pro
    Ingénieur qualité méthodes
    Inscrit en
    décembre 2013
    Messages
    2 483
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur qualité méthodes
    Secteur : Conseil

    Informations forums :
    Inscription : décembre 2013
    Messages : 2 483
    Points : 5 329
    Points
    5 329

    Par défaut

    Oui, quand on met une instruction info(), il y a un message qui s'affiche ! Ca te surprend ????

    Les 2 lignes qui s'affichent, ça te dit où se trouve le fichier utilisateurs qui est utilisé par ton programme. Je te le dis, mais tu aurais dû le deviner par toi-même. Tu peux donc aller voir ce fichier, et effectivement, tu devrais constater que ce fichier est vide, en double-cliquant sur le fichier.

    Si tu veux que ta procédure d'installation copie certains fichiers, il faut le paramétrer dans la procédure d'installation. Si on ne le demande pas, Windev a un comportement standard, il installe le programme, mais pas les données.
    N'oubliez pas le bouton Résolu si vous avez obtenu une réponse à votre question.

  7. #7
    Nouveau Candidat au Club
    Homme Profil pro
    TIEMELEKRO
    Inscrit en
    janvier 2015
    Messages
    88
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : TIEMELEKRO
    Secteur : Arts - Culture

    Informations forums :
    Inscription : janvier 2015
    Messages : 88
    Points : 0
    Points
    0

    Par défaut

    Je ne suis pas surpris mais cela ne répond pas à ma préoccupation.
    En revanche, je ne savais pas qu'il fallait paramétrer la procédure d'installation pour que windew copie les données.
    Comment faire ce paramétrage?

  8. #8
    Rédacteur/Modérateur

    Homme Profil pro
    Ingénieur qualité méthodes
    Inscrit en
    décembre 2013
    Messages
    2 483
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur qualité méthodes
    Secteur : Conseil

    Informations forums :
    Inscription : décembre 2013
    Messages : 2 483
    Points : 5 329
    Points
    5 329

    Par défaut

    J'avais bien mis dans mon message qu'avec l'instruction Info() , ça allait te donner des informations pour comprendre le problème. Ca n'allait pas résoudre le problème directement.
    N'oubliez pas le bouton Résolu si vous avez obtenu une réponse à votre question.

  9. #9
    Nouveau Candidat au Club
    Homme Profil pro
    TIEMELEKRO
    Inscrit en
    janvier 2015
    Messages
    88
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : TIEMELEKRO
    Secteur : Arts - Culture

    Informations forums :
    Inscription : janvier 2015
    Messages : 88
    Points : 0
    Points
    0

    Par défaut

    Mon problème est:
    vue que la fenêtre d'identification de l'utilisateur "FEN_ID_Utilisateur est la première fenêtre du logiciel
    vue qu'à la création de la procédure d'installation, les fichiers sont vidés donc le mot de passe et le login standards enregistrés dans le fichier Utilisateur, sont supprimés, Comment faire pour que l'utilisateur puisse avoir accès au logiciel?

  10. #10
    Membre éprouvé
    Profil pro
    Inscrit en
    avril 2010
    Messages
    638
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2010
    Messages : 638
    Points : 1 003
    Points
    1 003

    Par défaut

    Bonjour.
    Creer par programmation l'utilisateur.

  11. #11
    Rédacteur/Modérateur

    Homme Profil pro
    Ingénieur qualité méthodes
    Inscrit en
    décembre 2013
    Messages
    2 483
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur qualité méthodes
    Secteur : Conseil

    Informations forums :
    Inscription : décembre 2013
    Messages : 2 483
    Points : 5 329
    Points
    5 329

    Par défaut

    Une soution, par exemple :
    Dans le code d'ouverture du projet , tu mets ça :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
     
    hcreatonsiinexistant("*")
    si hnbenr(utilisateurs) = 0 alors 
       utilisateurs.login = "AA"
       utilsateurs.psw = "BB"
       hajoute(utilisateurs)
    fin
    N'oubliez pas le bouton Résolu si vous avez obtenu une réponse à votre question.

  12. #12
    Nouveau Candidat au Club
    Homme Profil pro
    TIEMELEKRO
    Inscrit en
    janvier 2015
    Messages
    88
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : TIEMELEKRO
    Secteur : Arts - Culture

    Informations forums :
    Inscription : janvier 2015
    Messages : 88
    Points : 0
    Points
    0

    Par défaut

    Merci beaucoup.
    C'est exactement ce que je voulais.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. problème d'identification LDAP avec OpenLDAP
    Par doczorg dans le forum Websphere
    Réponses: 6
    Dernier message: 06/11/2007, 15h42
  2. [Administration] Problème avec identifications, journal vide
    Par semheis dans le forum Subversion
    Réponses: 1
    Dernier message: 03/09/2007, 12h07
  3. Problème avec les cookies d'identification du forum sur mon poste
    Par Flow_75 dans le forum Mode d'emploi & aide aux nouveaux
    Réponses: 3
    Dernier message: 13/03/2007, 10h57
  4. problème avec une identification
    Par boulette85 dans le forum ASP
    Réponses: 7
    Dernier message: 07/07/2006, 14h50
  5. Réponses: 2
    Dernier message: 22/12/2005, 21h23

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo