Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    août 2018
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : août 2018
    Messages : 4
    Points : 2
    Points
    2

    Par défaut [gulp] Erreur lors de la compilation

    Bonjour,

    j'ai un gros problème avec gulp qui ne compile plus !! voici e message d'erreur
    events.js:136
    throw er; // Unhandled 'error' event
    ^

    Error: spawn /usr/local/bin/compass ENOENT
    at _errnoException (util.js:1031:13)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:201:19)
    at onErrorNT (internal/child_process.js:389:16)
    at _combinedTickCallback (internal/process/next_tick.js:138:11)
    at process._tickCallback (internal/process/next_tick.js:180:9)
    j'ai par la suite essayer de tracer le chemin parcourus vavec cette function :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    (function() {
        var childProcess = require("child_process");
        var oldSpawn = childProcess.spawn;
        function mySpawn() {
            console.log('spawn called');
            console.log(arguments);
            var result = oldSpawn.apply(this, arguments);
            return result;
        }
        childProcess.spawn = mySpawn;
    })();
    j'ai continue à chercher avec cette ligne de commande :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    sudo gem install -n /usr/local/bin compass
    qui a donner ceci :
    Building native extensions. This could take a while...
    ERROR: Error installing compass:
    ERROR: Failed to build gem native extension.

    current directory: /Library/Ruby/Gems/2.3.0/gems/ffi-1.9.25/ext/ffi_c
    /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby -r ./siteconf20181206-12706-iqa94q.rb extconf.rb
    checking for ffi.h... *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of necessary
    libraries and/or headers. Check the mkmf.log file for more details. You may
    need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/$(RUBY_BASE_NAME)
    --with-ffi_c-dir
    --without-ffi_c-dir
    --with-ffi_c-include
    --without-ffi_c-include=${ffi_c-dir}/include
    --with-ffi_c-lib
    --without-ffi_c-lib=${ffi_c-dir}/lib
    --with-libffi-config
    --without-libffi-config
    --with-pkg-config
    --without-pkg-config
    /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:456:in `try_do': The compiler failed to generate an executable file. (RuntimeError)
    You have to install development tools first.
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:571:in `block in try_compile'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:524:in `with_werror'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:571:in `try_compile'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:1091:in `block in have_header'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:942:in `block in checking_for'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:350:in `block (2 levels) in postpone'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:320:in `open'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:350:in `block in postpone'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:320:in `open'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:346:in `postpone'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:941:in `checking_for'
    from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/mkmf.rb:1090:in `have_header'
    from extconf.rb:16:in `<main>'

    To see why this extension failed to compile, please check the mkmf.log which can be found here:

    /Library/Ruby/Gems/2.3.0/extensions/universal-darwin-16/2.3.0/ffi-1.9.25/mkmf.log

    extconf failed, exit code 1

    Gem files will remain installed in /Library/Ruby/Gems/2.3.0/gems/ffi-1.9.25 for inspection.
    Results logged to /Library/Ruby/Gems/2.3.0/extensions/universal-darwin-16/2.3.0/ffi-1.9.25/gem_make.out
    j'ai essayer aussi npm install ! enfin j'ai toujours pas trouver de solution a mon problème si quelqu'un a une idée je suis preneur !!

    merci d'avence
    Bonne journée.

  2. #2
    Modérateur
    Avatar de Marco46
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2005
    Messages
    3 655
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2005
    Messages : 3 655
    Points : 14 302
    Points
    14 302

    Par défaut

    si quelqu'un a une idée je suis preneur
    Ben faut juste lire la log :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    Error: spawn /usr/local/bin/compass ENOENT
    Ça veut dire que /usr/local/bin/compass n'existe pas sur le disque.

    C'est du a :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     
    Building native extensions. This could take a while...
    ERROR: Error installing compass:
    ERROR: Failed to build gem native extension.
    Du coup pas de compass.

    C'est ce problème qu'il faut régler.

    Pour avoir plus de détail la log te donne comme piste :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     
    Could not create Makefile due to some reason, probably lack of necessary
    libraries and/or headers. Check the mkmf.log file for more details. You may
    need configuration options.
    Du coup pour aller plus loin il faudrait que tu nous postes le contenu du fichier /Library/Ruby/Gems/2.3.0/extensions/universal-darwin-16/2.3.0/ffi-1.9.25/mkmf.log.

    Il faudrait aussi regarder la doc d'installation de compass pour voir quelles sont ses dépendances systèmes. Ya plein de mentions à Ruby, est-ce qu'il ne faudrait pas qu'il soit installé sur ton système au préalable ?
    "Toute personne croyant qu'une croissance exponentielle peut durer indéfiniment dans un monde fini est soit un fou, soit un économiste."
    Kenneth E. Boulding

    "Les richesses naturelles sont inépuisables, car, sans cela, nous ne les obtiendrions pas gratuitement. Ne pouvant être ni multipliées ni épuisées, elles ne sont pas l’objet des sciences économiques."
    Jean-Baptiste Say, Traité d'économie politique, 1803.

    "/home/earth is 102% full ... please delete anyone you can."
    Inconnu

  3. #3
    Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    août 2018
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : août 2018
    Messages : 4
    Points : 2
    Points
    2

    Par défaut voici le contenu du fichier mkmf.log

    Bonjour,

    voici le contenu du fichier de log !!

    package configuration for libffi is not found
    "xcrun clang -o conftest -I/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/include/ruby-2.3.0/universal-darwin16 -I/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/include/ruby-2.3.0/ruby/backward -I/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/include/ruby-2.3.0 -I. -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -D_DARWIN_UNLIMITED_SELECT -D_REENTRANT -g -Os -pipe -DHAVE_GCC_ATOMIC_BUILTINS -iwithsysroot /usr/local/libressl/include conftest.c -L. -L/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib -L. -L /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.Internal.sdk/usr/local/libressl/lib -L/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.12.Internal.sdk/usr/local/lib -arch x86_64 -arch i386 -lruby.2.3.0 -lpthread -ldl -lobjc "
    In file included from conftest.c:1:
    In file included from /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/include/ruby-2.3.0/ruby.h:33:
    /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/include/ruby-2.3.0/ruby/ruby.h:24:10: fatal error: 'ruby/config.h' file not found
    #include "ruby/config.h"
    ^~~~~~~~~~~~~~~
    1 error generated.
    checked program was:
    /* begin */
    1: #include "ruby.h"
    2:
    3: int main(int argc, char **argv)
    4: {
    5: return 0;
    6: }
    /* end */
    je vais regarder du coté de la doc de compass pourvoir si c'est ça vient de là!
    merci d'avance pour votre aide.
    du coup j'ai tenter l'instalation de compass avec la commande :
    et voici la réponse :
    Updating rubygems-update
    Fetching: rubygems-update-2.7.8.gem (100%)
    ERROR: While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /Library/Ruby/Gems/2.3.0 directory.
    j'ai quand meme essayer l'autre commande pour voir !!
    le réponse est la meme :
    Fetching: ffi-1.9.25.gem (100%)
    ERROR: While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /Library/Ruby/Gems/2.3.0 directory.
    j'espère que vous pourrez m'aider !!

  4. #4
    Modérateur
    Avatar de Marco46
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2005
    Messages
    3 655
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2005
    Messages : 3 655
    Points : 14 302
    Points
    14 302

    Par défaut

    Tes problèmes viennent de la gestion des droits de ton user lorsque tu as installé Ruby. Comment l'as-tu installé ? Il te faut aller voir du côté de la doc d'installation de Ruby pour Mac.

    Donc en manipulant gem tu te situes un niveau trop bas, gem c'est le package manager de Ruby, ton problème se situe lors de l'installation de Ruby. Il te faudra probablement désinstaller Ruby et le réinstaller proprement.
    "Toute personne croyant qu'une croissance exponentielle peut durer indéfiniment dans un monde fini est soit un fou, soit un économiste."
    Kenneth E. Boulding

    "Les richesses naturelles sont inépuisables, car, sans cela, nous ne les obtiendrions pas gratuitement. Ne pouvant être ni multipliées ni épuisées, elles ne sont pas l’objet des sciences économiques."
    Jean-Baptiste Say, Traité d'économie politique, 1803.

    "/home/earth is 102% full ... please delete anyone you can."
    Inconnu

  5. #5
    Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    août 2018
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : août 2018
    Messages : 4
    Points : 2
    Points
    2

    Par défaut désinstaller ruby

    bonjour je trouve pas comment désinstaller ruby pouvez vous me dire si vous l'avez déjà fait ?
    comment dois-je mis prendre ?
    je dois supprimer les dossiers et fichier manuellement ? ou il y a un désinstalleur avec brew ?

  6. #6
    Modérateur
    Avatar de Marco46
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2005
    Messages
    3 655
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2005
    Messages : 3 655
    Points : 14 302
    Points
    14 302

    Par défaut

    Désolé je n'utilise ni Mac ni Ruby.
    "Toute personne croyant qu'une croissance exponentielle peut durer indéfiniment dans un monde fini est soit un fou, soit un économiste."
    Kenneth E. Boulding

    "Les richesses naturelles sont inépuisables, car, sans cela, nous ne les obtiendrions pas gratuitement. Ne pouvant être ni multipliées ni épuisées, elles ne sont pas l’objet des sciences économiques."
    Jean-Baptiste Say, Traité d'économie politique, 1803.

    "/home/earth is 102% full ... please delete anyone you can."
    Inconnu

  7. #7
    Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    août 2018
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : août 2018
    Messages : 4
    Points : 2
    Points
    2

    Par défaut ruby error config.h

    j'ai donc essayer plusieurs chose que voici :

    xcode-select --install
    xcode-select: error: command line tools are already installed, use "Software Update" to install updates

    xcode-select -v
    xcode-select version 2347.

    j'ai vérifier mon environement :
    gem environment
    RubyGems Environment:
    - RUBYGEMS VERSION: 2.7.8
    - RUBY VERSION: 2.3.7 (2018-03-28 patchlevel 456) [universal.x86_64-darwin16]
    - INSTALLATION DIRECTORY: /Library/Ruby/Gems/2.3.0
    - USER INSTALLATION DIRECTORY: /Users/toto/.gem/ruby/2.3.0
    - RUBY EXECUTABLE: /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby
    - EXECUTABLE DIRECTORY: /usr/bin
    - SPEC CACHE DIRECTORY: /Users/toto/.gem/specs
    - SYSTEM CONFIGURATION DIRECTORY: /Library/Ruby/Site
    - RUBYGEMS PLATFORMS:
    - ruby
    - universal-darwin-16
    - GEM PATHS:
    - /Library/Ruby/Gems/2.3.0
    - /Users/toto/.gem/ruby/2.3.0
    - /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/gems/2.3.0
    - GEM CONFIGURATION:
    - :update_sources => true
    - :verbose => true
    - :backtrace => false
    - :bulk_threshold => 1000
    - REMOTE SOURCES:
    - https://rubygems.org/
    - SHELL PATH:
    - /Users/cminotti/.npm-global/bin
    - /usr/local/bin
    - /usr/bin
    - /bin
    - /usr/sbin
    - /sbin


    j'ai essayer brew install ruby :


    Warning: Bottle installation failed: building from source.
    ==> Downloading https://www.openssl.org/source/openssl-1.0.2p.tar.gz
    Already downloaded: /Users/cminotti/Library/Caches/Homebrew/downloads/6d2f0aa30538560efe2aae756229a9ced40e636a70083696fb1bceb6c1a7564c--openssl-1.0.2p.tar.gz
    /usr/local/Homebrew/Library/Homebrew/utils/fork.rb:49:in `write': Broken pipe (Errno::EPIPE)
    from /usr/local/Homebrew/Library/Homebrew/utils/fork.rb:49:in `puts'
    from /usr/local/Homebrew/Library/Homebrew/utils/fork.rb:49:in `rescue in block (3 levels) in safe_fork'
    from /usr/local/Homebrew/Library/Homebrew/utils/fork.rb:31:in `block (3 levels) in safe_fork'
    from /usr/local/Homebrew/Library/Homebrew/utils/fork.rb:30:in `fork'
    from /usr/local/Homebrew/Library/Homebrew/utils/fork.rb:30:in `block (2 levels) in safe_fork'
    from /usr/local/Homebrew/Library/Homebrew/utils/fork.rb:27:in `open'
    from /usr/local/Homebrew/Library/Homebrew/utils/fork.rb:27:in `block in safe_fork'
    from /usr/local/Homebrew/Library/Homebrew/vendor/portable-ruby/2.3.7/lib/ruby/2.3.0/tmpdir.rb:89:in `mktmpdir'
    from /usr/local/Homebrew/Library/Homebrew/utils/fork.rb:26:in `safe_fork'
    from /usr/local/Homebrew/Library/Homebrew/formula_installer.rb:719:in `build'
    from /usr/local/Homebrew/Library/Homebrew/formula_installer.rb:311:in `install'
    from /usr/local/Homebrew/Library/Homebrew/formula_installer.rb:572:in `install_dependency'
    from /usr/local/Homebrew/Library/Homebrew/formula_installer.rb:534:in `block in install_dependencies'
    from /usr/local/Homebrew/Library/Homebrew/formula_installer.rb:534:in `each'
    from /usr/local/Homebrew/Library/Homebrew/formula_installer.rb:534:in `install_dependencies'
    from /usr/local/Homebrew/Library/Homebrew/formula_installer.rb:251:in `install'
    from /usr/local/Homebrew/Library/Homebrew/cmd/install.rb:321:in `install_formula'
    from /usr/local/Homebrew/Library/Homebrew/cmd/install.rb:253:in `block in install'
    from /usr/local/Homebrew/Library/Homebrew/cmd/install.rb:251:in `each'
    from /usr/local/Homebrew/Library/Homebrew/cmd/install.rb:251:in `install'
    from /usr/local/Homebrew/Library/Homebrew/brew.rb:89:in `<main>'
    Error: An exception occured within a build process:
    Errno::EACCES: Permission denied @ dir_s_mkdir - /usr/local/Cellar/openssl/1.0.2p

    j'essaye de voir du coté de xcode car j'ai l'impression que ça vient de lui ?!!


    j'ai continuer mes recherche voila ce que j'ai fais :

    brew update :

    touch: /usr/local/Homebrew/.git/FETCH_HEAD: Permission denied
    error: cannot open .git/FETCH_HEAD: Permission denied
    /usr/local/Homebrew/Library/Homebrew/cmd/update.sh: line 527: /usr/local/Homebrew/.git/UPDATE_FAILED: Permission denied
    touch: /usr/local/Homebrew/Library/Taps/homebrew/homebrew-core/.git/FETCH_HEAD: Permission denied
    error: cannot open .git/FETCH_HEAD: Permission denied
    /usr/local/Homebrew/Library/Homebrew/cmd/update.sh: line 527: /usr/local/Homebrew/.git/UPDATE_FAILED: Permission denied
    touch: /usr/local/Homebrew/Library/Taps/homebrew/homebrew-php/.git/FETCH_HEAD: Permission denied
    error: cannot open .git/FETCH_HEAD: Permission denied
    /usr/local/Homebrew/Library/Homebrew/cmd/update.sh: line 527: /usr/local/Homebrew/.git/UPDATE_FAILED: Permission denied
    fatal: Unable to create '/usr/local/Homebrew/.git/index.lock': Permission denied
    fatal: Unable to create '/usr/local/Homebrew/.git/index.lock': Permission denied
    Cannot save the current index state
    Error: Could not 'git stash' in /usr/local/Homebrew!
    Please stash/commit manually if you need to keep your changes or, if not, run:
    cd /usr/local/Homebrew
    git reset --hard origin/master
    cd /usr/local/Homebrew
    git reset --hard origin/master
    fatal: Unable to create '/usr/local/Homebrew/.git/index.lock': Permission denied

    bref je suis un peu bloqué si quelqu'un a une idée je suis preneur !!

  8. #8
    Modérateur
    Avatar de Marco46
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2005
    Messages
    3 655
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2005
    Messages : 3 655
    Points : 14 302
    Points
    14 302

    Par défaut

    Tu remarqueras que c'est toujours une erreur de permission.

    Je vais avoir du mal à t'aider je ne connais pas MacOS mais ne peux-tu désinstaller complètement Ruby avant de lancer une installation ?

    Sinon ne peux-tu installer une instance différente de Ruby ailleurs sur ton disque ?

    Je pense que tu devrais ouvrir un sujet dans la partie Apple du forum (dans la bonne section je ne sais pas laquelle il faut) pour demander comment effectuer ces opérations en donnant le lien de cette discussion.
    "Toute personne croyant qu'une croissance exponentielle peut durer indéfiniment dans un monde fini est soit un fou, soit un économiste."
    Kenneth E. Boulding

    "Les richesses naturelles sont inépuisables, car, sans cela, nous ne les obtiendrions pas gratuitement. Ne pouvant être ni multipliées ni épuisées, elles ne sont pas l’objet des sciences économiques."
    Jean-Baptiste Say, Traité d'économie politique, 1803.

    "/home/earth is 102% full ... please delete anyone you can."
    Inconnu

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo