Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Bibliothèques et frameworks PHP Discussion :

[DOM XML] Dom XML sur php5.1


Sujet :

Bibliothèques et frameworks PHP

  1. #1
    Nouveau membre du Club
    [DOM XML] Dom XML sur php5.1
    Salut à tous !!

    Un petit probleme avec le dom xml sous php5.1 (version windows).
    J'ai fait quelque recherche infructueuse sur developpez.com, désolé si j'ai raté quelque chose.

    Quelles sont les extensions à activer dans php 5.1 pour pouvoir profiter de la classe (ainsi que les méthodes appendChild(), etc) ?

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    $dom = new DomDocument();


    J'ai telechargé php_domxml.dll de la pecl, mis dans le repertoire ext, activer l'extension dans php.ini (extension=php_domxml.dll), mais apparement ca ne veut pas fonctionner.

    Je vous donne l'erreur que me donne juste la petite ligne de php au-dessus:

    Warning: domdocument::domdocument() expects at least 1 parameter, 0 given in D:\site\souriez\news.php on line 31
    nb:
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    $dom = new DomDocument('1.0');


    Me renvoit:
    Warning: domdocument::domdocument() [function.domdocument-domdocument]: Entity: line 1: parser error : Start tag expected, '<' not found in D:\site\souriez\news.php on line 31

    Warning: domdocument::domdocument() [function.domdocument-domdocument]: 1.0 in D:\site\souriez\news.php on line 31

    Warning: domdocument::domdocument() [function.domdocument-domdocument]: ^ in D:\site\souriez\news.php on line 31
    Merci de votre aide.

  2. #2
    Membre expert
    Citation Envoyé par Kioo
    Salut à tous !!

    Un petit probleme avec le dom xml sous php5.1 (version windows).
    J'ai fait quelque recherche infructueuse sur developpez.com, désolé si j'ai raté quelque chose.
    Oui mais c'est pas ta faute, c'est parce que le tuto est pas encore publié :
    http://eusebius.developpez.com/php5dom/

    Attention : DOM (PHP5) N'EST PAS DOMXML (PHP4).
    Avec PHP5 tu n'as rien à charger pour utiliser DOM.

  3. #3
    Membre habitué
    Moi j'ai exactement le même problème et je ne comprends pas.
    Je pense que c'est un bug.

    créer juste
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    $dom = new DomDocument();

    ne fonctionne pas et me renvoit la même erreur.

    Si je passe la version en paramètre, j'ai également l'erreur citée par kioo.

    je comprends pas ... c'est un bug connu ? il y a une manière de le résoudre, le contourner ?

    merci d'avance.

  4. #4
    Membre habitué
    Bon en fait j'ai trouvé :p

    Il faut desactiver l'extension "domxml" dans le php.ini, elles ne peuvent apparement pas cohabiter.

  5. #5
    Membre expert
    Citation Envoyé par Sinclair Voir le message
    Moi j'ai exactement le même problème et je ne comprends pas.
    Je pense que c'est un bug.

    créer juste
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    $xslt = new XSLTProcessor();

    ne fonctionne pas et me renvoit la même erreur.

    Si je passe la version en paramètre, j'ai également l'erreur citée par kioo.

    je comprends pas ... c'est un bug connu ? il y a une manière de le résoudre, le contourner ?

    merci d'avance.
    Plutôt que de remonter une conversation vieille d'un an et demi et qui concerne un objet complètement différent, crée-en une nouvelle, en précisant bien ta version de PHP et les erreurs précises que tu obtiens...

    Pour ton erreur je ne connais pas XSLT (d'où l'intérêt de ne pas poster dans une conversation sans lien avec ton problème), mais je te conseille déjà les notes de prérequis et d'installation de la doc : http://fr3.php.net/manual/fr/ref.xsl.php

  6. #6
    Membre habitué
    Mon problème est (enfin était) strictement identique, et la réponse n'avait pas été postée ici. C'est pour ca que j'ai jugé plus opportun d'enrichir ce thread plutot que d'en multiplier sur le même sujet.

    C'est juste de ma faute, j'ai recopié la mauvaise ligne de mon code (j'ai édité), ca ne concerne pas XSLT le problème, mais bien la même erreur sur exactement la même instanciation.

    Merci d'y avoir prêté attention dans tous les cas.