IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Tableaux - Graphiques - Images - Flottants Discussion :

Problème option "page" dans pdfpages


Sujet :

Tableaux - Graphiques - Images - Flottants

  1. #1
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    octobre 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Hauts de Seine (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : octobre 2017
    Messages : 3
    Points : 2
    Points
    2
    Par défaut Problème option "page" dans pdfpages
    Bonjour,
    j'ai récemment eu un soucis avec les packages pdfpages et graphicx.
    Voici mon ECM (je ne peux pas vous glisser le pdf à inclure, mais n'importe quel pdf de plus d'1 page devrait convenir, puisque j'ai essayé avec plusieurs) :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    \documentclass{article}
    \usepackage{graphicx}
    \usepackage{pdfpages}
     
    \begin{document}
    \includegraphics[scale=0.5,page=1]{Criteria.pdf}
    \includepdf[scale=0.5,page=2]{Criteria.pdf}
    \end{document}
    Sur mon PC, j'obtiens le Warning : Option 'page' is unknown to <span style="font-family: monospace; padding: 2px; background: #ddd; display: inline-block"><span style="color: #BE0000">\includepdf</span></span>. Pourtant, lorsque je compile, il affiche effectivement la page 2 si je le lui demande, et la page 1 si je change le numéro.
    Encore, ce problème là n'est pas très grave. Mais lorsque je compile le même ECM sur le PC d'une collègue, elle obtient l'erreur : ! Package keyval Error: page undefined.See the keyval package documentation for explanation.Type H <return> for immediate help.... pour le \includepdf et le \includegraphics et rien y fait, impossible d'effectivement inclure le PDF.

    Qu'est-ce qui pourrait être la cause de ce dysfonctionnement, sachant que toutes les maj ont été effectuées sur le PC de ma collègue ?

    Merci pour vos réponses.

  2. #2
    Responsable LaTeX

    Avatar de -Nikopol-
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2013
    Messages
    2 098
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 46
    Localisation : France, Haute Marne (Champagne Ardenne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2013
    Messages : 2 098
    Points : 11 063
    Points
    11 063
    Billets dans le blog
    5
    Par défaut
    Dans les deux cas évoqués, il faudrait vérifier l’état des mises à jour, et ensuite se demander quelle est la chaine de compilation. Il est préférable d’utiliser pdftex.
    Sinon, sans garantie que je puisse résoudre le problème, poster le fichier log.

  3. #3
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    octobre 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Hauts de Seine (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : octobre 2017
    Messages : 3
    Points : 2
    Points
    2
    Par défaut
    Merci pour cette réponse, et pour le reformatage de mon premier message.

    Après mise à jour de mes packages, j'ai réussi à régler le warning sur mon PC. Je n'ai pas encore pu tester sur celui de ma collègue (nous n'avons pas les droits administrateurs, il faut donc faire appel aux informaticiens). En attendant, son fichier log donne :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    l.10 \includepdf{Criteria.pdf}
    ! Package keyval Error: page undefined.
     
    See the keyval package documentation for explanation.
    Type  H <return>  for immediate help.
    Je vous tiendrai au courant si l'on parvient à résoudre le problème après les mises à jour.

  4. #4
    Rédacteur/Modérateur
    Avatar de Winnt
    Homme Profil pro
    budget et contrôle de gestion
    Inscrit en
    décembre 2006
    Messages
    1 962
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France

    Informations professionnelles :
    Activité : budget et contrôle de gestion
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : décembre 2006
    Messages : 1 962
    Points : 4 097
    Points
    4 097
    Par défaut
    Bonsoir,

    Citation Envoyé par Zarquon
    nous n'avons pas les droits administrateurs
    Dans ce cas vous pouvez vous tourner vers une version portable de TexLive.
    C'est ce que j'utilise à mon travail et je n'ai pas, non plus, les droits administrateurs.
    Winnt
    Merci de lire les règles du forum LaTeX et Qu'est ce qu'un ECM ?.
    N'hésitez pas à parcourir la FAQ la réponse y est peut-être déjà.
    Pensez au bouton si votre problème est résolu.


    C'est en Linuxant qu'on devient .... geek
    Et c'est en LateXant qu'on devient flemmard
    Mon blog tout neuf.
    Articles : présentation de la distribution Gentoo, Les index sous LaTeX et leur personnalisation.

  5. #5
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    octobre 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Hauts de Seine (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : octobre 2017
    Messages : 3
    Points : 2
    Points
    2
    Par défaut
    Le problème a été résolu après mise à jour complète de MiKTeX et des packages.

    Je note néanmoins la possibilité d'utiliser TeXLive.

    Encore merci.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [XL-2007] Problème pour importer page web dans Excel
    Par Allspark dans le forum Excel
    Réponses: 3
    Dernier message: 18/09/2014, 11h23
  2. [itext]problème multi-insertion page pdf dans pdf
    Par DoubleM76 dans le forum Documents
    Réponses: 1
    Dernier message: 20/08/2009, 17h41
  3. problème d'affichage page html dans outlook 2007
    Par Michel 5475 dans le forum Outlook
    Réponses: 1
    Dernier message: 07/07/2008, 23h59

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo