Discussion: SignalR et https

  1. #1
    Candidat au Club
    Homme Profil pro
    Consultant informatique
    Inscrit en
    mai 2013
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2013
    Messages : 8
    Points : 4
    Points
    4

    Par défaut SignalR et https

    Bonjour,

    J'ai une application web anciennement hébergé en http, et je propose des services supplémentaires grâce à une solution C# qui exploite signalr. Je suis passé en https sur le site web pour des raisons de sécurité, je n'arrive pas à inclure de certificat ssl dans la solution C# pour exploiter la couche signalr... Comment utiliser signalr pour un site hébergé en https ?

    Cordialement

  2. #2
    Modérateur
    Avatar de DotNetMatt
    Homme Profil pro
    CTO
    Inscrit en
    février 2010
    Messages
    3 276
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 29
    Localisation : Etats-Unis

    Informations professionnelles :
    Activité : CTO
    Secteur : Finance

    Informations forums :
    Inscription : février 2010
    Messages : 3 276
    Points : 8 702
    Points
    8 702
    Billets dans le blog
    3

    Par défaut

    As-tu binde ton certificat SSL vers l'IPort que tu utilises ? Voir plus d'info ici : Hosting SignalR under SSL/https .
    Less Is More
    Pensez à utiliser les boutons , et les balises code
    Desole pour l'absence d'accents, clavier US oblige

  3. #3
    Candidat au Club
    Homme Profil pro
    Consultant informatique
    Inscrit en
    mai 2013
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2013
    Messages : 8
    Points : 4
    Points
    4

    Par défaut

    Citation Envoyé par DotNetMatt Voir le message
    As-tu binde ton certificat SSL vers l'IPort que tu utilises ? Voir plus d'info ici : Hosting SignalR under SSL/https .
    Bonjour,

    Tout d'abord merci pour votre réponse, je désespère un peu sur le sujet...

    J'ai en effet suivi ce tuto, j'ai une erreur persistante dans la console de chrome : https://localhost:12345/BettyBot/Bet...=1502283471600 net::ERR_INSECURE_RESPONSE

    J'ai executé un netsh http add sslcert ipport=0.0.0.0:12345 appid={12345678-db90-4b66-8b01-88f7af2e36bf} certhash=43ab0570e95f5f7ebf85dca2b7b61c4408be14ea
    Puis netsh http show sslcert ipport=0.0.0.0:12345 me donne en effet un certificat.
    Le certhash a été généré depuis inetmgr


    Je n'ai donc pas d'appel au C# depuis le site web...

    Cordialement

  4. #4
    Modérateur
    Avatar de DotNetMatt
    Homme Profil pro
    CTO
    Inscrit en
    février 2010
    Messages
    3 276
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 29
    Localisation : Etats-Unis

    Informations professionnelles :
    Activité : CTO
    Secteur : Finance

    Informations forums :
    Inscription : février 2010
    Messages : 3 276
    Points : 8 702
    Points
    8 702
    Billets dans le blog
    3

    Par défaut

    Apparemment tu utilises un self-signed certificate. Est-ce qu'il est installe dans ton TrustedStore ?
    Less Is More
    Pensez à utiliser les boutons , et les balises code
    Desole pour l'absence d'accents, clavier US oblige

  5. #5
    Candidat au Club
    Homme Profil pro
    Consultant informatique
    Inscrit en
    mai 2013
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : Consultant informatique
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2013
    Messages : 8
    Points : 4
    Points
    4

    Par défaut

    Citation Envoyé par DotNetMatt Voir le message
    Apparemment tu utilises un self-signed certificate. Est-ce qu'il est installe dans ton TrustedStore ?
    En effet, j'ai fait le drag and drop dans certmgr.msc et toujours rien...
    Lorsque je veux régénérer un certificat et refaire la procédure avec certmgr.msc, je n'ai pas le nouveau certificat dans 'Personnel' .

    Cordialement

Discussions similaires

  1. Problème lié au protocole HTTP.
    Par giviz dans le forum Développement
    Réponses: 2
    Dernier message: 03/10/2003, 17h36
  2. [SSL]Communication avec un serveur en https
    Par menon dans le forum Développement Web en Java
    Réponses: 3
    Dernier message: 04/09/2003, 16h38
  3. [HTTP] Wget-like
    Par tmonjalo dans le forum Développement
    Réponses: 2
    Dernier message: 28/07/2003, 13h39
  4. [HTTP] Syntaxe méthode POST
    Par Gruik dans le forum Développement
    Réponses: 3
    Dernier message: 26/07/2003, 17h12
  5. [web] rapatrier un document via HTTP
    Par ddhia dans le forum Web
    Réponses: 2
    Dernier message: 08/04/2003, 11h01

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo