IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse PHP Discussion :

Installation PHP sur Eclipse Java


Sujet :

Eclipse PHP

  1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    mars 2007
    Messages
    75
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2007
    Messages : 75
    Points : 22
    Points
    22
    Par défaut
    Bonjour,

    Je souhaite installer PHP sur un Eclipse Java dont je me sers pour faire du développement Java.

    Eclipse Java EE IDE for Web Developers.
    Version: Kepler Service Release 1
    Build id: 20130919-0819

    J'ai installé cela:
    PHP Development Tools (PDT) Mylyn Integration 3.1.2.201212211235
    PHP Development Tools (PDT) Source Code 3.1.2.201212211235

    Je peux maintenant créer un projet PHP ou un fichier PHP.

    Je n'arrive pas a exécuter un fichier PHP, j'ai essayé dans la config de mettre un lien vers un EasyPHP mais ça ne fonctionne pas.

    Eclipse m'indique ceci, surtout quand je fais du copier / coller dans du PHP :
    An internal error occurred during: "Open Type Hierarchy action".
    org.eclipse.dltk.ast.ASTNode.end()
    Que faut-il que je fasse de plus pour pouvoir exécuter du PHP avec Eclipse ? Faut-il aussi que j'installe d'autres plugins car il me propose aucune complétion PHP ou autre ?

    Merci d'avance pour votre aide.

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 035
    Points
    17 035
    Par défaut
    Bonjour,

    Si tu n'as pas de contrainte forte nécessitant d'avoir les projets Java et PHP dans la même instance d'Eclipse, je te recommande fortement d'utiliser une installation spécifique d'Eclipse pour PHP.

    Quoi qu'il en soit, les plugins que tu indiques ne sont pas ceux qui sont censés te permettre de développer en PHP.
    Celui avec Mylyn étant un complément PHP pour l'utiliser avec le framework Mylyn, lequel sert à la gestion de tâches et cycles de vie des projets.
    Celui avec "Source Code", contient le code source du plugin PDT, ce qui ne sert strictement à rien si tu n'a pas l'intention de développer des plugins Eclipse pour compléter le plugin PDT...
    Voilà donc tout faut

    Etonnant que tu n'aies obtenu que ça comme proposition de plugin à installer mais ça dépend de comment tu t'y es pris.

    Je pense que le mieux est d'utiliser le Eclipse marketplace. Cf. http://eclipse.developpez.com/faq/?p...stallerPlugin4, tu devrais y trouver ton bonheur.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  3. #3
    Membre éprouvé Avatar de 4sStylZ
    Homme Profil pro
    Null
    Inscrit en
    novembre 2011
    Messages
    307
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ain (Rhône Alpes)

    Informations professionnelles :
    Activité : Null
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2011
    Messages : 307
    Points : 1 010
    Points
    1 010
    Par défaut
    Ce lien a résolu mon problème : http://www.eclipse.org/forums/index.php/t/374334/

    If you are going to install DLTK 4.0 into your Indigo,
    Go to Help > Install New Software
    Add "http://download.eclipse.org/releases/juno"
    Check "Dynamic Languages Toolkit - Core Frameworks" (under General Purpose Tools category)

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. comment installer JFreeChart sur Eclipse
    Par isankem dans le forum 2D
    Réponses: 3
    Dernier message: 23/04/2008, 11h20
  2. Bloqué sur Eclipse Java: "source not found"
    Par EnRadeSurEclipse dans le forum Eclipse Java
    Réponses: 6
    Dernier message: 17/12/2007, 09h16
  3. Erreur 401.5 apres install php sur serveur IIS6.0
    Par sosophie dans le forum IIS
    Réponses: 0
    Dernier message: 28/08/2007, 12h17
  4. installation php sur mandriva impossible
    Par vacknov dans le forum Applications et environnements graphiques
    Réponses: 1
    Dernier message: 08/08/2007, 16h32
  5. Installer PHP sur un serveur Tomcat
    Par yannick24 dans le forum EDI, CMS, Outils, Scripts et API
    Réponses: 1
    Dernier message: 13/12/2005, 09h36

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo