Soutenez-nous
Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Invité de passage
    Inscrit en
    février 2009
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : février 2009
    Messages : 8
    Points : 4
    Points
    4

    Par défaut Creation d'un Document datamart model

    Outils : spagogobi 1.9.4 et Exo prtal

    J'ai crée un datmart.jar ou j'ai uploader avec SpagobiQbeEngin... http://localhost:8080/SpagoBIQbeEngine/ (user/pwd : spagobi/andrea)

    J'arrive à visualiser mon Cube et faire des requetes dessus...

    Mais que je me connecte sur spagobi http://localhost:8080/sbiportal.. et que je veux ajouter mon Document datamart modele... j'ai "Geniric error" et sur ma consol :
    [WARN] JDBCExceptionReporter - SQL Error: -11, SQLState: 37000
    [ERROR] JDBCExceptionReporter - Unexpected token: LAST_INSERT_ID in statement
    [Select last_insert_id()]

    Je ne sais pas ou il cherhce LAST_INSERt_ID???
    Pouvez vous m'aidez si vous avez une idée..... Merci d'avance.

    je me connecte bien à ma base avec une LOV et je visualise mon cube sous l'adresse http://localhost:8080/SpagoBIQbeEngi...et/AdapterHTTP

    Voici en gros mes étape ... spagobi charge le jar datamart.jar dans exo-portal-1.1.4\webapps\SpagoBIQbeEngine\tmp\datamarts\mysqlmart
    J'ai crée dans le meme repertoir un fichier formula.xml et un fichier Template :
    <QBE>
    <DATASOURCE name="mysqlDataSource" dialect="org.hibernate.dialect.MYSQLDialect" />

    <DATAMART name="mysqlmart"/>
    <FUNCTIONALITIES>
    <FUNCTIONALITY name="expertQuery">
    <PARAMETER name="editable" value="TRUE"/>
    </FUNCTIONALITY>
    </FUNCTIONALITIES>

    </QBE>

    J'ai pas mal configurer des fichiers xml dans spagobi et surtout dans data_acces de QBEEngine :
    <CONNECTION name="mysqlDataSource" jndiResourceName="jdbc/mysqlmart" jndiContext="java:comp/env" />

    Je ne pense pas que c'est un probleme de connexion car j'arrive visualiser le cube autrement...

    Faut il passer par d'autre étapes avant ou quoi???


  2. #2
    Invité de passage
    Inscrit en
    février 2009
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : février 2009
    Messages : 8
    Points : 4
    Points
    4

    Par défaut Est ce un probleme de dialect

    Est ce que c'est un probleme de dialect mysql ?

  3. #3
    Invité de passage
    Inscrit en
    février 2009
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : février 2009
    Messages : 8
    Points : 4
    Points
    4

    Par défaut Aucune aidées

    Personne n'as une idée d'où vient ce problème !!!!

  4. #4
    Invité de passage
    Inscrit en
    février 2009
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : février 2009
    Messages : 8
    Points : 4
    Points
    4

    Par défaut Trouvée

    Bonjour,

    Après deux jours de casse tête... le probleme vient du fait que spagobi essaie d'inserer dans la base spagobi... celle ci etant en hsql alors que j'ai chargé un cube mysql ()... donc la recherche JDBC de last_insert_id() echoue car la base spagobi n'est pas mysql.... donc la solution est d'utiliser un seul moteur sjbd... Mysql dans mon cas... alors ce matin j'ai modifié le script spagobi.script sous sbidata\database en mysql ça prend un peut de temps mais bon...

    et aprés tt marche parceque l'insertion dans la base spagobi marche (c pourquoi il cherche le dernier element inseré) pour modifier des table interne à spagobi.

    J'espere que ça aide quelqu'un....


    Je peux passer à l'étape suivante ....

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •