p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Invité de passage
    Inscrit en
    mars 2010
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : mars 2010
    Messages : 8
    Points : 0
    Points
    0

    Par défaut Exécution en continue au démarrage

    Bonjour,
    Je cherche à créer un .exe de mon vi où dès le démarrage il se passe la même chose que lorsque j'appuie sur le bouton "exécution continue" de mon projet.
    Je débute sous LabView et je ne sais pas si c'est une option comme "éxecuter au démarrage" dans les paramètres du vi ou s'il faut le programmer avec une boucle.
    J'ai essayé une boucle While contenant mon code, mais j'ai des blocs qui affichent des erreurs alors que tout se passe bien en exécution continue "classique".

    Merci d'avance,

    Marvin

  2. #2
    Membre confirmé Avatar de eaglewatch
    Homme Profil pro
    Doctorant
    Inscrit en
    avril 2009
    Messages
    191
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Doctorant

    Informations forums :
    Inscription : avril 2009
    Messages : 191
    Points : 233
    Points
    233

    Par défaut

    Salut Timay,
    Donc, comme tu le dis, oui tu dois utiliser une boucle while cadancée (utiliser une tempo pour que ton programme ne sature pas le processeur).

    Si tu veux qu'on regarde plus en detail, poste ton VI (en Labview 10.0 ou version antérieure). Pour le poster tu vas devoir le compresser (.zip ou .rar).

    A+
    Windows 7 Pro 64bits
    LabVIEW 2010 SP1 32bits / 2010 64bits
    LabVIEW 2012 SP1 32bits / 2012 64bits


    "Gott würfelt nicht"- Albert Einstein

  3. #3
    Membre habitué Avatar de Mat32
    Inscrit en
    août 2009
    Messages
    243
    Détails du profil
    Informations forums :
    Inscription : août 2009
    Messages : 243
    Points : 109
    Points
    109

    Par défaut

    J'ai essayé une boucle While contenant mon code, mais j'ai des blocs qui affichent des erreurs alors que tout se passe bien en exécution continue "classique"
    Il faut que tu testes et que "tout se passe bien", comme tu dis, en exécution normal et pas en exécution continu dans ton projet...

    Mais sans le code c'est difficile de t'aider
    Devise Shadoks : Il vaut mieux pomper d'arrache pied même s'il ne se passe rien que de risquer qu'il se passe quelque chose de pire en ne pompant pas

Discussions similaires

  1. [Débutant]Exécuter du code au démarrage
    Par ProgVal dans le forum Outils pour C & C++
    Réponses: 1
    Dernier message: 29/12/2007, 13h27
  2. Réponses: 3
    Dernier message: 03/05/2007, 12h44
  3. [Jboss] Exécution de code au démarrage
    Par ebaynaud dans le forum JBoss
    Réponses: 3
    Dernier message: 28/04/2007, 21h24
  4. Réponses: 2
    Dernier message: 07/03/2007, 12h02
  5. Réponses: 2
    Dernier message: 18/12/2006, 15h09

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo