Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 8 sur 8
  1. #1
    Membre Expert

    Homme Profil pro John Doe
    Développeur .NET
    Inscrit en
    novembre 2010
    Messages
    1 113
    Détails du profil
    Informations personnelles :
    Nom : Homme John Doe
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : novembre 2010
    Messages : 1 113
    Points : 1 999
    Points
    1 999

    Par défaut Empêcher le téléchargement de fichiers suivant les droits

    Bonjour,

    j'ai un dossier Logiciels sur mon site web et je voudrais donner les droits de téléchargement de fichier dans ce répertoire à un seul rôle.
    J'ai donc configuré comme ceci mon web.config
    Code :
    1
    2
    3
    4
    5
    6
    7
     
    <location path="Logiciels">
    <system.web>
    <authorization>
      <allow roles="Amis"/>
      <deny users="*"/>
    </authorization>
    mais je peux toujours télécharger sans être connecté.

    si quelqu'un a une idée je suis preneur merci.

  2. #2
    Membre Expert Avatar de bossun
    Profil pro
    Inscrit en
    novembre 2002
    Messages
    1 347
    Détails du profil
    Informations personnelles :
    Âge : 31
    Localisation : Suisse

    Informations forums :
    Inscription : novembre 2002
    Messages : 1 347
    Points : 1 374
    Points
    1 374

    Par défaut

    Poste nous ton web.config

    Essaie d'utiliser ça dans cet ordre car je crois qu'il a son importance :

    Code :
    1
    2
    <deny users="*"/>
    <allow roles="Amis"/>
    il vaut mieux prendre son pied que de se prendre la tête!!

    http://bossun.noxblog.com

  3. #3
    Membre Expert

    Homme Profil pro John Doe
    Développeur .NET
    Inscrit en
    novembre 2010
    Messages
    1 113
    Détails du profil
    Informations personnelles :
    Nom : Homme John Doe
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : novembre 2010
    Messages : 1 113
    Points : 1 999
    Points
    1 999

    Par défaut

    malheureusement ça ne change rien

  4. #4
    Membre Expert Avatar de bossun
    Profil pro
    Inscrit en
    novembre 2002
    Messages
    1 347
    Détails du profil
    Informations personnelles :
    Âge : 31
    Localisation : Suisse

    Informations forums :
    Inscription : novembre 2002
    Messages : 1 347
    Points : 1 374
    Points
    1 374

    Par défaut

    Poste ton web.config pour voir ce que tu as mis dedans?
    il vaut mieux prendre son pied que de se prendre la tête!!

    http://bossun.noxblog.com

  5. #5
    Rédacteur

    Avatar de Louis-Guillaume Morand
    Homme Profil pro Louis-Guillaume MORAND
    Consultant
    Inscrit en
    mars 2003
    Messages
    10 840
    Détails du profil
    Informations personnelles :
    Nom : Homme Louis-Guillaume MORAND
    Localisation : France, Hauts de Seine (Île de France)

    Informations professionnelles :
    Activité : Consultant
    Secteur : Conseil

    Informations forums :
    Inscription : mars 2003
    Messages : 10 840
    Points : 25 117
    Points
    25 117

    Par défaut

    Citation Envoyé par bossun Voir le message
    Poste nous ton web.config

    Essaie d'utiliser ça dans cet ordre car je crois qu'il a son importance :

    Code :
    1
    2
    <deny users="*"/>
    <allow roles="Amis"/>
    de cette façon, tu bloquerais tout le monde, y compris le role amis... ;-)
    Faut imaginer chaque regle comme une porte, si elle elle renvoie true, alors elle s'applique
    1- est-ce que je fais partie des users * => oui => j'ai un accès refusé
    2- ca va pas plus loin

    dans l'autre sens, le bon du depart du thread
    1- est-ce que je suis role amis => oui => je rentre
    => non => regle abortée, je teste la regle suivante
    2- est-ce que je fais partie de "*" => oui => access denied


    ensuite, là, rien ne semble s'appliquer. soit le fichier web.config n'est pas le bon (ou mal placé, pas à la racine du site par exemple). Soit la config est mal positionnée dans le fichier web.config
    moi c'est Louis-Guillaume, ni Louis, ni Guillaume mais Louis-Guillaume et je n'aide pas ceux qui écorchent mon nom

  6. #6
    Membre Expert

    Homme Profil pro John Doe
    Développeur .NET
    Inscrit en
    novembre 2010
    Messages
    1 113
    Détails du profil
    Informations personnelles :
    Nom : Homme John Doe
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : novembre 2010
    Messages : 1 113
    Points : 1 999
    Points
    1 999

    Par défaut

    voici mon webconfig, oui peut être je l'ai mal positionné
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    91
    92
    93
    94
    95
    96
    97
    98
    99
    100
    101
    102
    103
    104
    105
    106
    107
    108
    109
    110
    111
    112
    113
    114
    115
    116
    117
    118
    119
    120
    121
    122
    123
    124
    125
    126
    127
    128
    <?xml version="1.0"?>
    <configuration>
     
      <configSections>
        <section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" requirePermission="false"/>
      </configSections>
     
      <location path="Logiciels" >
        <system.web>
          <authorization>
            <allow roles="amis"/>
            <deny users="*" />
          </authorization>
        </system.web>
      </location>
     
      <connectionStrings>
        <clear/>
        <remove name="LocalSqlServer" />
        <add name="LocalSqlServer" connectionString="*" />
      </connectionStrings>
     
      <appSettings configSource="app.config"/>
     
      <rewriter configSource="URLRewriter.config"/>
     
      <system.net>
        <mailSettings>
          <smtp>
            <network host="mail.ikoula.fr" port="25"/>
          </smtp>
        </mailSettings>
      </system.net>
     
      <system.web>
        <httpRuntime requestValidationMode="2.0" enableVersionHeader="false" useFullyQualifiedRedirectUrl="true" maxRequestLength="16384" executionTimeout="3600" requestLengthDiskThreshold="16384" />
        <globalization culture="fr-FR" uiCulture="fr" requestEncoding="UTF-8" responseEncoding="UTF-8" fileEncoding="UTF-8"/>
        <!--<globalization culture="en-US" uiCulture="en"  fileEncoding="iso-8859-1" requestEncoding="iso-8859-1" responseEncoding="iso-8859-1"/>-->
        <authentication mode="Forms">
          <forms name=".YAFNET_Authentication" protection="All" timeout="43200" cookieless="UseCookies"/>
        </authentication>
     
        <customErrors mode="RemoteOnly" defaultRedirect="Forum/error.aspx"/>
     
        <!-- Set debug to "true" to test out the system in development -->
        <compilation debug="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add assembly="System.Data.DataSetExtensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Xml.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
            <add assembly="System.ServiceModel.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
            <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
          </assemblies>
        </compilation>
        <httpHandlers>
          <add verb="GET" path="Resource.ashx" type="YAF.YafResourceHandler, YAF"/>
        </httpHandlers>
        <httpModules>
          <add name="YafTaskModule" type="YAF.Core.YafTaskModule, YAF.Core"/>
          <add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter"/>
        </httpModules>
        <pages theme="ThemePrincipal"  maintainScrollPositionOnPostBack="true" controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID" enableEventValidation="false" validateRequest="false">
          <controls>
            <!-- Default: use non-dynamic (compiled classes) in YAF -->
            <add tagPrefix="YAF" namespace="YAF.Controls" assembly="YAF.Controls"/>
            <add tagPrefix="YAF" namespace="YAF.Controls.Statistics" assembly="YAF.Controls"/>
            <add tagPrefix="YAF" namespace="YAF.Classes"/>
            <add tagPrefix="YAF" namespace="YAF"/>
          </controls>
          <namespaces>
            <add namespace="YAF.Core"/>
            <add namespace="YAF.Controls"/>
            <add namespace="YAF.Utils"/>
            <add namespace="YAF.Types.Interfaces"/>
            <add namespace="YAF.Types"/>
          </namespaces>
        </pages>
        <membership defaultProvider="YafMembershipProvider" hashAlgorithmType="SHA1">
          <providers>
            <clear/>
            <!-- YAF's ASP.NET Membership Provider is designed to work a bit better with YAF.NET options, but is by no means required.
                 But, you will not be able to switch providers after installing your forum. -->
            <add name="YafMembershipProvider" applicationName="YetAnotherForum" connectionStringName="LocalSqlServer" requiresUniqueEmail="true" useSalt="true" type="YAF.Providers.Membership.YafMembershipProvider"/>
            <!-- Set as default if you want to use use the built-in ASP.NET membership provider. Password Type of "Encrypted" requires a machine key. -->
            <add name="AspNetSqlMembershipProvider" applicationName="YetAnotherForum" connectionStringName="LocalSqlServer" enablePasswordReset="false" enablePasswordRetrieval="true" maxInvalidPasswordAttempts="5" minRequiredNonalphanumericCharacters="0" minRequiredPasswordLength="5" passwordAttemptWindow="15" passwordFormat="Encrypted" requiresQuestionAndAnswer="false" requiresUniqueEmail="true" type="System.Web.Security.SqlMembershipProvider"/>
          </providers>
        </membership>
        <roleManager enabled="true" defaultProvider="YafRoleProvider">
          <providers>
            <clear/>
            <!-- YAF's ASP.NET Role Provider is designed to work a bit better with YAF.NET options, but is by no means required.
                 But, you will not be able to switch providers after installing your forum. -->
            <add name="YafRoleProvider" applicationName="YetAnotherForum" connectionStringName="LocalSqlServer" type="YAF.Providers.Roles.YafRoleProvider"/>
            <!-- Set as default if you want to use use the built-in ASP.NET role provider. -->
            <add name="AspNetSqlRoleProvider" applicationName="YetAnotherForum" connectionStringName="LocalSqlServer" type="System.Web.Security.SqlRoleProvider"/>
          </providers>
        </roleManager>
        <profile enabled="true" defaultProvider="YafProfileProvider" inherits="YAF.Utils.YafUserProfile">
          <providers>
            <clear/>
            <!-- YAF's ASP.NET Profile Provider is designed to work a bit better with YAF.NET options, but is by no means required.
                 But, you will not be able to switch providers after installing your forum. -->
            <add name="YafProfileProvider" applicationName="YetAnotherForum" connectionStringName="LocalSqlServer" type="YAF.Providers.Profile.YafProfileProvider"/>
            <!-- Set as default if you want to use use the built-in ASP.NET profile provider. -->
            <add name="AspNetSqlProfileProvider" applicationName="YetAnotherForum" connectionStringName="LocalSqlServer" type="System.Web.Profile.SqlProfileProvider"/>
          </providers>
        </profile>
        <!--  Enable it if your application is hosted in a web farm or cluster (e.g. GoDaddy hosting) or you are using standard ASP.NET providers and encryption. 
              IMPORTANT: DO NOT USE THIS KEY! You need to generate your own machine key (google it).
        -->
        <machineKey validationKey="*" decryptionKey="*" validation="SHA1" decryption="AES"/>
      </system.web>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false"/>
        <modules>
          <remove name="YafTaskModule"/>
          <remove name="UrlRewriter"/>
          <add name="YafTaskModule" type="YAF.Core.YafTaskModule, YAF.Core" preCondition="managedHandler"/>
          <add name="UrlRewriter" type="Intelligencia.UrlRewriter.RewriterHttpModule,Intelligencia.UrlRewriter" preCondition="managedHandler"/>
        </modules>
        <handlers>
          <add name="YafHandler" preCondition="integratedMode" verb="GET" path="Resource.ashx" type="YAF.YafResourceHandler, YAF"/>
        </handlers>
      </system.webServer>
    </configuration>

  7. #7
    Membre Expert

    Homme Profil pro John Doe
    Développeur .NET
    Inscrit en
    novembre 2010
    Messages
    1 113
    Détails du profil
    Informations personnelles :
    Nom : Homme John Doe
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : novembre 2010
    Messages : 1 113
    Points : 1 999
    Points
    1 999

    Par défaut

    Aucune idée ?

  8. #8
    Membre Expert

    Homme Profil pro John Doe
    Développeur .NET
    Inscrit en
    novembre 2010
    Messages
    1 113
    Détails du profil
    Informations personnelles :
    Nom : Homme John Doe
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : novembre 2010
    Messages : 1 113
    Points : 1 999
    Points
    1 999

    Par défaut

    c'est toujours d'actualité

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •