Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2
  1. #1
    Invité de passage
    Inscrit en
    février 2007
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : février 2007
    Messages : 5
    Points : 1
    Points
    1

    Par défaut problème cgi sur mon serveur

    Bonjour a tous et à toutes.
    Je suis un nouvel utilisateur de serveurs et de perl.
    Je rencontre un gros soucis. que je trouve insurmontable et j'espère que je vais trouvé de l'aide.
    Voila j'ai installé mon serveur en Debian 6 et ispconfig 3 (qui gère, a ce que je peux lire sur les caractéristiques du logiciel, tout ce dont j'ai besoin)
    J'ai donc installé mon script sur mon site sur mon serveur.
    donc j'ai bien passé les données en ASCII et mis les droits en 755 sur les fichiers cgi instrallé dans le répertoire cgi-bin.
    Malheureusement quand je fais le test sur un fichier .cgi, le serveur me répond error 404. le fichier n'est pas la... alors que j'ai bien vérifié il est bien présent.
    Je pense que c'est un problème de configuration de mon site pour l'utilisation du perl.
    voici donc les options que j'ai pour configurer ce dernier :
    J'ai les options suivantes (a cocher)
    () CGI
    () SSI
    () Ruby
    () SuEXEC
    () SSL

    et j'ai un menu déroulant nommé PHP ou je peux chosir une des options suivantes :
    - disabled
    - Fast-CGI
    - CGI
    - ModPHP
    - SuPHP

    J'ai essayé toutes les variantes possible et imaginable et rien ne se fait.
    Je ne vois plus ce qu'il faut faire.
    Est-ce que quelqu'un peu m'aider svpl.
    Merci d'avance.
    Stef

  2. #2
    Membre actif
    Homme Profil pro Michel
    Inscrit en
    juillet 2009
    Messages
    164
    Détails du profil
    Informations personnelles :
    Nom : Homme Michel
    Âge : 70
    Localisation : France

    Informations forums :
    Inscription : juillet 2009
    Messages : 164
    Points : 187
    Points
    187

    Par défaut

    Bonjour,
    À mon avis, il vaudrait mieux poser la question sur le forum Web
    Cela dit, quel est le serveur : Apache ?
    Cordialement,
    nibroc

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •