Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 10 sur 10
  1. #1
    Invité de passage
    Inscrit en
    janvier 2006
    Messages
    25
    Détails du profil
    Informations forums :
    Inscription : janvier 2006
    Messages : 25
    Points : 3
    Points
    3

    Par défaut Image dans newsletter

    Bonjour,
    Je suis sous "spip" hébergé chez "OVH" avec un module "PhpMyNewsletters" pour le configurer je souhaite y insérer une image entête du site, j'ai suivi les explications de cette discution,
    http://www.developpez.net/forums/d11...s/#post6213652
    J'ai casé l'image en question dans le dossier "IMG" qui est à la racine du site et si j'ai bien compris, l'adresse est:
    <td style="background url('http://www.monsite.net/IMG/bandeau.jpg/header.jpg') no-repeat; height:170px; width:620px;">
    Hé bé, ça donne rien, sur la lettre on ne voit apparaître que le script.
    Merci de votre aide

  2. #2
    Membre éclairé Avatar de Inazo
    Profil pro
    Gérant - société de développement web
    Inscrit en
    avril 2007
    Messages
    307
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Gérant - société de développement web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : avril 2007
    Messages : 307
    Points : 363
    Points
    363

    Par défaut

    Bonjour,

    Tu as une coquille dans ton code HTML pour commencer :

    remplace ceci :
    Code :
    <td style="background url('http://www.monsite.net/IMG/bandeau.jpg/header.jpg') no-repeat; height:170px; width:620px;">
    Par cela :
    Code :
    <td style="background: url('http://www.monsite.net/IMG/bandeau.jpg/header.jpg') no-repeat; height:170px; width:620px;">
    Ensuite quand tu dit :

    on ne voit apparaître que le script.
    Je ne suis pas sur d'avoir compris en fait... Tu voie le code HTML dans la newsletter ?

    Cordialement,

  3. #3
    Invité de passage
    Inscrit en
    janvier 2006
    Messages
    25
    Détails du profil
    Informations forums :
    Inscription : janvier 2006
    Messages : 25
    Points : 3
    Points
    3

    Par défaut

    Bonjour,
    J'ai bien fais comme indiqué:
    <td style="background: url('http://www.monsite.net/IMG/bandeau.jpg/header.jpg') no-repeat; height:170px; width:620px;">
    "monsite" étant le nom du site, à la visualisation on ne voit pas l'image et à l'envoi, idem, désolé ça ne marche toujours pas

  4. #4
    Membre éclairé Avatar de Inazo
    Profil pro
    Gérant - société de développement web
    Inscrit en
    avril 2007
    Messages
    307
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Gérant - société de développement web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : avril 2007
    Messages : 307
    Points : 363
    Points
    363

    Par défaut

    Bonjour,

    Je viens juste de voir :

    Code :
    http://www.monsite.net/IMG/bandeau.jpg/header.jpg
    Vous demandez l'affichage de l'image header.jpg dans le répertoire bandeau.jpg je pense que là vous avez une coquille

    Cordialement,

  5. #5
    Invité de passage
    Inscrit en
    janvier 2006
    Messages
    25
    Détails du profil
    Informations forums :
    Inscription : janvier 2006
    Messages : 25
    Points : 3
    Points
    3

    Par défaut

    J'ai corrigé en supprimant "header.jpg" alors il est vrai que si j'appelle "www.monsite.net/IMG/bandeau.jpg" je vois le bandeau qui apparaît, mais rien dans la newsletters

  6. #6
    Membre éclairé Avatar de Inazo
    Profil pro
    Gérant - société de développement web
    Inscrit en
    avril 2007
    Messages
    307
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Gérant - société de développement web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : avril 2007
    Messages : 307
    Points : 363
    Points
    363

    Par défaut

    C'est possible de nous donner une capture d'écran du résultat de la newsletter ?

    Cordialement,

  7. #7
    Invité de passage
    Inscrit en
    janvier 2006
    Messages
    25
    Détails du profil
    Informations forums :
    Inscription : janvier 2006
    Messages : 25
    Points : 3
    Points
    3

    Par défaut

    Désolé pour le retard de ma réponse, je suis parti quelques jours, j'ai créé une nouvelle lettre, pour l'image j'ai insérée:
    <td style="background url('http://www.maiquez.net/IMG/bandeau.jpg') no-repeat; height:170px; width:620px;">
    et pour la copie écran de la visualisation du message:
    http://www.maiquez.net/squelettes/im...re_message.png
    Et voilà ce qui devrait apparaître:
    http://www.maiquez.net/IMG/bandeau.jpg
    Excuses moi encore pour mon retard, et merci

  8. #8
    Membre émérite

    Inscrit en
    juin 2007
    Messages
    672
    Détails du profil
    Informations forums :
    Inscription : juin 2007
    Messages : 672
    Points : 825
    Points
    825

    Par défaut

    Code :
    <td style="background url('http://www.maiquez.net/IMG/bandeau.jpg') no-repeat; height:170px; width:620px;">
    ne fonctionne pas avec tous les logiciels emails...
    faire comme ca :

    Code :
    <td><img src = 'http://www.maiquez.net/IMG/bandeau.jpg' alt=' ' /></td>
    Conception / Dev

  9. #9
    Invité de passage
    Inscrit en
    janvier 2006
    Messages
    25
    Détails du profil
    Informations forums :
    Inscription : janvier 2006
    Messages : 25
    Points : 3
    Points
    3

    Par défaut

    Bonjour,
    Merci,
    pour l'image ça marche, le seul problème c'est le pied de page ou j'indique de ne pas répondre à ce mail mais plutôt (adresse électronique) au lieu de se retrouver en bas du mail il se colle à la suite de l'article

  10. #10
    Invité de passage
    Inscrit en
    janvier 2006
    Messages
    25
    Détails du profil
    Informations forums :
    Inscription : janvier 2006
    Messages : 25
    Points : 3
    Points
    3

    Par défaut

    C'est bon pour le pied de page, dans la création de la lettre j'ai ajouté <br /> je ne sais pas si c'est bien propre enfin y a pas de raisons, maintenant je cherche le moyen de mettre le contenu du pied de page en rouge
    Merci

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •