Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 2 sur 2

Discussion: Installation php oci8

  1. #1
    Membre habitué
    Femme Profil pro Chris
    Développeur Web
    Inscrit en
    mai 2010
    Messages
    245
    Détails du profil
    Informations personnelles :
    Nom : Femme Chris
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : mai 2010
    Messages : 245
    Points : 113
    Points
    113

    Par défaut Installation php oci8

    Bonjour,
    Suite à la mise en place d'un nouveau serveur; ou oracle avait été installer; j'ai installé php avec yum mais oci8 n'a pas été pris en compte :
    voici phpinfo():
    Code :
    1
    2
     
    ./configure' '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--with-kerberos' '--enable-ucd-snmp-hack' '--enable-shmop' '--enable-calendar' '--without-sqlite' '--with-libxml-dir=/usr' '--enable-xml' '--with-system-tzdata' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter' '--without-sqlite3' '--disable-phar' '--disable-fileinfo' '--disable-json' '--without-pspell' '--disable-wddx' '--without-curl' '--disable-posix' '--disable-sysvmsg' '--disable-sysvshm' '--disable-sysvsem'
    Donc j'ai télécharge oci8 pour l'installer en utilisant phpize,make,make install. A la fin il n'y a pas d'erreur.
    J'ai modifié php.ini pour l'extension=oci8 et redemarrer apache. Mais quand je regarde dans les logs d'apache j'ai cette erreur:
    Code :
    1
    2
    3
    4
    5
    6
    7
    [Tue May 29 12:01:36 2012] [notice] caught SIGTERM, shutting down
    [Tue May 29 12:01:36 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Tue May 29 12:01:36 2012] [notice] Digest: generating secret for digest authentication ...
    [Tue May 29 12:01:36 2012] [notice] Digest: done
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/oci8.so' - /usr/lib64/php/modules/oci8.so: undefined symbol: zend_new_interned_string in Unknown on line 0
    [Tue May 29 12:01:36 2012] [notice] Apache/2.2.15 (Unix) DAV/2 PHP/5.3.3 configured -- resuming normal operations
    oci8.so est bien dans le dossier /usr/lib64/php/modules.
    Je ne comprend pas l'erreur.

    Merci d'avance pour toutes informations.

    Chris.

  2. #2
    Invité régulier
    Homme Profil pro Carlos Sharonstaine
    Étudiant
    Inscrit en
    septembre 2011
    Messages
    12
    Détails du profil
    Informations personnelles :
    Nom : Homme Carlos Sharonstaine
    Localisation : Cameroun

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2011
    Messages : 12
    Points : 8
    Points
    8

    Par défaut

    Slt chris,
    le problème que tu poses est celui que je vis.
    Si tu as une breche de solution, priere de m'en faire part

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •