p
u
b
l
i
c
i
t
é
publicité
  1. #1
    Invité de passage
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Service public

    Informations forums :
    Inscription : mai 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut Liste déroulante vide

    Bonjour à tous,

    Je souhaite faire un formulaire php qui se connecte à une base Postgresql.
    J'ai créer une liste déroulante mais rien ne s'affiche. En plus, je n'ai aucun message d'erreur.

    Voilà mon code:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    <form name="frm" method="post" action="./page_travaux.php">
    	Sélectionnez une commune<select name="zl_commune">
    				<option value="0">Toutes</option>
     
    <?php
     
    include('./inclusion/connect.inc');
    $idc=connect();
     
    $sql='select num_commune, nom_commune from commune order by commune';
    $rs=pg_exec($idc,$sql);
    while ($lg=pg_fetch_assoc($rs))
    	{
    		print('<option value="'.$lg['num_commune'].'">'.$lg['nom_commune'].'</option>');
     
    	}
    ?>
    							</select><br />	
     
    </form>	
     
    Concernant la connection à la base, voici ce que j'ai fait:
     
    <?php
     
    function connect()
     
    {
    	$idc=pg_connect('user=postgres password=postgres dbname=reseau host=localhost port=5432');
    	return($idc);
    }
     
    ?>
    J'utilise postgresql 9.0 et easyphp 5.3.8

    Cordialement

  2. #2
    Invité de passage
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Service public

    Informations forums :
    Inscription : mai 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut résolu

    Problème résolu, j'avais confondu l'extension de mes pages.

Discussions similaires

  1. Liste déroulante vide
    Par fgaiga dans le forum IHM
    Réponses: 12
    Dernier message: 02/10/2007, 14h03
  2. Réponses: 14
    Dernier message: 21/06/2007, 13h55
  3. Réponses: 2
    Dernier message: 27/07/2006, 20h03
  4. liste déroulante vide
    Par boulette85 dans le forum ASP
    Réponses: 2
    Dernier message: 03/07/2006, 09h07
  5. liste déroulante vide
    Par gwendk dans le forum Access
    Réponses: 4
    Dernier message: 24/04/2006, 09h28

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo